Jump to content

  •  

UPGRADE DEADLINE - SEPTEMBER 26, 2014!
FileMaker Inc. has a deadline for users of version 10,11, 12 as Individual box or volume licenses (with expired maintenance).
If you don't renew your maintenance and upgrade to FMP 13 you will no longer be eligible to upgrade, at the discount pricing.

Volume Licensing upgrade pricing for FileMaker Pro 13, FileMaker Pro 13 Advanced and FileMaker Server 13 will be discontinued.
Individual upgrade pricing for FileMaker Pro 13 and FileMaker Pro 13 Advanced will increase after September 26, 2014.
As of 27-September-2014, FileMaker 10 products will no longer be available for purchase or support.

http://help.filemaker.com/app/answers/detail/a_id/13865


Photo

I need REAL help

FM8

  • Please log in to reply
6 replies to this topic

#1 WilliamG  newbie

WilliamG
  • Members
  • 8 posts
  • FM Application:11
  • Platform:Mac OS X Leopard
  • Skill Level:Novice
  • Time Online: 3h 33m 15s

Posted 09 April 2008 - 05:18 PM

Hello; I'm new here but not to Filemaker. I started using FM with the first version when Nashoba owned it. My first problem, and this has existed since version 5, is that the serial number will not advance. I use this feature for invoicing (thank God I am the only employee) and starting with version 5 it became erratic and finally I had to increment it manually. I have been through exporting the data and rebuilding the file and importing the data again and no luck. I just don't know why it doesn't work and no one else seems to either. I contacted Filemaker back when it was Claris, and you could talk to someone without mortgaging your house, and they tried but couln't help either. I was really hopeful that when I installed 8.5 my problem might go away. Anyone have a clue? I have searched everywhere for an answer. Thanks, Bill
  • 0

#2 Lee Smith  I like the v13 layout tools

Lee Smith
  • Staff
  • 10,153 posts
  • FM Application:13 Advance
  • FMGo:iPhone / iPod Touch
  • Platform:Mac OS X Mavericks
  • Skill Level:Expert
  • Membership:TechNet
  • Time Online: 229d 9h 41m 52s

Posted 09 April 2008 - 05:42 PM

Hi William, welcome to the Forum.

Since you seem to know how it should work, why don't you attache a copy of your file so we can check it out for you.

To attach a file, just make a reply to this Thread, and use the
File Attachments: Manage files
below.

Remove any confidential information by either saving a Clone, no records, or copy and delete the confidential information.
Zip the File
and then attach it.

Lee
  • 0

#3 WilliamG  newbie

WilliamG
  • Members
  • 8 posts
  • FM Application:11
  • Platform:Mac OS X Leopard
  • Skill Level:Novice
  • Time Online: 3h 33m 15s

Posted 13 April 2008 - 05:22 PM

Thank you Lee for the response, sorry for the delay but I think this is what you asked for. The file is attached, Bill.

Attached Files


  • 0

#4 The Shadow  veteran

The Shadow
  • Members
  • 773 posts
  • FM Application:10 Advance
  • Time Online: 36m 10s

Posted 13 April 2008 - 06:30 PM

The Invoice# seems to update for me when a new record is created, was that the field causing you trouble? Did you try to reproduce the problem in the empty file you attached?
  • 0
The Shadow Knows...

#5 WilliamG  newbie

WilliamG
  • Members
  • 8 posts
  • FM Application:11
  • Platform:Mac OS X Leopard
  • Skill Level:Novice
  • Time Online: 3h 33m 15s

Posted 14 April 2008 - 08:37 AM

Yes that is the correct field, yes I did try and it does but the problem is when I import from "Quotes". Quotes is a layout that I use for telephone parts price requests. Some customers prepay their orders so the quote stays open until I receive payment. If after a set period of time the customer does not send in a payment then the quote is deleted. When a payment is received the quote is imported into invoices and a new number is supposed to be generated. The problem is the number never changes it just assigns the same number over and over, although I have caught it once in awhile advancing to the next number but very erratically. Thanks, Bill
  • 0

#6 The Shadow  veteran

The Shadow
  • Members
  • 773 posts
  • FM Application:10 Advance
  • Time Online: 36m 10s

Posted 14 April 2008 - 02:54 PM

Well, your script for importing replaces the serial numbers for the imported records as its last step with new ones, could that be the cause of your troubles?
  • 0
The Shadow Knows...

#7 WilliamG  newbie

WilliamG
  • Members
  • 8 posts
  • FM Application:11
  • Platform:Mac OS X Leopard
  • Skill Level:Novice
  • Time Online: 3h 33m 15s

Posted 14 April 2008 - 04:11 PM

Thanks for the reply, I don't think so because the record(s) have no number when imported and the script is set to start at the last number incremented. I am just wondering if I should set it up to look at the last invoice number in the actual records rather than keep track of it in the script.
  • 0





FMForum Advertisers