Sign in to follow this  
Followers 0

Kiosk Mode on Windows 7

12 posts in this topic

Posted

I've built a small runtime app which I'd like to run in kiosk mode. I'm using FMP11v2 Advanced

When the app starts up, it displays only the layout as expected, however it doesn't fill the whole screen - it sets up a window which is the full width of the screen, but the bottom quarter of the screen is black. I've tried running an adjust window (maximize) step in a startup script but the kiosk widow still doesn't occupy the whole screen

Is this a quirk of Windows 7, or am I missing something?

Thanks

Brian

Share this post


Link to post
Share on other sites

Posted

I have the same problem, i'm using windows 7 and i get this image with a lot of black space.

Imagem

http://img853.imageshack.us/i/filekiosk.png/

Did you test it with other windows version (XP; vista).

Do you find any solution yet?

Share this post


Link to post
Share on other sites

Posted

I have the same problem, i'm using windows 7 and i get this image with a lot of black space.

Imagem

http://img853.imageshack.us/i/filekiosk.png/

Did you test it with other windows version (XP; vista).

Do you find any solution yet?

Same problem with XP; not tried it with Vista yet.

Real issue for me, and still no solution. Kiosk runtimes with this kind of limitation are not usable for what I need to do.

May try asking Filemaker... not holding my breath.

Brian

Share this post


Link to post
Share on other sites

Posted

Maybe it your file?

Share this post


Link to post
Share on other sites

Posted

I see you are just using the default layouts.

Try resizing the top elements to your screen width (instead of allowing them to stretch).

Also draw a bar at the bottom of the layout to match the bottom of you screen.

Jerry

Share this post


Link to post
Share on other sites

Posted

Jerry, did work. I get a black bar at button (all times).

Can you share a file with a kiosk example, then I test it with windows 7 and filemaker pro 11.

Thanks,

Caps

Share this post


Link to post
Share on other sites

Posted

I has this one recently too. Seems it appeared in FM10 and affects XP and Win7.

My fix was to resize the window with

Height: Get (WindowDesktopHeight) - 4

Width: Get (WindowDesktopWidth) - 4

HTH

Share this post


Link to post
Share on other sites

Posted

Ok, let´s test it and share the results

First step: create a script with mode/resize window (current window) and your specification, correct?

Height – 4 pixels

Width – 4 pixels

The Get (WindowDesktopHeight) is a calculation? How I do that when I need a script to run each time I open the file? So i did a mode/resize

Second step: Perform script each when open.

Results: ……….. (mystery) Didn’t work same problem a big black space.

Did I do everything correct? Or there is a problem with windows or filemaker?

Idealdata, can you share an example then i post the image here?

Share this post


Link to post
Share on other sites

Posted

I has this one recently too. Seems it appeared in FM10 and affects XP and Win7.

My fix was to resize the window with

Height: Get (WindowDesktopHeight) - 4

Width: Get (WindowDesktopWidth) - 4

HTH

I tried this fix with FMP11Advanced V2. The result was to push part of the window to the left, off the edge of the screeen, and leave a black area at the right hand side. The slightly good news was that the black area at the bottom had now disappeared.

Different, but still no use.

Brian

Share this post


Link to post
Share on other sites

Posted

You can also center a RT with the Left and Top vars being ( ( Get (WindowDesktopHeight) - <your solution height> ) / 2 ) and ( ( Get (WindowDesktopWidth) - <your solution width> ) / 2 ) respectively...

Looks way better than aligned to the left top, especially on bigger screens.

Share this post


Link to post
Share on other sites

Posted

Just for the ones who want to know... If you want to have a background image in kiosk mode (in case you have a nice photoshop interface design), use the following settings to avoid the scrollbars to join the party:

BODY height: screen height minus 16 pixels

Image X: 16 pixels

Image Y: 16 pixels

Image width: screen width minus 32 pixels

Image height: screen width minus 32 pixels

So you guessed it, you are stuck with a border of 16 pixels all around. Making it black I guess will makes it look best. Oh, Mac only... still need to figure out above data for Windows.

Share this post


Link to post
Share on other sites

Posted

I came across this problem too ...except my left side windows is way off the screen with an unsightly black border on the right. And it does not fully resize to the height of the screen... any ideas what went wrong? This is with runtime and kioks mode enabled

runtimeprob.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0