Jump to content

  •  

Photo

IWP "it works!" no it doesn't!

iwp instant web publishing port

  • Please log in to reply
5 replies to this topic

#1 jdg88  newbie

jdg88
  • Newbies
  • PipPip
  • 2 posts
  • FM Application:11 Advance
  • Platform:Mac OS X Snow Leopard
  • Skill Level:Intermediate

Posted 10 September 2011 - 08:21 AM

Hi All

Hope some one can throw some light on this.

I have FM Advanced Pro 11 running on an iMac running OS 10.6.8 (Snow Leopard).

I have a static IP address.

I am trying to share a database with a colleague using IWP, however no matter what I try I can only get "it works!" when connecting from the outside world.

I have tried:-

A - System Prefs - Web Sharing On, IWP - port 80, http://212.159.106.29 :RESULT: "it works!"

B - System Prefs - Web Sharing Off, IWP - port 80, http://212.159.106.29 :RESULT: page cannot be reached

C - System Prefs - Web Sharing On, IWP - port 591, http://212.159.106.29:591 :RESULT: page cannot be reached

Plus many more variations out of pure frustration. I also tried localhost http://localhost:591and that worked taking me to the FM IWP page as expected.

Can anyone advise what I'm doing wrong or point me in the right direction please?

Many thanks.
  • 0

#2 IdealData  IdealData

IdealData
  • Members
  • 2,585 posts
  • FM Application:12 Advance
  • Platform:Mac OS X Snow Leopard
  • Time Online: 8d 11h 6m 57s

Posted 11 September 2011 - 01:16 AM

There are several possibilities:

1. Your router probably has a firewall enabled, allowing port 80, but denying all others

2. Your router needs to have port forwarding enabled for the IP port that IWP is broadcasting on. IWP default is port 80, but conventionally is used under 591

3. OS X firewall is normally off, but check in System Prefs > Security > Firewall

Listed in most likely order.

HTH
  • 1
Ideal Data - Coherent systems for a chaotic world
I'm available for hire, e-mail me

#3 jdg88  newbie

jdg88
  • Newbies
  • PipPip
  • 2 posts
  • FM Application:11 Advance
  • Platform:Mac OS X Snow Leopard
  • Skill Level:Intermediate

Posted 11 September 2011 - 12:52 PM

Thanks for your suggestions it turns out to have been down to Apache settings. I needed to set up a virtual host directing to localhost at port 591.

Can't really understand why port forwarding to 591 didn't work on it's own but all working now with the virtual host and I've learnt a shed load!

Thanks again.
  • 0

#4 IdealData  IdealData

IdealData
  • Members
  • 2,585 posts
  • FM Application:12 Advance
  • Platform:Mac OS X Snow Leopard
  • Time Online: 8d 11h 6m 57s

Posted 11 September 2011 - 11:45 PM

Wanna share exactly what you did - others might read this too.
  • 0
Ideal Data - Coherent systems for a chaotic world
I'm available for hire, e-mail me

#5 Andres Dominicci  member

Andres Dominicci
  • Members
  • 9 posts
  • FM Application:11 Advance
  • Platform:Mac OS X Snow Leopard
  • Skill Level:Novice
  • Time Online: 5d 17h 48m 36s

Posted 29 September 2011 - 03:21 PM

Please share. I'm having the same problem. I can open from Filemaker Go from my ipad since I forward to port 5003. But can't do it with port 591 from Ipad's safari browser. Thanks.

Andre
  • 0

#6 Andres Dominicci  member

Andres Dominicci
  • Members
  • 9 posts
  • FM Application:11 Advance
  • Platform:Mac OS X Snow Leopard
  • Skill Level:Novice
  • Time Online: 5d 17h 48m 36s

Posted 30 September 2011 - 06:05 AM

Hi guys:

Got it working. I'm on FM Pro 11. The port that I opened in my router and got it working was 8080. That's the default port when sharing in IWP.

Andre
  • 0





FMForum Advertisers