Jump to content

  •  

Photo

No access IWP from web on Filemaker Server 10 Advanced


  • Please log in to reply
4 replies to this topic

#1 mk2000  newbie

mk2000
  • Newbies
  • PipPipPipPipPip
  • 5 posts
  • LocationMontreal, Canada
  • FM Application:10 Advance
  • Platform:Windows 2003
  • Skill Level:Beginner

Posted 10 February 2012 - 03:55 PM

HI ,
I am a newbie and i am sure its a tiny simple click that i am missing :) I set up a server with filemaker server advance 10. Its up and running. I can accessto database in my home network with 192.168.1.1/..... numbers. with fmp7 extentions i can access to my database from internet. With different ip address in allover city with filemaker pro 10. So i know I have no problem accessing with pro versions.The only problem which is very important for me, i cant access my IWP from the web.
here is the info what i have

*Filemaker Server 10
*Filemaker pro 10
*Windows 2003 server
*IIS setup
-------------------------------------
*all the database open and normal and checked for IWP
*It says IWP running correctly
*On Router 80 and 591 and 8080 ports open
*Other Open ports=16004-16006-16008-16010-16012-16014-16018-5003-50003-16000-16001-50006-389
*I can access in my network 192.168.1.116/fmi/iwp but no access <my ip address>/fmi/iwp outside of my network
*People can access to my network with filemaker pro
*On server IWP enabled
------------------------------------
*Also thru web ,i can access filemakerserver 10 with my ip adress http://<my ip address>:16000/


So whats the problem that i can access to my server with filemaker pro but i cant access with IWP to my server?
I have tried everything and going crazy :))))
Please help !!!!!!
  • 0

#2 Steven H. Blackwell  Humble Servant

Steven H. Blackwell
  • Moderators
  • 4,765 posts
  • FM Application:13 Advance
  • Platform:Cross Platform
  • Skill Level:Expert
  • Certification:7, 8, 9, 10, 11, 12
  • Membership:FileMaker Business Alliance, FIleMaker Platinum Member
  • Time Online: 9d 7h 20m 34s

Posted 10 February 2012 - 04:28 PM

Does the Account you are using have privileges to access by IWP? Check in Manage Security and be suer the fmiwp privilege bit is enabled for the Account.

Steven
  • 0

Steven H. Blackwell
Platinum Member Emeritus, FileMaker Business Alliance
Platinum Member, FileMaker Business Alliance (2007-2011)
Partner Member, FileMaker Solutions Alliance (1998-2007)
Partner Member, Claris Solutions Alliance (1997)
FileMaker Certified Developer 7|8|9|10|11|12
FileMaker Authorized Trainer 9|10|11|12
_ _ ____________________________ _ _
http://www.fmp-power.com
http://www.filemakersecurity.com


#3 mk2000  newbie

mk2000
  • Newbies
  • PipPipPipPipPip
  • 5 posts
  • LocationMontreal, Canada
  • FM Application:10 Advance
  • Platform:Windows 2003
  • Skill Level:Beginner

Posted 10 February 2012 - 05:05 PM

Thanks for your quick respond.
Yes fmi/iwp enabled for the account. Still when i go to " http://<my ip address>/fmi/iwp " page from outside, it doesnt give me access. Again only works in my private network. :(

I am assuming something to do with windows server 2003 configuration. Because any how in my network between 4 PC's IWP working perfectly. I am entering accounts that i created easyly. When i tell someone outside to enter my network, it gives error cant even connect.
  • 0

#4 mk2000  newbie

mk2000
  • Newbies
  • PipPipPipPipPip
  • 5 posts
  • LocationMontreal, Canada
  • FM Application:10 Advance
  • Platform:Windows 2003
  • Skill Level:Beginner

Posted 20 February 2012 - 11:26 AM

hello all

finally i found the problem. I should do that at the very begining.
CALLING my internet provider. I dont know if its same in USA but in canada they
block all 80 and 591 port numbers who has residential internet access. That way
they force you to use static business account with more money . Thats why People werent being
able to access to my IWP database only but accessing my filemaker pro database because
they use different port :) I hope this information will help others.


thanks for your help
  • 0

#5 IdealData  IdealData

IdealData
  • Members
  • 2,616 posts
  • FM Application:12 Advance
  • Platform:Mac OS X Snow Leopard
  • Time Online: 8d 22h 46m 30s

Posted 21 February 2012 - 12:57 AM

You don't have to use port 80 or 591 for IWP. more than likely your ISP blocks many other ports. Try using a really high number > 20000.
  • 0
Ideal Data - Coherent systems for a chaotic world
I'm available for hire, e-mail me




FMForum Advertisers