Sign in to follow this  
Followers 0

MirrorSyncing Container Fields

3 posts in this topic

I am failing to sync container fields with MirrorSync


FileMaker Server 12.6

Mac Ox 10.9.1

Mirror Sync2_0082


There is no error message when MirrorSync2 finishing the sync process with an iPad. "Sync Complete"


Using the FileMaker Tasks sample, images entered on iPad do not show on networked file after syncing, same when images entered in the networked file do not who on the iPad.


Container fields show: <Missing: photo001.jpg size450.300>

FileName shows: remote: File Name


I have tried several configurations of the container field settings.


I tried (as per documentation) save a "self contained copy": even in this file are no images but <Missing: photo001.jpg size450.300>


Does anybody has an idea what would work?






Share this post

Link to post
Share on other sites

Problem solved:


The problem was in the external data sources. Open that open (File -> Manage -> External Data Sources). Verify that the IP address and the filename point to the file on the server where the container data lives.
The source of the problem was changing the FMP file name.
Syncing containers works fine now. 

Share this post

Link to post
Share on other sites

Glad to hear it - that was going to be my first suggestion to check.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Similar Content

    • MirrorSync set up after editing application
      By doughogg
      Does anyone have a link to a short reference on updating MirrorSync settings after making changes to the Filemaker solution (other than the original MirrorSync documentation)?
    • Storing and Opening PDF in Container Field
      By andersonk06
      I am starting to create a new solution to catalog all of our companies Safety Data Sheets and would like to make the PDFs accessible through FMP14. At the moment I have created a container field that is Interactive and has temporary storage. If I choose "Insert PDF" FMP thinks about it for a moment then opens the pdf I have selected, if I close the pdf I can see that something is in the container but there is no content show. If I move to a record where this has been done the PDF automatically opens, albeit slowly, but I am unable to view the PDF contents without exporting it. If I insert the pdf as a file I see a file icon but am not able to read the file in any way except by exporting it. 
      From reading about PDFs and container fields, it sounds like I should at least be able to see a thumbnail of the pdf but I am not able to read any of the PDFs content. Has anyone else been having that problem? A sample file is attached. 
      Ideally the pdf would be viewable in the record or by clicking a single button and then could be saved to the user's computer for printing purposes. 
    • One iPad failing with "java.util.NoSuchElementException"
      By ScottGH
      I have a client with several iPads in the field. One today failed to sync, though the others have been syncing fine. I had him close the FileMaker file, quit Go and all other apps, and restart his iPad before syncing again. Same error. I restarted the WPE and the Tomcat server. Same error. Had him restart again while I restarted WPE and Tomcat. Same error. Others had since synced fine. Below is the error we are getting. I redacted the domain and client's IP address. I told him to click "Report Bug" so you should have that.
    • MirrorSync script is out of date
      By maverik_uk
      Using the following configuration:
      * FileMaker Server 13 on Mac Mini, FileMaker Pro v13 on remote MacBook Pro, MirrorSync 2.406 build 8009
      We are seeing the following message when trying to sync using MirrorSync.
      'You will not be able to successfully sync. MirrorSync is out of date or missing some script steps. Would you like to save changes anyway?'
      I have deleted the configuration and started over, then repasted the script steps into the MirrorSync script.
      I have not been able to repaste the layout as MirrorSync does not request it second time over - does this contain some reference to the original configuration and if so, how do I reset it.
      Any ideas?
    • Do I Need to Deploy New Local Copies
      By Jason Mundok
      I have a solution where the master database is copied and deployed to 3 laptops and 3 iPads for offline use.
      I need to add new functionality that will only be used on the laptops. If I add that functionality and it requires new fields to be added to the database and the MirrorSync layouts, can I copy the master and deploy it to the laptops only, or do I need to deploy a new copy to all 6 devices?
      In other words, if didn't deploy a new copy to the iPads, would the sync from the iPads to the master fail after adding the functionality?