Sign in to follow this  
Followers 0
RyanESmith7

pc FileMaker Pro on FileMaker Server Server

7 posts in this topic

Is it OK if I install FileMaker Pro on my FileMaker Server? We are running FMS13 on a Windows 2012 Server (Standard). I was thinking of putting FileMaker Pro 13 on the server so that I could open up backups on occasion. Do they co-exist well?

 

Share this post


Link to post
Share on other sites

According to the FMS 13 Getting Started Guide: 

 

If you are currently running FileMaker Pro on the same machine, you must quit FileMaker Pro 

before installing FileMaker Server.

 

https://fmhelp.filemaker.com/docs/13/en/fms13_getting_started.pdf#page=9

 

I don't know if its good or bad, I have never had a need to install FM Pro or Advanced on the server machine.

Share this post


Link to post
Share on other sites

Yes. But DO NOT open the backups directly.

Instead make a COPY of the backup you want to investigate. Don't just drag the backup elsewhere you must make a COPY. This is due to the way the backups are generated using HARD LINKS

I do it my myself but for other reasons.

Share this post


Link to post
Share on other sites

Hi Ryan,

 

I don't believe there will be a problem with installing Pro on the Server machine.

 

Josh's reply relates to the installation process for FileMaker Server. Always close open Pro/Advanced applications during the installation process.

 

Also, if you plan to use FileMaker Pro for debugging purposes in addition to opening the backups, grab Advanced instead.

 

Hope this helps

 

-JohnAustin

Share this post


Link to post
Share on other sites

Josh's reply relates to the installation process for FileMaker Server. Always close open Pro/Advanced applications during the installation process.

 

hehe...yeah. The reference was simply to show that Pro can be installed on the same machine.

 

IdealData - Great clarification.

Share this post


Link to post
Share on other sites

Wouldn't they conflict, as both would try to listen on port 5003?

Share this post


Link to post
Share on other sites

First, never have both open at the same time.

 

Second, it is possible, perhaps even likely, the FileMaker Pro will behave abnormally running on the Server OS.  However, it likely is possible to install it.

 

Third, pay very close attention to the comments about the backups.  Never open the backup on the machine.  Always make a copy of that backup and open the copy if need be.  You can copy it to another location on the same server machine.

 

Steven

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Similar Content

    • Any experiences on the latest El Capitan upgrade (10.11.5)?
      By cbum
      Any experiences on the latest El Capitan upgrade (10.11.5)?
    • web server not passing test
      By Aussie John
      Hi I am installing a new OSX server and FMS. During the deployment I can't get past the web server test with error: Test web server (http://127.0.0.1:81/fmi-test/test.xml): Connection refused
      any thoughts - I turned off websites in the admin server. Funny I did this not so long ago and didn't run into this. Thanks in advance.
       
    • Admin Console Password incorrect (it's not)
      By Harry
      Hello Board!
       
      FMS 13. Hardware crashed. File closed incorrectly, listed as 'closed' on server console. I've opened the file locally with a version of Pro, done the checks and now have a file that works and can be opened locally.
       
      I log into FMS, using the console login and password, get access.
       
      Then i try uploading the file via FMP - it checks the file then asks me for the admin login and password for the Console. That fails as 'incorrect login/password.' But it's not incorrect. I've logged in to FMS Console with that password, changed it, tried it, been refused as incorrect, then logged back in/out of console with the new password to put it back to the original one which also fails!
       
      What is going on?
    • Why does it do this?
      By Charity
      I get strange symbols sometimes. anyone know why?  is it because I do not have enough memory? Thank you.