Sign in to follow this  
Followers 0

Strange Convert Behavior

2 posts in this topic

Hi - 


I have a single file runtime solution, and working on an upgrade that requires conversion from pre-FMP12 format.  I'm using the Convert File script step.  I've run into something very strange.  My solution uses it's own file extension  .fhc.


So I've set up the Convert step with no dialog and with a specified source file - namely 'fhcm.fhc.  The first several times I tried this, the output file was named fhcm.fmp12 - as expected -- and the original file was left unchanged, since I specified no dialog.  (It does not get changed to a fp7 file extension.  


Somewhere along the way, the Convert File step started naming the output file FHCM #, where # is a digit, starting with 0 and incrementing if I do this multiple times.  It also changes the lowercase to upper case.


So instead of naming the converted file fhcm.fmp12 (which it had done at first), I now end up with a converted file named FHCM 0.fhc or FHCM 1.fhc, etc.


I can't for the life of me figure out what changed nor can I find any documentation of when or why it would do this.


Any thoughts?




Share this post

Link to post
Share on other sites

I think I've figured this out, and it appears to be a genuine bug - or else I missed the documentation.  It seems that runtime behaves differently when using the Convert File script step.  Documentation says converted file will get fmp12 extension, but when I run from runtime, with dialog turned off, it adds a space and digit to the filename but does NOT change extension.  Seem to be very consistent.  

Would be great if anyone else can test this.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Similar Content

    • Records disappear
      By millmaine
      We have been having an occasional issue where records just disappear. It's been going on for almost a year now and we simply can't see what might be causing it. It is not common and seems to happen at random. Once every 2 weeks or so.
      Our database has 33 tables. The disappearing records all come from the same table. It is hosted on a cloud based server with 17 clients in 2 cities (same time zone) accessing it.
      Steps we have taken so far are:
      • Disabled "delete record" from the Menu Set
      • Implemented a dedicated "delete record" script that notifies the administrator when it is run so that the administrator can confirm with the user that the deletion was intentional.
      • Checked that records can not be deleted via a relationship
      • Tracked the timing of discovery that records have disappeared. This is difficult because it may be weeks or months before someone needs to refer to it, so doesn't really tell us when the record disappeared.
      When the record is deleted it appears that related records are NOT deleted.
    • Converted from FM5 to FM13: Find criteria missing?
      By Justin Close
      I have a client who converted an old solution (FM5) to FM13 recently.  They have found that some Find script steps, that used embedded criteria, have the operator missing from the step.  It may just be limited to ">" operators, too.  (I haven't have a chance to look at the files yet, but a couple of printouts show this to be the case.)
      Does anyone have experience converting these old files that use embedded criteria?
    • $$Map_HTML customisation
      By Lloyd Hird
      Hi there,
      I am using EasyMaps and trying to integrate into my own solution. I am loving it so far, however, I have run into issues when trying to create infoWindow on Marker Click.
      I had it working within maps as a standalone setup in my database before I integrated EasyMaps but now i can only load a blank screen.
      Here is my code. I know it's flawed, I just don't know where lol.
      "<!DOCTYPE html>¶ <html>¶ <head>¶ <meta name=\"viewport\" content=\"initial-scale=1.0, user-scalable=no\">¶ <meta charset=\"utf-8\">¶ <title>FMEasyMaps " & Get ( CurrentTimestamp ) & "</title>¶ <style>¶ html, body, #map-canvas {¶ height: 100%;¶ margin: 0px;¶ padding: 0px¶ }¶ </style>¶ ¶ <script src=\"[[API_KEY]]&v=3.exp&sensor=false\"></script>¶ ¶ <script>¶ ¶ function initialize() {¶ ¶ var positionLatlng = new google.maps.LatLng([[START_COORDS]]);¶ ¶ var mapOptions = ( {¶ zoom: 5,¶ center: positionLatlng¶ } );¶ ¶ var map = new google.maps.Map(document.getElementById('map-canvas'), mapOptions);¶ ¶ var contentString = '<div id=\"content\">'+¶ '<div id=\"siteNotice\">'+¶ '</div>'+¶ '<h1 id=\"firstHeading\" class=\"firstHeading\">Tony McShane</h1>'+¶ '<div id=\"bodyContent\">'+¶ '<p><b>TONY</b>, also referred to as <b>Epic Douchebag</b>, is a dude from cranny' +¶ '</p>'+¶ '<div id=\"link_div\" style=\"text-align:centre\">'+¶ '<a href=\"fmp://REMOVED/iCOMPLI%20Auditor_Tenancy%20Lite%20MetCash%20upgrade.fmp12?script=goto_iCompli%20Map%20Info%20Window%20Button%20Click%20TEST\">View Client Record</a>'+¶ '</div>'+¶ '</div>'+¶ '</div>';¶ ¶ var infowindow = new google.maps.InfoWindow({¶ content: contentString¶ ¶ });¶ ¶ });¶ ¶ var bounds = new google.maps.LatLngBounds();¶ ¶ [[MARKERS]]¶ ¶ google.maps.event.addListener(marker, 'click', function() {¶,marker);¶ });¶ ¶ map.fitBounds(bounds);¶ ¶ }¶ ¶ google.maps.event.addDomListener(window, 'load', initialize);¶ ¶ </script>¶ </head>¶ <body>¶ <div id=\"map-canvas\"></div>¶ </body>¶ </html>"Any help would be appreciated.
    • no multiple attachments in Send Mail script step? really?
      By naio
      I can't handle more than one attached files in the Send Mail script step, it's me or it is really a limitation of FM?
    • HELP. Mac. Fp7 (used in 11) doesn't update to FMPro13
      By erussell
      Just got off hour long call with FM support, recommended I post in forum.
      Forced (Mavericks upgrade) to FMPro13 broke an old Filemaker-supplied inventory/invoicing program I have used for years.  Structure, basically, 7 connected db files: People.fp7, Products.fp7, Invoices.fp7 etc. called with Menu.fp7. 
      Had upgraded numerous times before, didn't break.... 
      This time did normal conversion (to fmp12). Basically, broke scripts.  (Did one pass of remapping external data sources. Worked in some cases, not in others.) Just too much for me to track down so I think I'm looking for someone to take it on.... but any thoughts welcome.
      Seems to me I have tried to export records and import into new solutions but hasn't worked.
      Help, thoughts?