We have reset all users FileMaker related profile fields. Please take the opportunity to update your information,  this will provide background to members whom read your posts. Click here.

Jump to content

GeoSteven

Members
  • Content count

    14
  • Joined

  • Last visited

Community Reputation

0 Neutral

About GeoSteven

  • Rank
    novice
  • Birthday 05/05/1952

Profile Information

  • Gender
    Male
  • Location
    Upstate SC
  1. FMSA 11 - error 512

    Sorry for my delayed response. ggt, I am updating the record using a 'set field' command. I was able to capture the error as needed by using Wim's suggestion of placing an 'open record' step before the "set field" step. However, the underlying problem, which I found while gathering info to give you both feedback, was that I am looping through a found set of records. When a certain condition is met I call a subscript to add/replace a record in a related table. In that subscript I was also updating the field in the parent table (from the related one) then, upon returning to the calling script I attempted to update the field again (in the parent table). Hence the error 512. The reason it would only fail occasionally is that the 'certain condition' would only be met occasionally. I removed the step in the subscript to update the parent table so that it was only done in one place. For extra measure I added the 'open record' step as suggested by Wim. Thank you both.
  2. FMSA 11 - error 512

    I am running a server side script that attempts to update records in a MySQL table that is set up as an external data source. It runs without issue for hours to weeks at a time then gets hung on error 512 (Record was already modified by another user). The problem is that I can't figure out how to capture and handle this error. I've tried adding "If get(lasterror)=512 then <skip this record and continue to next> just after the 'Go to Record(next)' but it never gets to that step. Instead hangs on try to move the record pointer and writing error after error to the log. I've searched the forums fairly thoroughly but there is not a lot of info forthcoming. Surely this has been a problem for someone else that has figured out how to handle it. Any suggestions appreciated. Will be glad to provide more info on the environment if needed. Thanks in advance, Steve
  3. FM6 and ODBC to MySQL

    Thank you Lee for getting me to the right place. And thank you Wim for the solution. Works like a charm when you know what to do!! :<)
  4. FM6 and ODBC to MySQL

    This is hurting my head trying to remember this far back. I'm trying to put together a test platform for an FM6 application. The current production platform pulls data from a MySQL database (that resides on the same physical server with FM6). The client wants to have the MySQL hosted offsite so I need to test pulling the data while MySQL is installed in a different city/state. It should work but while trying to define the host in the "Import Records" script step I can't get the host to present the tables. I have placed a copy of the entire FM6 project on a separate laptop with FM6ProDev installed on it. On that same PC I have defined a DSN for the new MySQL installation in the ODBC manager and successfully tested the connection. I can step through the script with "Perform without dialog" unchecked in the "Import Records" step and that works fine. When I'm prompted to select data source the DSN I created is there. When I select it I'm prompted for a user name and password which I enter (I've also made sure that I check "Save User Name and Password"). When I click OK I can see the new connection at the MySQL server and I'm able to complete the remainder of the import steps as expected. However when I go back to the script in the script editor it still has the old (production) DSN in the script step. If I attempt to define the file and click on the "Hosts" button I cannot for the life of me get the Hosts dialog to present the database. I've clicked "Specify Host" and tried typing in the name of the server (MySQL.companyname.com), the DSN and even "DSN:<DSN name here>". In every attempt the "Open" button continues to be greyed out. I suspect that it has something to do with having to log in the database but I thought that was why I created the DSN to begin with. When I try the "MySQL.companyname.com" FM goes into hourglass mode for about 10 seconds but I never see an attempt on the MySQL server to connect and then I'm returned right back to the same dialog. What am I missing? Any help will be appreciated. - Steve
  5. just to follow up on this - 360 works educated me on this. I was using the interal IP address (ex 192.168.111.111) in the web viewer URL instead of the external one (ex www.mydomain.com/subaddress). Naturally this failed because any user outside our LAN would be directed to their own local IP address. A real 'duh' moment for me.
  6. Activation for runtime solutions

    Good morning - I'm also developing a runtime that I need to provide similar protection. I'd be interested in learning more about how you intend to accomplish this or if you have found any authoritative references on the subject. - thanks
  7. I know this thread is kinda old but it's the only one I can find that relates to the issue I'm having. I believe my issue has been caused by the same thing but cannot figure out how to do the forensics. Based on the previous post it would seem that a field in my DB is requiring validation that has not been met. When the user canceled out of the dialog the server started throwing these errors (see attached log file). How can I tell which field is the culprit? How can I recover from this in my current DB? What can I do to prevent this in the future? FM11dev_serverlog.txt
  8. We have FMSA 11 on (server name FM01) which is serving our "VM" app via IWP. We have SC installed as a stand alone on a different server (SC01) which has been modifed to place documents on a 3rd server (FS01). We will not be using the SC plugin so we've designed a portal with a web viewer next to it to show the document related to the record chosen. Everything works as expected using an FM11 client or IWP… as long as we are within the firewall (on the LAN). If I try to access the docs (via IWP) from any point outside our office the browser brings back all of the related record information then after a few minutes the web viewer displays (… cannot display this web page…). I initially suspected this was a firewall issue so I added an entry to forward any reqs to port 8020 on our domain to port 8020 on the server which has SC running on it. This has not fixed the problem. If I enter http://outdomain:8020/SuperContainer/ into a browser outside the LAN it display a SC page and gives the option to upload docs (which I need to prevent if I can) which tells me the firewall is allowing the traffic. But still the application will not display the doc. I've checked this from 3 different PC's using 3 different ISP's. I've also verified that the latest Java updates are installed. What am I missing here?
  9. Hard Company Relationship

    sd - I agree Randy that more explanation would be useful. There seem to be a lot of nebulous replies in forums that the inexperienced undoubtedly struggle with. My attempt to offer a complete explanation was not a defacto schema design but hopefully offered enough information to provoke a constructive train of thought. I would also agree with you that the 3 tables have a lot of common attributes which could/should be placed in a 'contacts' table which would be tied to the 3 tables mentioned. I will point out though that the 3 roles I described are different enough that they should be separated as described. While it is certainly possible to combine all of them there are attributes for a 'customer' that have nothing in common with a client or vendor.
  10. Hard Company Relationship

    OK - I think I understand. I would design this with 3 separate tables, one for each role. Company (me), Clients (pay me for my services) and Vendors (I pay them for their services). Company becomes the 'prefs' or control table and is related to vendors and clients via CompanyID. Now the only question left would be is this a distributed application or a web hosted one? If it's distributed and only a single company will have access to it (ie - instaled on their servers on their premises) then when the package is initially installed you direct the user setting it up to enter the pertinent company information. This info is placed into a single record in the 'company' table along with a 'CompanyID' (auto generated serial number). Regardless of who logs in there is only one company. No choice needed. In my designs this would also serve as your 'prefs' table, as mentioned earlier, storing things like file locations, default system control values, etc. Being a single record you can make the majority of the fields globals for easier access in your scripts and layouts. If it's a web based solution so that multiple companies may access it (ie - hosted by a third party other than the 'company') then you have to back into the company record from your user table. Ex - user AlexD logs in, your autoexec/login script locates him in the user table along with the CompanyiD (tied back to company) that he works for and you populate global fields that set your relationships into vendors and clients. I'm sure all that's just as clear as mud. Hope it helps. :bye:
  11. Hard Company Relationship

    Hi Randy, It may help to describe to us what the company is. You mention clients and vendors. What role does each play in your business model? Do your users work for different companies and you want the company to be set depending on what user logs in? Steve
  12. Oops! Can I disable start-up script?

    I know I'm jumping in late here but I ran across this thread looking for something else. My answer to your issue seems simpler to me. Create (or open) any other database. Set script debugger on. Open 'locked' database. Go to scriptmaker from the debug window. Remove offending script step. Save... :
  13. Using mailto

    I am currently facing this same issue. As old as it is there must be a solution but I cannot seem to find it. I've been to several forums where the question is asked but no answers are given. Is there a way around this annoyance? FM10 advanced WinXP Pro Outlook 2003
  14. I use a product called "Advanced Installer" (see www.advancedinstaller.com) to pack everything into an .msi for Windows. To reduce size I do not include the foreign languages (my app is used by in house personnel only). Each language dictionary and associated dll set is over 11MB. I've just upgraded from FM8.5A to FM10A and recompiled only to find that my trimmed down install file grew from 12MB to over 20MB!. Ah... progress.
×