jaboda

Tab Control not displaying in Webdirect correctly

8 posts in this topic

Posted (edited)

This seems to be a bug in Filemaker as the layout is not displaying correctly in Webdirect. If there's a corruption in the Theme then repairing the file should fix it - hence why I think it's a bug.

I have attached an image of how it displays in Filemaker, Webdirect 14 and also the file.

The only way I can think of to fix it is to rebuild the entire theme, but this is a massive pain. Any other suggestions?

Thanks.

Filemaker.png

Theme Test.zip

Webdirect.png

Edited by jaboda

Share this post


Link to post
Share on other sites

The main problem is I can't change the tab control elements - for example add a border or reliably change colours.

I also can't create more than one style (as well as Default) - otherwise the styles don't work properly in Webdirect.

When using another theme these features work fine.

Share this post


Link to post
Share on other sites

Do you mean that when you modify a this Tab in FileMaker, it doesn't hold in Web Direct?

or, you don't see how to modify a theme object?

I modified your tabs to show lines and rounded colors see Theme Test Copy.fmp12

I'm not sure why it wouldn't hold in using Web Direct, maybe you need to save the changes made to a new style name, and then save it to a new  theme?

Share this post


Link to post
Share on other sites
20 hours ago, Lee Smith said:

Do you mean that when you modify a this Tab in FileMaker, it doesn't hold in Web Direct?

or, you don't see how to modify a theme object?

I modified your tabs to show lines and rounded colors see Theme Test Copy.fmp12

I'm not sure why it wouldn't hold in using Web Direct, maybe you need to save the changes made to a new style name, and then save it to a new  theme?

I've just tried your file in WebDirect and it doesn't show the lines. Additionally if I move the mouse over the active tab the background colour disappears.

Same problem I'm having with my live solution.

Share this post


Link to post
Share on other sites

I don't have a way to test in Web Direct, perhaps someone else can step in.

I know that there were some things that didn't work like they do in FileMaker, and I kind of remember that the themes were a problem?

Which Theme did you start with?

Just for kicks, I changed the theme to Minimalist and then recreated the colors and lines to see if it would remove any influences from the starting theme.

If it isn't tied to the theme, then I would do a Bug Report with FileMaker.

 

Theme Test 3.fmp12

Share this post


Link to post
Share on other sites

It's probably a WebDirect bug, there are still a number of formatting issues. Use a slide panel instead and script buttons to move between the slide panels. You can style this so it looks like a tab panel.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now