Keawe

supercontainer windows server webdirect won't show

3 posts in this topic

Posted (edited)

Hello,

I installed supercontainer on my Windows server at aws Amazon. I also installed the companion plug-in. It shows up on Filemaker Pro no problem. But it doesn't show on webdirect. Any idea?

Here is my configuration:
- FMS 15, Windows 2016 server. 
- SuperContainer 2.94, build 9234.
- I have the companion plugin put inside "..\FileMaker Server\Web Publishing\publishing-engine\cwpc\Plugins".
- The plug-in I use is "SuperContainer_Companion_Plugin.fmx64".

Thanks.

P.S.: I will send an email to 360works. But just want to post it here so we can all share the solution. Thanks.

Edited by Keawe

Share this post


Link to post
Share on other sites
11 hours ago, Keawe said:


- FMS 15, Windows 2016 server. 

Not supported!  Only FMS16 runs on 2016 Server and I'm pretty sure there are valid (IIS) reasons why it is not supported.

Share this post


Link to post
Share on other sites

Solved it!! I didn't set my x-frame properly to allow webdirect to show the supercontainer in iframe.

If you run into the same problem, please go to your IIS config and set the iframe to ALLOW-FROM http://yourfilemakerserverhostIP/

It is secure since you are only allowing iframing from yourself.

That will do it. Hope you find this solution useful and don't have to pull your hair out like I did. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By Gnurps
      On two Filemaker Server machines I manage, I cannot get FTPeek to activate. After checking the checkbox, a grey message appears appears stating that the plugin was enabled, but the checkbox is unchecked. 
      I have checked the permissions of the plugins. Both owned by fmserver and group fmsadmin. I have restarted the machines. I have tried Wim's suggestion of installing with server-side script. Both have Java 1.6 installed. Both have the BaseElements plugin installed and successfully enabled.
      Both are running FMS 14.04. One is a Mac mini running Yosemite, with  Core 2 Duo processor and 8gb. Other is a Mac mini running El Capitan with Core 2 Duo and 4gb. 
    • By Jonathan Ackerman
      My client is experiencing empty dialog windows-- starting with the Launcher.
      She is running FileMaker Pro 15 - 32bit on windows.
      She reinstalled several times with same result.
      any ideas?
       
      thanks!

    • By animation_master
      FileMaker Pro 15 Launch Center connects to our AWS instance with no problem. But then it reports
      No files are currently hosted on AWS instancename.
      Well, there ARE files currently hosted. We access them via WebDirect, so they must be hosted.
      Moreover, when we launch a local copy of the file, FileMaker offers to open the remote copy with
      This file has previously been uploaded to FileMaker Server. Use Hosted Version?
      It even displays the proper address for the hosted file.
      However Use Hosted Version returns this error:
      The file “filename.fmp12“ could not be opened. (Extended privilege disabled)
      So, we created a privilege set that extended privileges for fmwebdirect, fmapp and fmxdbc.
      On the next launch of Remote Version, we got this:
      FileMaker cannot share a file because FileMaker network sharing is turned off.
      So, we turned on ODBC sharing, and on the next launch, we got this:
      FileMaker cannot share files because another user is already sharing files using FileMaker Pro on this computer.
      I’m going in circles here. Are these errors related? What am I doing wrong?
    • By EdwinJ
      We have a script using the 360 Works plugin and it worked for a long time and know we get the message "No login methods supported!". The script is connecting to an exchange server with Imap.  In the script we already use  "forceTrust=True".
      Is there somebody who has the same problem ?