Maker of Files

Background color changes color in preview mode

5 posts in this topic

I don't even know where to begin.

 

I have a db...In every layout for every table—in spite of the fact that their parts all have a white fill—the background turns red in preview mode. I'm using 12, so if I change the theme, this doesn't happen, but if I change the theme back to classic, I get the red background again. I put white rectangles covering the layout parts and that helps; except at the part boundaries, you can still see red and there's nothing you can do about it.

 

Any ideas where to being troubleshooting? I found out that if I remove the white background fill, the default color is red...in classic...So what that seems to mean, then, is that in preview mode, my white background is being stripped away. The clumsy solution was to select a new theme, turn everything white, remove the alternating body fill, and copy the layout objects onto this new layout. But I want this red background thing to make sense to me!

 

So thanks for any ideas at all.

post-106170-0-15843700-1394051002_thumb.

post-106170-0-06319000-1394051006_thumb.

post-106170-0-16405600-1394051009_thumb.

post-106170-0-92920400-1394051158_thumb.

Share this post


Link to post
Share on other sites

Hi Maker, and welcome to the Forum.

 

I  moved your question from "Layouts" to "Custom Themes in FM12 because, we created this especially for the layout tools new with the release of v12.

 

Are you using the latest update of v12, if not update and let us know if that fixe the problem.

 

p.s.

 

Update your Profile to reflect your current information as v12 etc. Here is a quick link for you. MY PROFILE.

Share this post


Link to post
Share on other sites

Hi Maker

 

Just wondering if you ever got to the bottom of this, because i have exactly the same problem, (though in my case the colour is blue, not red) and I can't get to the bottom of it. 

 

Any help or advise would be great,

 

Milt

Share this post


Link to post
Share on other sites

Anybody find a fix for this problem? We have the exact same issue (FMP 12.0v5) with the background turning red in Preview mode in a database which suddenly started exhibiting the issue after months of trouble-free operation.

Thanks,

Colin

Share this post


Link to post
Share on other sites

Posted (edited)

I believe the problem lies with new features in Filemaker 13.

We had that problem recently as one of us tested FMA 13 while most of our users are still using FM 12 client. In FM 13, layouts do have a general background color (Inspector -> Appearance) which does not exist in FM 12.

It seems that when you edit a layout in FM 13, you might accidentally set this background color which then takes precedence over the elements' background colors you can manage in FM12.

So, the solution is to open the layout in FM13 and set or remove this layout background color.

You can see that "Layout background" feature on the right side of the image below. (source : http://www.technologytell.com/apple/131237/filemaker-pro-13-for-os-x-review/ )


fmpro13-inspector-appearance-364x1024.pn

Edited by NLMR
Added the source website for the picture

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • Formatting non-active fields in list view
      By Karlos Fandango
      Hi.
      I built a database about a year ago but it wasn't required at the time, a year later and it is needed so I'm pretty rusty at present ref FMP but need to is user friendly.
      All I want to do is add a slight tint to the background colour of certain fields in list view when the row is not active but try as I might I just can't seem to do so. In the active state yes, but not when the row isn't active. I have made a little video that might help the reader understand my predicament, any help would be appreciated.
      https://drive.google.com/file/d/0B687aT8LAHKmRHEyZjh5OFdlSnM/view 
      Karl.
       
    • Trying to organize a company->company->employee database
      By Hoytopher
      Apologies if this is in the wrong forum, new to FileMaker and unsure of how to articulate what I'm trying to achieve.
      I am trying to reorganize a database using FileMaker. My client's work is literary, and wants to be able to sort agents/editors by their publishing house/imprint. I am using the Personnel Files starter solution, as it comes with some of the features I'm looking for, particularly the "Personnel List". A quick summary of relationships:
      Publishing Houses [House] are parent companies. Sometimes they do their own publishing, but it's often left to children companies, or Imprints. There are House-specific publishers, editors, etc [People].
      Imprints [Imprint] are composed the exact same way, with Imprint-specific People. They are owned by parent companies. For simplicity, lets assume that every House has 5 Imprints.
      Editors/Publishers/etc [People] have their own specific pages. House/Imprint use duplicate layouts (companies), same with different categories of People.
      I want to achieve the following:
      The ability to use the Personnel list to sort either alphabetically by name (as is done currently). I also want to be able to sort by Publishing House -> Imprint -> [People]. What do I need to know to do this? I envision a list of all Houses. Then, clicking on one, the imprints show up in an adjacent list. Clicking on the Imprint, People working for that Imprint pop up, and then clicking on one of them leads to their Details page (currently set up). In order to view details on the House itself, the House's own page would be set up as an Imprint.
      What are the gaps in my knowledge here? Where should I start? I am trying to create a system of increasing specification for finding data quickly.
       
    • Can I make a layout containing a card and a list simultaneously from the same table??
      By cfaber
      Hi,
      I was wondering if it is possible with FileMaker Pro Adnvanced (12 my version) to create a layout containing a list and a card (details view displaying a whole record) in the same layout, i.e.:
      - on the left side, see a list of all records (and a scrollbar maybe)
      - if I click on a line, in the right column, a details view is shown to edit the details.
      It does not work with the referenced records tool - they are not records from other tables, but the same table.
      (and sorry for maybe some odd words - I have the German version and I am not sure about the correct English ones)
       
      Does that work? Many thanks for your help,
      Claus
    • Returning to same Scroll Row on Layout
      By benmort81
      Hello,
      I am using Windows OS for my solution.  I have a layout in list view showing events. An admin user is to add groups of people as attendees of these events by pressing a button to run a script.  The script Freezes the window, changes layout, adds the attendees in the relevant table and returns the user to the original layout.
      This all works well, except for when the script returns to the original layout and unfreezes the window, the scroll position of the active row (the record that the user is editing) jumps to the bottom of the screen.  I would like the scroll position to remain static or be returned to where it was before the script changes the layout - so a change is imperceptible to the user.
      The Window Scroll options seem limited to top, bottom, pg up, pg down.  I have also tried having the script open a new window before changing the layout, but you then see the script working - if only briefly - as the new window comes to the front.
      Has anybody got any suggestions on how I can return the scroll position to exactly where it was before the script executes?
      Thanks in advance,
      Ben
    • How to, on the layouts, relate two many-to-many records
      By YannickBouanha
      Hello community, 
      I have two entities, that have a many-to-many relationship.
      I have my Computers entity, and a Users entity. One user can have many computers, and one computer can be used by many users.
      I created my Computers and Users tables, plus a join table to have the relationship. The tables are OK, and work fine, I manually tested with setting IDs.
      My problem is that, on the layouts, I don't know how to technically and concretely relate two records from each table. I tried with external portal, but when I tried, it also creates records that I don't want.
      Simple: I would like to be on the Computers layout for example, and set a field so this computer is linked to one given user. And the opposite.
      With what tools can I do that. What related field to put on which layout so I can relate a Computer with a User.
      Thanks a lot for your help !!