Richard Fincher

Moving from "Open URL" to "Insert from URL"

3 posts in this topic

I've been inserting small bits of data from Filemaker Pro into other systems we've written for some time using "OpenURL".  However, this approach works, but leaves you with a browser window open, and isn't able to see what the other system returns.  So moving to the "Insert from URL" script step instead.  This seems to work fine when the "Insert from URL" is the only step in a script, but it doesn't complete satisfactorily when "Insert from URL" is one of multiple script steps.  What could be happening?  My first thought was that perhaps the script step isn't given enough time to complete, but now I'm not sure that's the answer.

Share this post


Link to post
Share on other sites

My first, perhaps obvious, question would be: is the Insert step executing while the target field is available? The field needs to be on the layout for any of the Insert steps to work, including Insert from URL.

Share this post


Link to post
Share on other sites

And you might want to put a 0.5 second pause in afterwards, if it's a lot of data you're inserting.

If you use the FileMaker Advanced, you can use the Debugger; it will give you an error number when something goes awry. Then you can look up the error by the number and see what you need to modify.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By jamescv7
      XML error: No memory at line 1
      Greetings, this error occurred when the Filemaker API cannot generate a bunch of records. (1000+ records and above)
      I've adjusted the time out settings for PHP even the memory limits.
      Is there any possible solution for this?
       
      According to some information, the error turns out that the 10 MB XML scripts is unchangeable.
      thanks.
    • By 123
      Hey,
      I have a Tab-Separated Text File which I want to import to a database that I just created in FileMaker Pro 15. The text file essentially is a log of events, for instance, one line describes an order, another line describes a payment that has been made. The problem is that I somehow need to import all these lines into different tables. I want all lines in the log file that describe a payment in a table called Payments, and all lines that describe an order in a table called Orders for example.
      I'm just starting out with FileMaker so forgive me if there is an obvious solution that I'm not aware of. I have a background in software development, so the only solution that I can think of is writing a small program myself that does all the parsing for me and creates separate text files that contain all the orders and payments and other events that have been logged in the file. Then I could simply import each file into the table I need all the data in. 
      So to sum everything up, my main question is if there is a way to somehow parse the text file before importing it. I know that you can create custom scripts in FileMaker but I'm not sure if what I need to do can be done just with that.
      Thanks in advance,
      Mike
    • By charmcello
      I am tasked with troubleshooting a web registration form that queries a Filemaker Pro v12 database via a Filemaker PHP API.
      The web form had been running well for a couple of months after major revision, when all of a sudden:
      All dropdowns are empty All radio buttons are missing These symptoms appear to be browser-independent. The appearance of these symptoms is mysterious:
      Nobody has modified the PHP code for the web form - I've done a compare with a backup done at the time when the web form was not broken and it is identical to what is currently on the server.  The Filemaker Pro layout that the web form is querying is just fine - all the value lists for the dropdowns and radio buttons are present. I've created a stripped-down version of the web form: https://campmeetings.cccsda.org/test_form.php and I've also attached the php source code file.
      The date and record fields are populating correctly. Notice the empty dropdown list after "Church I attend."
      Could this be caused by an incompatibility between the FMP PHP API and PHP libraries on the server? Perhaps due to a PHP update on the server? Any ideas how to troubleshoot this? 
      test_form.php
    • By DeathRobot
      Hi. I am trying to script the getting of some data from a website that has an API. I have BaseElementsPlugin and was given an example bit of code by the website:
       data = {'domain': domain, 'include_generic': True}
                  headers = {'X-Api-Key': 'xyz123'}
                  resp = requests.post('https://api.anymailfinder.com/v3.0/search/domain.json', data=data, headers=headers)
      I have never dealt with this kind of programming and am not even sure where this info would go or what script step(s) I would use to call this. Is this CURL? Are you aware of sample FM scripting that I could use as a model to figure this out?
      Thanks for any help with this!
    • By fm8443
      I have a simple Applescript that works in Script Editor
      tell application "Keyboard Maestro Engine" 
      do script "Search the Web" 
      end tell
      I add this same script (with escape chars) to my RESOURCES::A_SCRIPT field inside FM.
      The RESOURCES table is not connected to the other tables in the graph.
      "tell application \"Keyboard Maestro Engine\" 
      do script \"Search the Web\" 
      end tell"
      I've tried this with this field being defined as a Global Storage Field or not.  Similar problems with both.
      I have an FM Script called EXECUTE:
      Perform Applescript (RESOURCES::A_SCRIPT)
      When I run this FM Script I get an error message:
      "Error: -2741" / "Expected EOL but found Command Name"
      I've have tried rebooting my Mac.
      Any ideas?