34South

Container export to IOS Photo app?

2 posts in this topic

I have developed a solution for IOS devices which also utilizes scripts that facilitate importing of GPS coordinates and especially photos from the device, i.e. iPhone or iPad, within FMGo. Although I have scripted the possibility of emailing images originally captured by the solution outside of the solution, there does not seem to be a possibility for exporting the captured image to the Photos app and thus pushing them to the iCloud. I know one could first capture the image in the Camera app and then import it into a container within the solution, but this distracts from the all-in-one nature of my solution, where quick image capture is paramount. Ideally, the user would use the solution to capture the image and related contextual data, but also elect to save such an image in the Photo app at a later stage to permit sharing it to social media apps, for example.

 I'm fairly advanced, having used FM since the Claris days.

Share this post


Link to post
Share on other sites

I guess the App extensions addition to FMGo 15 accommodates saving to the Photos app, as well as direct sharing to FB/Pinterest/Twitter etc., although still not scriptable.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By Goons
      Really new to using FileMaker Go 15 and can't seem to find the way to copy files to the device so I can input data while offline.
       
    • By Oyseka
      Hi All, I am developing a system to produce, among other things, Quotations and Job Cards in a mixed FMP and iOS environment. One to the problems was the lack of support for autocomplete of drop down lists in iOS which I have tried to get round, with the help of this community, by using a filter from a cartesian join relationship. I now find that when more than one person is creating a quote on a mobile device from the hosted file that you may end up with other peoples input in your QuoteItems table for the quote you were creating. Can any one tell me how to change the relationship ,(design), to stop this.
      On a desktop system the flow is:
      From the Customer - create Quote - Quotation Table
      In the Quotation Table use the portal into QuoteItems to select the Department, Product and Quantity

    • By WF7A
      Howdy, all:
      I'm looking through the documentation and the forum here, but I can't see a way to export records using a scripted filename in FM Go. If I'm not mistaken, it only allows you to use the file's name.
      What I'd like the user to be able to do is fire a script that exports a table's records using the table's name as the filename.
      TIA for your help!
    • By Wickerman
      I have a nifty little backgammon quizzing solution set up for FMGo that shows images of game positions and you tap on the image container to view the solution  below. This works by toggling a simple text field from empty to 'Show' when you tap the Problem image.   I've used the calculation  IsEmpty ( Positions::z_SolutionToggle ) in the 'Hide Object When' option in the inspector for three items on the layout:  A Text Field giving the simple answer, a Container Field with a picture of the proper solution, and a Web Viewer for displaying comments about the proper play. Tapping the Problem image toggles the control field empty again, hiding the 3 items.  I have an 'On Record Load' script trigger set up to clear the toggle field so when you go to the next problem the answers are hidden.
      All three items work just fine in FMP my desktop.  On the iPad in Go, however, the Web Viewer is glitching in a particular way.  The tapping to show/hide works fine - - but if I have the answers revealed and tap for the Next problem, the web viewer fails to Hide itself, while the other two objects hide  as expected.  The data in the web-viewer *does* update to the text for the fresh problem -- it just doesn't hide itself.  The other tw items vanish, but it stays there, displaying the new comments.  Tapping the Problem pictures toggles the other two items into view as planned, and another tap hides all three, and moving to the next problem, they all remain hidden as intended, so it is only when going frrom the Revealed state to the next Hidden state that the web viewer falls down.
      The contents of the web viewer are drawn from a text field using this data URL I gleaned from a thread where web-viewers were offered as an alternative to fields with scrollbars in GO because scrollbars don't work so well in GO:
      "data:text/html," & "<html><style>*{ font-family: arial, verdana, sans-serif; font-size: 16px;}</style><body>" & 
      Substitute ( GetAsCSS ( Positions::Comments ) ; "¶" ; "<br />" )
      & "</body></html>"
      I have the 'Allow Interaction' and 'Automatically encode URL' boxes ticked.
      Any suggestions for fixing this bug?  Thanks!

    • By IT_User
      I have already posted here:
      https://community.filemaker.com/thread/170677
      and have some thoughts in mind, but I will copy what I put in there, here.
       
      Avoid FMGo Connection Interrupted
      Server Timeout Disconnect
       
      In the attached links, it goes back to questions that I had that dealt with a file on an iOs device, making sure it stays live and up to date.
       
      So what I have done is worked on a local file that syncs to the one on the server.
      That seemingly works, however there is a problem that just recently came up when I was testing. When the local file tries to reach the file on the server, it doesn't always connect.
      In talking with others there is two consensus of what might be the cause:
      The Wireless access point is blocking access File security permissions are not working (File Access tab in Security) "Reset All" temporarily works (on the server file) Deauthorizing and Authorizing sometimes works (on the server file) Turning off the File Access requirement doesn't seem to help (on the server file) I do have File Access on the local file, but I haven't tried turning that off.
      Since I can't debug exactly what is going on, on the iPad this makes it harder. (I have put in some custom dialogs to see some things.)
      The local file with the syncing to the server file works on my desktop, but that is a wired connection. (I could try the same wireless connection.)
       
      It could be that I'm making a duplicate of the local file and putting that on the iPad, which makes the file not work.
      (I put on the duplicate file on the iPad newly each time for testing, because I need a file without certain info on it, which will be filled later [dealing with Get(PersistentID)].)
       
      Is there something I'm not thinking of?
       
      To my knowledge, it had been working until recently.
      I'll try a few more things, but hopefully get answers in the meantime.
      Thank you