Jump to content
Sign in to follow this  
Dave MM

can see server from Filemaker Pro, but files do not show as available on the server

Recommended Posts

I'm running Filemaker Server 10 on a Windows 2008 Server box. From the Filemaker Pro clients, if I choose File -> Open -> Remote - I can see the server - but the databases/files I am hosting do not appear. I'm not sure where to go from here:


For years, we ran Filemaker 9 Server on an SBS 2003 box. We had Filemaker Pro 9 on the desktops, and we had no problem using the Filemaker Pro client and going file -> open -> remote and clicking on the server name in the left hand pane and the files in the right hand pane. We only used it as a database server - not at all web publishing.

We recently upgraded our server from SBS 2003 to SBS 2008 which is of course Windows 2008 64 bit. I have Filemaker 10 Server, and since FIlemaker 9 is not certified on Windows 2008, I installed FM 10 Server. I installed Bonjour 64 bit, and the install seemed to go fine and all the files are open (I first tried copying the files to the databases folder) and then I removed them and did an upload a database task. In each case, everything looked normal. Of note - in case it was an issue with 64 bit, I also have a spare server with Windows 2008 Server 32 bit on it, so I also tested in that case and got the exact same results on the client. See below.

On the client (all Windows XP) with Filemaker 9.0.3 Pro, if I click File -> Open remote, I see the server and its IP address in the left hand pane, but where I used to see the databases/files to open - there is nothing. Not even the sample file - which I think used to be there. I have brought down the files to the local workstation and opened them to check the file sharing - and it is indeed on. I have even turned it off - closed - reopened - turned on sharing again and closed again and then re-uploaded/added the databases to the FM server. I have also tried using Filemaker Pro 10 as the client - same result. I can see the server, but I can't see the databases on the server.

I'm at a total loss. This should be pretty easy, but I'm just not seeing the databases in filemaker pro. Any help is appreciated.




Share this post

Link to post
Share on other sites

this turned out to be super easy. It was a firewall issue. My clue was that I installed FMS and FMP on the same machine. On FMP, while I was on the machine, I could see the files in open -> remote - but on other machines on the LAN, I could not see the files.

After I opened up ports 5003, 16000, and 16001 - the other machines on the LAN could see the files on the server. I can't complain, it's in installation documentation, but no one really reads that anyway. There should be a dialog box that comes up during the install. Anyway, all fixed.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use.