Jump to content
Sign in to follow this  

Perpetually creating blank records

Recommended Posts

Hi All


I am experiencing a very odd problem with a web form we created for our clients.


The web form worked absolutely perfectly on the Apache server we started the clients off on. We're now trying to move them to a new IIS server on a much more powerful machine, however there have been some issues. On entry of the first page a record is created in the database & when the form is posted, that record is edited & continues to be edited on subsequent form pages after filemaker's record ID and the primary key are stored as session variables. NOTE: There is an included page prior to the code I have entered below which sets $ID & $recordID to the value of the session variables for the ID's.


A few items of code had to be re-written & these elements now work fine, however I have just noticed a new problem & I have no idea how it is happening...


The first step on the first page is to test for the existence of 2 variables. If these variables do not exist a record is created in the database and the 2 variables are set (see below).

if (!isset($ID) AND !isset($recordID)){

	$stepTwoEdit = $fm->newAddCommand('webCandidateFormStepTwo'); 
	$result = $stepTwoEdit->execute();	
	if (FileMaker::isError($result)){
		echo $result->code;
}//if record has not yet been created in the database create it so that we have an id

Now this code works perfectly. I have echo-ed the variables onto the page and they are being set correctly & I have done tests to verify that the newAddCommand is only being performed once by echo-ing text inside the if statement.


So it appears to all be working correctly, until you go and look in FileMaker.


Blank records are being continuously created by the server, despite the fact that the newAddCommand is not being repeated. This command is called once and only once. These records are not just created on page refreshes or on navigation between form pages - they just keep being created every x seconds (there's no consistent interval)...


Any ideas?!? Really need to get these clients onto our new server asap, so help would be massively appreciated!


Thanks in advance!



Share this post

Link to post
Share on other sites

The code shown appears correct.  Copy this snippet to a new test file (with the proper FM access prefix) to confirm.


The next place to look is if the If() statement shown is inside a loop, or if the entire PHP script is being called repeatedly by another script.

Share this post

Link to post
Share on other sites

Or if Clients are just hitting Refresh in their browsers...


Personally, I'd start the session at the beginning of the page and test for the session variables...




Share this post

Link to post
Share on other sites

Hi Guys


Thanks for your responses!


doughemi - I think that's my next step - to start picking out bits of codes and run them separately to try an identify what the problem is.


There is no looping anywhere on the page except when I'm picking up value lists much further on in the code & there's definitely nothing else triggering this...


webko - refreshing should not be an issue - even if the user refreshes the page the session variable has already been created therefore that if won't validate to true and the newAddCommand won't execute. I've tested this by echoing text inside the if statement - on page entry the text is there, but when I refresh it's not as the session variables have been made and the if does not validate to true. Also the session is started at the beginning of the page - aside from connecting to the DB & a couple of other miscellaneous bits.


The weird thing is that on the first page load I can literally sit and watch blank records slowly being added to the database even if I don't refresh the page, it just slowly starts creating the records and does not stop! It's nuts!





Share this post

Link to post
Share on other sites

Do you have a redirect anywhere on the page?


I've managed to create a loop between two pages that redirected to each other before...

Share this post

Link to post
Share on other sites

Hurrah! Finally gotten round to having another stab at this... And I've only gone and fixed it!


Default document for the site with the form on was set to the first page of my form where the record was being created....


I changed the default document to a blank html page and BOOM - problem solved.


Thanks for your help guys!

Share this post

Link to post
Share on other sites

Ah... that would indeed do it ;-)


Good catch

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use.