Jump to content
Sign in to follow this  
michele

Script on button in portal row doesn't show in DDR

Recommended Posts

michele    0

Hello,

 

I just discovered something scary.  I wanted to check if a specific script was used on a layout as I wasn't sure anymore.  So I created a DDR.

 

When checking the script in the DDR the 'Layouts that use this script' and 'Scripts that use this script' parts were empty.

Still I felt a bit unsure about deleting my script, so I searched for it manually on my layout and...I found it.

I used it in a portal on a button (=text).

 

Is this a known bug of the DDR or did I miss something?

Share this post


Link to post
Share on other sites
Ocean West    103

curious did you give the button object a name? - wonder if doing so would force it to be included in the DDR?

Share this post


Link to post
Share on other sites
BruceR    152

Your description is unclear. Can you provide an example or provide a more detailed description? What is "button (=text)" ?

Share this post


Link to post
Share on other sites
Wim Decorte    446

Was this an HTML DDR or an XML DDR?

 

The HTML DDR is a translation of the XML one so it could have been missed in the translation.

Share this post


Link to post
Share on other sites
comment    1,371
When checking the script in the DDR the 'Layouts that use this script' and 'Scripts that use this script' parts were empty.

...

Is this a known bug of the DDR or did I miss something?

 

Hard to tell without being able to reproduce your issue.  Which I cannot do:

post-72594-0-31594300-1405914810_thumb.p

Share this post


Link to post
Share on other sites
michele    0

I need to apologize.  The DDR consisted of different parent folders and I appear to have a script with the same name in another parent folder.

@Comment it's your picture that made me go back to the DDR to take screen shots and realise there was something different going on. 

I should have tried to reproduce the error myself but I was 'stuck' staring at the script name.

 

Thank you all for your replies.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • By Keith McKay
      I have two tables, A & B, with similar fields.  I want to write a script that will search table B for records that match the fields that are entered in table A.  I am not sure how to do this.  Any suggestions?
    • By Dave Ramsey
      Since FileMaker 16 now exports a plugin "source" code with the DDR (even if the plugin is not present) for plugin script steps, it would be helpful to have a way to identify a plugin based upon this "source" code.  It would be immensely helpful if developers could provide this information.  
       
      For reference the "source" code that I'm talking about is "FMmp" in the sample plugin source code.
       
      In the interest of gathering this information, I whipped up a Google Form for data collection.  To reduce misuse, this form is entry-only.  Once created, there is no way to edit a record.  If the information changes over time (say, you would like users to go to a different URL), just make a new record.  I can't speak for everyone else, but FMPerception will likely be using the last record available for each source code.
       
      At some later date, this may be expanded into a larger registry, but for now I'd just like to get some data.  Follow this link to fill out the form:
      FileMaker Plugin Registry Form
       
      I don't have any interest in being the only person with access to this information, so if you would like to view the results, feel free to click here.
      Plugin Registry - Google Sheets
       
      If there is some other registry, just point me to it, and I'll apologize for the distraction.
       
      Thank you very much.
      Dave Ramsey
       
      P.S.  Here's an example of how it looks when FMPerception knows about your plugin:
       

    • By DreadDamsel
      Hi. I'm using FMPro 12 Advanced.
      Creating a database for our community centre and I need to add a membership number to contacts - but not all of them.
      I've created a separate table for Membership numbers (as not all contacts will have one, so serial numbers aren't appropriate).
      Each membership has a number of details fields.
      It's probably a REALLY logical and stupid problem I'm batting against - but I need to:
      Select a contact>go to their details>add a membership number (go to a floating window layout, enter the details to the serial-number-derived membership) and have the details including the number show up in a tab on the contact's details layout.
      I've created a relationship between my contacts file and my membership file via the Contact_ID>Contact_ID_fk and have played around with other relationships. 
      I've also created a simple script from a button on the Contacts membership tab to go to the Membership Layout window and create a new record. But it keeps creating a new record in the Contacts, not Membership - even though the relationship only has to create new records in the memberships side.
      I'm now running around in circles - please can anyone help me out here?????
    • By Julio
      Hello,
      I have a weird issue that just started happening when I use the 'Print to PDF' script step in a loop.
      I have a script that passes through and prints out a set of pages. When I use the script Debugger and when I reach the spot I am having issues with, I can see, during the preview, that it is in the correct record; showing the correct page, but once it is done and saved as a PDF, it is showing the first record that was browsed.
       
      I have attached a snapshot of the script I am using.
      If you notice, I have it go to the layout First, Performs a Find based on a Variable - It finds the proper records.
      Then it goes to the first record, (for this example, lets say record # 36)
      Starts a loop and saves the record being browsed to a PDF. Then it moves on to the next record in the found set.
      The Custom Dialog which SHOULD show the next records ID, does not. It still shows record #36.
       
      I have no clue as to why. Even though as I go through each script step and I can visually confirm it is moving to the proper record in the FileMaker client, it does NOT save the proper Record.
       
      If I switch the option on the 'Save Record as PDF' from Current Record, to records being browsed, it saves the proper records to PDFs, but it duplicates them 3 times and does not set the proper page numbers.
       
      Attached is also the end result
      The Observ ID: should be 36, 37, 38 but all three pages stay at 36 showing the exact same record.
       
      Thank you all for your help.
       
       
       
       
       
       
       




    • By dysong3
      I have a number of scripts that have worked perfectly for years in previous versions of FileMaker, however in FMP 15 they causse FM to crash.  They only way I have found to avoid the crash is to use the debugger and to use the "step into" button.  That of course is a very cumbersome workaround. You can see one of the culprits below.  Anyone have any ideas what's wrong here?
       
       

×

Important Information

By using this site, you agree to our Terms of Use.