Jump to content


Popular Content

Showing most liked content on 02/10/2017 in all areas

  1. 1 point
    This thread seems to be stuck in a loop.
  2. 1 point
    There are a couple of issues with 0x00 it can not be inserted with Char( 0 ), Substitute ( fieldname; Char( 0 ) ; " _There was a 0x00 here_ " ) it can not be substituted by Char( 0 ) as in the example directly above, also tried pasting the 0x00 that looks like a line break in FileMaker into the script as follows Substitute ( fieldname; " " ; " _There was a 0x00 here_ " ) when copy pasted it sometimes become Char( 13 ) – 0x00 is untouchable in many ways. 0x00 is an invalid search criteria when copied from a field in browse mode and pasted into the same field in find mode In essence Char( 0 ) means end of string, it is fully capable on making its way into a FileMaker field, actually it probably is what terminates all FileMaker fields. It exports fine to FileMaker files. #include <stdio.h> int main () { char greeting[6] = {'H', 'e', 'l', 'l', 'o', '\0'}; printf("Greeting message: %s\n", greeting ); return 0; } After copy / pasting using the keyboard into the same field Char( 0 ) turns into Char( 13 ) [ Solved ] When Checking the box "Apply current layout's data formatting to exported data" for formatting the issue of 0x00 is no longer present for XML exports.
This leaderboard is set to Los Angeles/GMT-08:00

Important Information

By using this site, you agree to our Terms of Use.