Jump to content

Rook183

Members
  • Content Count

    12
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Rook183

  • Rank
    newbie
  1. I have a solution running on a Filemaker 16 server. I have accessed the server via VPN on a remote Mac and now want to access the data via ODBC on that remote Mac. I have turned ON ODBC/JDBC for ALL USERS in the Filemaker file I have downloaded ODBC Manager – the free version But when I try access the Filemaker "System DSN" in the ODBC Manager, nothing appears. This is a mystery to me as this exact (and rather simple) setup works perfectly on my local network. I originally set up the local network some time ago, so: • Have I missed a step? • Does the ODBC not work
  2. Perhaps you could just point me in the direction of a sensible tutorial on access security as my queries are really beginner queries and should be easily answered by a basic tutorial Cheers
  3. Thanks for your input. Since I am self-taught I often mix up scripts and calculations – and I apologise for that. However… The table does return no records (rather than entries with "NO ACCESS"). This might be because I also have a script which triggers when the layout loads which searches (by the same global variables) for records that user is allowed to see. This actually works fine (though it is probably clumsy in pure scripting terms). In other words, without even using access privileges, the user can alway only see what I want them to see – except when they invoke quickfind
  4. I am sure this is one of those simple ones… that has me bamboozled for nearly 2 days now. I need to limit access of my users viewing only a limited set of "Company" records after they log in. The companies that they are allowed to see are listed in each respective user's profile. My opening script goes to the user's profile and creates a global variable for each company that they are allowed to view. When I go to the "Manage Security > Edit Privilege Sets > Records > Custom Privileges > Limited > Script", and use any of those variables (e.g. $$Company01"), the rec
  5. Bingo! Embarrassingly easy and obvious. The layout option is still there, but nothing shows. Many thanks.
  6. I want to remove the layout option on the menu header bar since, basically, I do not want the user to be able to change layouts except through the my built in navigation. Is this possible?
  7. Thanks for the feedback. I will work through our great advice and let you know how it goes
  8. I have a frustrating problem. Is there someone out there who can advise me. I have a set of records in which a table is an important element. The table draws content from related records. In the regular Filemaker viewer, it is in a portal. However, I need to make the data available on a print layout in Webdirect. The table might vary from 1 row up to about 20, depending on the record. I have tried several methods of getting the data onto the layout but have a conflict as follows: If I aggregate the table in a field before brining it into the layout, it elegantly merges into
  9. i actually posted this problem twice, once by error in the windows section and one, correctly in layouts. the other post received a simple reply – to leave date as formatted on the format>date section. this sort of fixes the problem (it now displays the correct date. however it prevents me from diaplying the date the way i like it (ie 03/11/2009), since the default format is 3/11/2009 – no leading "0" on the day. i have always customised my date format this way and cannot understand why it gives me this problem now. any ideas
  10. that simple… many thanks. it solves my problem, but what if i wanted to have the date formatted in another way? i still do no understand why filemaker would change it this way. it now displays the correct date. however it prevents me from displaying the date the way i like it (ie 03/11/2009), since the default format is 3/11/2009 – no leading "0" on the day. i have always customised my date format this way and cannot understand why it gives me this problem now. any ideas
  11. i have an extraordinary date display problem. i have a simple date field (not a calculation field) displayed in a portal. regardless of what date i enter, it displays the 9th of that month (eg 27 august displays as 09/08/2009 (dd/mm/yyyy format). when i click on the field, it highlights and the correct date displays, but when i click off the field, it reverts to the 9th again. see attached .png files. any suggestions?
  12. i have an extraordinary date display problem. i have a simple date field (not a calculation field) displayed in a portal. regardless of what date i enter, it displays the 9th of that month (eg 27 august displays as 09/08/2009 (dd/mm/yyyy format). when i click on the field, it highlights and the correct date displays, but when i click off the field, it reverts to the 9th again. any suggestions?
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.