Jump to content

Menno van Beek

Members
  • Content Count

    11
  • Joined

  • Last visited

  • Days Won

    1

Menno van Beek last won the day on July 29 2013

Menno van Beek had the most liked content!

Community Reputation

1 Neutral

About Menno van Beek

  • Rank
    member

Profile Information

  • Gender
    Male

FileMaker Experience

  • Skill Level
    Expert
  • FM Application
    16 Advanced

Platform Environment

  • OS Platform
    Mac
  • OS Version
    Sierra + Windows 7/8.1/10/2012/2016

Recent Profile Visitors

2,002 profile views
  1. Menno van Beek

    SSL certificate for internal machine

    I honestly don't know. As I wrote, my domains are public and I use Lets Encrypt. My setup is like this: I have one Linux webserver where I host several websites, including the domain-names I used on my 3 filemaker-servers (2 x Windows 2012 and 1 Windows 2016). The certificates are renewed automatically once every three months and once every 3 months I import the renewed certificates in my FmServers. My router runs also an internal DNS-service and only 1 FmServer is actually reachable from the external internet. The internal DNS-server routes all internal call to any of the FmServers directly to the appropriate server. Internally in my network I can run Advanced/Pro/Go and WebDirect with Green locks. Externally I can connect using Advanced/Pro and Go only to my first FmServer, the other domains cannot be reached with an FM-client. CWP and Webdirect can be used for all 3 domains, but that is achieved by the reverse-proxy I have running on my Linux-webserver. As you can understand I don't have a typical setup, but it works fine for me, mainly because I have the webserver that requests the certificates for me and auto-renews them. The only thing I do is to import the new certificates every now and then. I think if you'd like to try a setup similar like the one I have, that you may consider running a dedicated webserver somewhere (doesn't have to be on premise) and copy the certificates you have been issued for that webserver to your FmServer. Make sure that the FQDN is used on that FmServer is the same as you "specially dedicated" webserver and configure your internal DNS to route all internal calls to FQDN directly to the FmServer in stead of the webserver. In essence that is what I did in my setup. kind regards, Menno
  2. Menno van Beek

    SSL certificate for internal machine

    Maybe you can check out: https://www.globalsign.com/en/blog/certificates-for-internal-servers/ and https://www.globalsign.com/en/ssl/intranetssl/ to obtain a GlobalSign IntranetSSL certificate. I have not used it myself, I use Lets Encrypt, but my domains are public so I personally don't have your problem. Hope this helps you :-)
  3. I have this exact same issue with Scribe version 3.0.5 . I did a few tests to see which plugin causes the most problems in terms of starting FM and to see if there's interaction with other installed plugins. All tests (30) were done with FMP Advanced 15.0.3 on MacOS Sierra and FMPA15.0.3 on Windows 8.1. The Mac is 2016 MBP 15" and the Windows is a 2012 HP Elitebook 8570p. Both machines i7, both 16GB ram and both 2TB SSD. Both machines were on the same network and had a VPN with all traffic directed through the VPN to the same VPN-server. It would be nice if there was a scriptable way to load and unload plugins, but FM hasn't got any commands to do that, besides the Download-plugin script-step. See the attached file for my measuring results. As you can see in there is quite a bit of interaction, but even with only the scribe-plugin loaded, the starting time on MacOS goes up to 65 seconds. Yo can also see that on Windows there is some influence, but that is all less than 10 seconds and that is totally acceptable. PluginBounces.xlsx.zip
  4. When updating any 360works-plug-in it is deactivated after any update. Sometimes it does not even is replaced. I have created batch-scripts to shut off FileMaker and then remove any 360works-plug-in. After that my user(s) have to restart the application again and the new version of (any) 360works plug-in is installed correctly and activated automatically. I also use other plug-ins by Troi, Dacons en Goya simultaniously and these work perfectly fine and also will be updated and activated when a newer version is being installed. Only the 360works-plug-ins fail to update everytime. I use the script-step "Install plug-in file" so nothing exotic is done there. The problems occur on windows 7, 8, 8.1, 10, 2008 and 2012. On the 32 and 64 bits versions (2012 - 64-bit only) Any suggestions or anyone else has the same trouble?
  5. On windows 8 the command EmailSend returns the error: Invalid Addresses The very same database-, record- and script-combination works just fine on windows 7, so it must be a problem with Windows 8 I am using FMP(A) 12v4 with JRE 1.7v25 and Email-plugin version 1.972 on Windows 8 professional. I've tried this in 2 different network where there are an exchange-smtp-server and a postfix-smtp-server. Using any of these servers result in the same: it works on Windows 7, but not Windows 8 I allready had contact with support about this issue and I thought it was solved, but it seemed to have worked only once and now I get the invalid addresses error again. For now my customer only uses Windows 7, so there's no pressure yet, but I am running Windows 8 and must assume the code I write just works cq have to fire up an old windows 7 pc to check if it works, before I deploy my solution to the customer.
  6. Menno van Beek

    New JRE 1.7v25 doens't work with plugin

    I have had the same issue with both the email-plugin and the scribe-plugin. I did not want to go about the customer's company-building to manually remove plugins from 20+ workstations, so I created a batchscript that I export to the temporaryfolder from a containerfield and set it to open immediatly: ping -n 2 127.0.0.1 > nul taskkill /F /IM "Filemaker Pro.exe" ping -n 2 127.0.0.1 > nul CD C:Users%username%AppDataLocalFileMaker DEL /S /F 360Works* exit After this the plugins are removed (for XP you may need to alter the path in after CD), filemaker has to be started again. Your autoupdate-scripts should now push the new 360works-plugins to the workstations. Hope it helps you, regards, Menno
  7. Filemaker crashes inmediately when i try to register the plugin with EmailRegister ( "Reg-code" ; "Company" ). I use version 1.964 I have cleared the java-cache en removed all old applications, all that doesn't help. We heave tried this on 32 and 64 bit Windows7 systems. Ik have re-installed JRE 1.7v21 and told my users to do the same and then there's no crash anymore. regards, Menno
  8. Menno van Beek

    Connections to IMAP with ssl fails

    Outlook, Thunderbird, AppleMail are the regular client that I have used to test this and where it all worked fine as did webaccess, so the credentials where OK and still the emailplugin didn't connect. For the internal network (where this is running) the users now may connect without SSL and that works OK now.
  9. Hi, I am trying to connect to a exchange-server using IMAP with: EmailConnectIMAP ( "exchange.server:993" ; "user" ; "*****" ; "ssl=1" ) and the connection fails with this error: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target how do I solve this .... regular emailclients connect to this server without any trouble (same account-settings), so I'm pretty sure I should solve this on the Filemaker-/Plugin-side .... only I don't know how. regards, Menno
  10. Thanks for your reply, but Scribe stands out with the posibility to write values, so will it support writing carriage-returns in values in the future? Regards, Menno
  11. When writing an address to a worddocument with ScribeDocWriteValue ( name ; value ) all ¶'s are "converted" to spaces printing the address as one line (I've of coarse made sure that in the field-properties in word the "allow multiple lines"-option is selected for this particular field). I've tried changing the ¶ to \n and <br/>, but that's literally written to the worddoc. For the time being I have a workaround by cutting up the address in several fields, but that's not a long term solution (different countries use different mockups of an address). Anyone knows how to solve this ? regards, Menno
×

Important Information

By using this site, you agree to our Terms of Use.