Jump to content

Ben_TFS

Newbies
  • Content count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Ben_TFS

  • Rank
    newbie
  1. Ben_TFS

    System Script user account

    Hi Olger, Yes it is a permissions problem, which is why I am trying to get a script to run using an admin account. The point I was trying to get across with this script is that it will run if I use the default account but will say it is "missing or invalid" when trying to run it using admin credentials. The actual script sequence I am trying to set up definitely does need admin permissions in order to work.
  2. Hi There, I am writing a system script that needs to be run using an admin account on a Windows Server 16 machine. However when I try to set this up it says that the script is missing or invalid. The login details I am entering are to an admin account on the local Windows Server 2016 machine. I have tried both these, and the default administrator account. If I try to enter the login details for the FMS16 account it says Invalid account. For now I am just trying to run a test script. This script executes successfully when I run it manually as well as when I schedule it to run using the default account. Code in test.bat: @ECHO OFF PowerShell.exe -NoProfile -ExecutionPolicy Bypass -Command "& 'C:\Program Files\FileMaker\FileMaker Server\Data\Scripts\test1.ps1'"; Code in test1.ps1: $put = "C:\Program Files\FileMaker\FileMaker Server\Data\Scripts\test.txt" $filecontent = "Hello World" $filecontent | Out-File $put -Encoding ASCII Screenshot 1 shows the option I am talking about. For the test if I do not tick this then it executes fine. Screenshot 2 is showing that it comes up as missing or invalid.
×

Important Information

By using this site, you agree to our Terms of Use.