Jump to content

Mif

Members
  • Content Count

    122
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Mif

  • Rank
    ..everlearning

Profile Information

  • Gender
    Male
  • Location
    Toronto
  1. I have 2 tables, One ESS SQL table and one Filemaker table related by "shop_product_item" ID. Table A is set to "allow creation of records...." in Table B (related throughout table occurrence shop_product_item15....) Table A. name = "shop_product_item" (SQL Ess connection) Field A1 - "is_published" (Auto enter calc - "Case (shop_product_item::in_stock = 0 and shop_product_item15_ShopProductItem_ID::z_unpublishAtZero = 1;0;1)" Field A2 - "in_stock" Table B. name = "ShopProductItem" (Filemaker table) Field B1 - "z_unpublishAtZero Problem - when SQL Table A > Field 2 "in_stock", changes to zero, Field A1 -"is_published", doesn't change to "0" If I change "A2" (in_stock) to "0" manually, "A1" changes to "0" How do I trigger the calculation in "A1" when SQL changes "A2" to zero?
  2. I can't seem to get a horizontal line separating repeating fields, to show up using IWP. Works fine from FM client but not from web view. Any thoughts as to why? I've tried different thicknesses, colours, browsers and I am using the classic theme. Thanks
  3. It only seems to work if you want to use it with one field, and only if that field is in the tab order. By the way, I tried the "Go To Object" with "Get Script Parameter", and yes it goes to that field, but still can't get that cursor flashing in the field. It just highlights the field border.
  4. I can see how my question looks a little confusing. Let me give it another try. I have two fields on a layout, FirstName and LastName I want to be able to click in either of the two fields, invoke a find and end up in find mode with the cursor inserted and flashing in the field I clicked in. (The whole problem seems to be getting the cursor to remain in the field I selected. If it is the only field in the tab order, it works fine. If both fields are in the tab order, the cursor flashes in the the 1st field in the tab order. If none of them are in the tab order, neither gets a flashing cursor.) (My original question was around trying to grab the field name as a variable or through script parameter and then scripting a "Go to field" to get the cursor inserted in the field I want.) Thanks
  5. My goal is to have a generic script which enters find mode, goes to "x" field so I can keep my script population down. I am attempting to do this based on the script parameter for the button launching the script, but it seems that the "Specify" option only related to a repeating field. Am I on the right track or is there a smarter way? If I'm on the right track, what am I missing here?
  6. I have since noticed that crashing is what has caused it for me as well. There must be a temp file somewhere that contains the data.
  7. Anyone know where I might recover a bunch of handy calculations I have always had listed on the "Watch" tab of the data viewer? Any idea how they dissappeared? Thanks
  8. Thankyou, that worked perfectly. Believe it or not, today I am experiencing the same thing from my MacbookPro - Is there a similar setting there?
  9. FM 11 - 20 clients running off Server 11 and using Windows XP 2 - While in find mode, three of those clients can't see what they are typing until they click out of the field. This is only happening in FileMaker. No strange behaviour in any other programs. Windows administrator checked that everything is the same on machines with and without the problem. Measures taken: 1. Made sure hardware and Windows settings matched between machines 2. Made sure FM memory settings were the same. Because it looks like a refresh issue, I wondered if this had something to do with the way the client was communicating with FM server. Sorry if this post is in the wrong forum.
  10. I am working on a solution with a very large relationship graph. The last 1/8 of the graph only shows the TOG connectors and none of it is editable. I have tried two things. 1. increased memory up to 256 - but no changes 2. accessed file remotely in 2 different ways. a/ VNC direct to client server (Mac Mini - 2G ram - fm Memory set to 256) b/ on macbook pro (4gig ram - FM memory set to 256k), via filemaker network In both cases, exact same result. At the breaking point, just one scroll arrow click downward and TOG's lose text and editablity. (see attachment) I also have gone through the entire graph and minimize all TOG's which should have freed up some memory but still same problem at same location. Any suggestions?
  11. Thanks Comment, that worked fine. Another example of the "blinding flash of the obvious". Maybe I wasn't pausing after entering find mode, which made me think that it wasn't entering the field....hmm?
  12. I've tried making the field a button as well as script triggering based on entry, keystroke and modify.
  13. I find if I just use Enter Find Mode [] that the cursor isn't anywhere to be seen. What am I missing? I'd like the cursor to be flashing in any field I click on the screen.
  14. My goal is to click in a field, and end up in find mode with the cursor in that field, type a request, and hit enter to perform the find. So far I have created this script launched by the field: Set Variable [$Fieldname; Value; (Get (ActiveFieldName))] Enter Find Mode [] Go to Field [] -"it is here I want it insert $Fieldname" What should I be doing?... Thanks in advance
  15. I found the answer. This occurs when custom menus are activated, in which case I have to make sure I am in layout mode before entering the relationship graph.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.