Jump to content

mecchaeric

Members
  • Posts

    33
  • Joined

  • Last visited

mecchaeric's Achievements

Contributor

Contributor (5/14)

  • First Post
  • Collaborator
  • Conversation Starter
  • Week One Done
  • One Month Later

Recent Badges

0

Reputation

  1. Thank you. I ended up creating newCompanyID field (in database whose records i'm importing), and renumbered it. Then, I created newID fields in all other related files and based on current relationship(s), renumbered them. I did offline, as a test, and it seemed to go very well. Once I test it a few more times, check it many times, etc. I'll then import these records w/ renumbered ID's into THE main databases, using newID fields when importing. Again thank you all.
  2. Thanx for your response. Please read my previous post for background. Trust me, I've thought about this many times and for many months. Is there a better way? I believe I understand your idea though, and It sounds great to me. I'll def be trying it (on offline Db's, of course, which is what I do for all MAJOR development). As for backups, oh yeah, no worries there either. My databases are backed up every 1/2 hr to separate hard drive, every night to separate hard drive, to my Mac weekly, an external hard drive weekly, burned to CD weekly, brought offsite weekly, etc. Thank you again.
  3. Basically, when I came on board there were 3 Companies databases and 3 Employees databases and 2 Call Log databases. I've decided to perform merge, so there is one Company database, one Employees database and one Call Log database. They are all centered around CompanyID and Employee ID. However, before I merge the databases, I need to resolve the fact that there are overlapping CompanyID's and Employee ID's, which will result in dupes in the main Companies database (the one I'm merging others into). I hope this is clear. Is there a better way? Again, thanx to all in advance.
  4. I obviously know how to renumber a field in a particular database using Replace Field Contents. However, I need to "renumber" a related field called CompanyID in the Companies database, but have it change its related CompanyID in the Employees database to be equal, so relationship is not lost. In fact, there are several databases where related CompanyID resides, and I need all related databases w/ CompanyID to update as well. How do I do this? Any and all assistance would be greatly appreciated. I wan't sure where to post this so forgive me if it wasnt best to post it here.
  5. FYI: This is in response to all posters (and I appreciate all posts). First off, what is the point of a Forum of any kind when so many members respond with something to the effect of 'look it up in FileMaker help docs' or try 'reading a FileMaker book' or 'search the forum on keywords first'? Believe me or not, I did all three. I own a ton of books on most everything I deal with. I make it a point to. However, sometimes, even finding the info doesn't quite give you answer you're looking for or doesn't seem to do so clearly enough. As for Forums, a lot of posters talk more technical then they have to, or at least, have to to me. Ultimately, you post a topic w/ details re: your own question/issue/situation, and hope its answered more clearly and to the point. Thirdly, I'm not a newbie. I'm not an all-out FileMaker or Database expert, but I'm not a newbie. In addition to being the FM database admin, I'm the mysql database admin, the server admin, the tech support guy, the phone system admin, the webmaster, basically, the only IT person here...needless to say, I like to save as much time as I can. Whew, I feel better now. With that, yes, moving to a seperate Categories table/database related via a CategoryID is being thrown around (my idea a long time ago), however, I can't imagine that would be absolutely needed. Let me mention, that although we have ~30 Categories, there are only one of two logos that any Category would be assigned. I have the following fields: Company, Category_Code, g_logo1 (Container, Global), g_logo2 (Container, Global). Then I have field c_logo_flag (Calculation, Result is Container) with following calc: === Case(Category_Code = "VM"; g_logo1; Category_Code = "VM1"; g_logo1; Category_Code = "VM1"; g_logo1; Category_Code = "VM2"; g_logo1; Category_Code = "VM3"; g_logo1; Category_Code = "VM4"; g_logo1; Category_Code = "J4"; g_logo1; Category_Code = "J5"; g_logo1; Category_Code = "NN"; g_logo1; Category_Code = "RR"; g_logo1; g_logo2) === I really thought what I put in place would work. And it does, until I close database. Now, maybe I don't understand Globals enough, or Container fields enough, or even certain complex relationships enough. All I know is I'm still not 100% on what to do and how. Do I HAVE to create a seperate Categories table/database? If not, what changes to my existing solution described above am I making? Again, I thank you all for your knowledge, and to those who have it, your patience :)
  6. Situation: I have two Databases. One is called Companies, the other Contacts. Each company record has a LocationID. Each contact has a ContactID, but also has a LocationID so they are assigned/related to a particular company. Fact: In the past, I have re-numbered ContactID, no problems, but that was ok, as LocationID in both databases were obviously unaffected. Basically I know how to re-number a field. Problem: I will be merging some other database data into the Companies and Contacts databases. However, the there is a conflict with the LocationID's in the databases that are to be merged. Question: So all contacts are still assigned/related to same companies, how do I re-number the LocationID in the Companies database, while also equally and accurately re-numbering the related LocationID's in the Contacts database? I hope I decribed all this well. Thanx in advance to all for any and all assistance.
  7. So, are you saying if I take the multi-user/hosted offline, make it single user, then input data into the Global fields, then return database to multi-user/hosted status, those fields will retain its data (Global fields won't be on any accessable layout for data to be changed). What I want to do is simple. Our database keeps track of members, each member is assigned a Category Code. I want a Logo to appear as per the Category Code, hence the Global fields that contain said Logos. I didnt think it would be this hard. Again, thanx for all your help.
  8. Yes, fields are type: Container and they're Global fields. Database is multi-user (hosted via FileMaker Server 8). Are you saying Global Container fields in multi-user/hosted databases won't retain its data? Thanx again for your help.
  9. I have two seperate container fields located in the same database. Everytime I insert a small jpg logo file into each container field, the images are gone when I go back in the database. I leave unchecked the option "Store only a reference to the file" being I want the image stored IN the database. Each jpg is only 4k. What gives? There must be something I'm missing. Each container field has Use Global Storage checked off. Please help. It's not do or die, but man it's frustrating.
  10. 1. What logs are there for IWP and CWP access? I know the httpd access log gives me some info, but are their logs specific to IWP and/or CWP access? 2. In my list of IWP databases, there is one that isn't IWP enabled. It use to be, but no longer. Why does it still show up in the IWP database home page? Thanx in advance, Eric
  11. My httpd conf file seems fine. Here is my research so far, compared with clone of startup drive made prior to 7v4 update, which I started at ~ Dec 1st 5:15 PM or so: -I noticed /Library/StartupItems/FileMakerServer and /Library/StartupItems/FileMakerServerHelper directories group was wheel prior to 7v4 update and is now admin. Should it be changed back to wheel? Recursively? -System log indicates hostname changed from lemon to localhost on Dec 1st at 5:42 PM and then changed back to lemon on Dec 2nd at 3:15 AM. During this time, following line item in System log appears: = Dec 1 18:19:23 localhost SequeLink[388] Failed to load configuration file from /Library/FileMaker Server 7/Extensions/Plugins/xDBC Support/cfg/swandm.ini = -/Library/FileMaker Server 7/Data/Logs/ and in it, Event.log perms didn't change. Stats running fine. -/Library/FileMaker Server 7/Data/Databases and it's child directories perms seem unchanged and correct. -/etc/hostconfig appears unchanged and ok. -/etc/httpd/httpd.conf appears unchanged and ok. I'm most curious about the difference in group ownership on the FileMaker StartupItems. Would this even prevent Event.log from logging properly? I started a paid case w/ FileMaker support, we'll see what they come up with. Thanx, Eric
  12. Man, what problems. I indeed read the Read Me file. However, I'm having issues. First, I would attempt to access via FileMaker Server Admin, it would tell me server wasn't started, but wouldn't actually let me start it. Yet, fmserverd and fmserver_helperd are indeed running as per Activity Monitor. Yet, databases weren't available. I repaired perms on startup drive twice and restarted server. That fixed it. However, after another restart, back to same issue. Repaired perms twice again and restarted server again to no avail. Repaired perms three times, restarted and now its working again. However, I noticed Event Log isn't properly logging. It provides date, time and hostname, but no actual action. To boot, I had issue updating FSA on my workstation, telling me no instance of 7v3 was found. I finally had to physically copy FSA 7v4 from server to my Workstation. Now, I'm afraid to restart the server, and the Events log isn't logging properly. This 7v4 update is killing me.
  13. So whatever happened, what's the latest? Any fix? Are there any others that can verify this reported issue or any others. I havent found any other documentation on web, let alone FileMaker's site. I want to update to FMS 7v4, but am now hesitant. *Running FMSA 7v3/xServe Dual 1 GHz G4/Mac OS X Panther Server 10.3.9/1 GB RAM
  14. I've noticed a strange behavior recently. When I remove one of my xServe G4 drive modules (and temporarily replace it with another), the backup paths in my backup schedules indicate 'not a valid path' and my backup schedules don't run. Put the original drive module back in, paths are valid, schedules run successfully. Keep in mind, the volume I backup databases to is NOT on the drive module I'm removing. What gives? Running FileMaker Server 7.0v3 Advanced on Mac OS X Panther Server 10.3.9 on xServe G4 with 1 GB RAM. Thanx in advance.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.