Jump to content

Jdawg

Members
  • Posts

    37
  • Joined

  • Last visited

Jdawg's Achievements

Contributor

Contributor (5/14)

  • First Post
  • Collaborator
  • Conversation Starter
  • Week One Done
  • One Month Later

Recent Badges

0

Reputation

  1. Comment, Your suggestion works perfectly. Thank you so much! I've attached a PDF of the script and a picture of my ERD for anyone else that may benefit from this solution. Done.pdf ERD.pdf
  2. I've been searching the forum for several days now looking for a way to require a unique value without using the built-in field validation. The reason I don't want to use the built-in field validation is because it is executed on field exit, which prevents me from triggering my own script and carrying out various commands based on the validation. For example, I don't want the user to be allowed to go to another layout if they didn't enter a unique value when creating a record. Users are creating reservation records in the reservations table. The reservation ID is a concatenated text field that combines lab name, date, and timeslot. I'm trying to do something like this: If reservation ID IS NOT unique Show Custom Dialog("Reservation Conflict";"this time slot has already been reserved. Please select another time slot.") Exit Script End If Go to Layout("Home") Adjust Window(Maximize)
  3. efen, Thanks for the heads up on this demo! I'll take a look.
  4. I'm looking for a solution that will allow teachers to sign up for our computer labs and reserve the lab for a given date and timeslot. I need the system to lock that timeslot for that lab once the teacher signs up for it. I also need them to be able to quickly paruse the calendar and see which time slots are available for each lab. I've downloaded the free SeedCode calendar, but that isn't really a resource scheduler, and it allows for redundant entry. I basically need library check-out functionality. (The book isn't available if it's been checked out.) Any tips or suggestions?
  5. Comment, Thank you for turning me onto those threads. They are dealing with the issue that I'm dealing with. What I don't understand is why it all of a sudden deletes the parent record with v10 but it's never done that with v8.5 and 9.3. Does "Delete Portal Row" actually delete that child record, or just remove the row from the portal? My goal is to leave the parent record in-tact, but delete the child record within the portal.
  6. Thanks for your reply. I've attached a PDF of the script. Line 6 is likely where the problem is occuring with version 10. This has been working fine for 2 years with version 9.3. Script.pdf
  7. A script that works fine on v9.3 doesn't work correctly with v10. This script, designed to delete related records in a portal, is also deleting the parent record when running it on a mac with v10. Any suggestions? Is this a bug with v10?
  8. Ideal, Thanks for the heads up on closing the file first with the admin software before copying it and replicating it. I appreciate the feedback and help!
  9. Wim, Thanks so much for the reply. The folder that stores the files to be served is a folder on the server that few people have access to. I actually just solved my problem by realizing that I was simply serving too many files at once. Closing some old files that were open allowed me to open my file. Whew! You would think the message would be different like, "You've reached the maximum number of files that can be hosted. In order to share this file, you must first close another file."
  10. When I go to the file list using the Server admin software, the file that I want to open just remains closed. Network sharing is turned on for all users in the file itself, but it still isn't allowing the file to be opened in a shared state. Opening the file on my desktop gives me the message,"filemaker cannot share files because another user is already sharing files using filemaker pro on this computer." It seems like alot of people have had similar flavors of this problem. This is what I typically do: 1.) go to Start, Run, access the network folder, and copy a currently shared and hosted filemaker file 2.) paste the file to my pc's desktop, update the records, rename the file, and add the new file to the network folder. 3.) Open FM server admin and open the file so that my users can access this new file remotely.
  11. You are so right. I had expanded the field earlier, but apparently I didn't expand it enough. I just stretched it out further, and that was the answer. Thank you!
  12. Thanks for your reply. That was one of the first things I tried before I entered this post, but that's not actually the problem. The problem has to do with the fact that the calculation, in this rare instance, produces a whole number instead of a decimal. So the decimal formatting and percent notation doesn't know what to do with it.
  13. I have some fields that perform a basic average calculation. The fields are using number formatting, and they are using decimal formatting. My fixed number of decimal digits is 1 because if I set it at 2, I don't get clean percentages. I'm using percent notation with no thousands separator. My question is regarding the rare ocassion when the average is actually 1. (The numerator and denominator are the same.) This causes a "?" to appear, but when you click in the field, it says "1". I can't get it to show as "100.0%" Any ideas? Thanks a mil!
  14. That's unfortunate. I guess I could change the field back to a text field, and create another calc field that could serve as a temporary bucket for the calculations. Then I could run a script to update the text field used in the relationship. Something like: Loop Set Field[tableX::text field; tableX::Calc field] Go to Record/Request/Page [Next; Exit after last] End Loop
  15. I'm trying to find out why switching one of my key fields from a static text field to a calculation field is causing the calculation fields of the parent table not to work. Initially, the static text field was manipulated by a script, and the parent table had no problem calculating other fields based on this relationship. Now the parent table's calc fields provide me with nothing. There's something about the field now being a calc field that's breaking up the relationship. Any ideas?
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.