Jump to content

FMReader

Members
  • Content Count

    26
  • Joined

  • Last visited

Community Reputation

0 Neutral

About FMReader

  • Rank
    novice
  1. Sorry, this is part of a large and complex database that's been developed over the last two years. Trying to strip everything out isn't practical and the info is proprietary. Starting a separate file from scratch doesn't solve the problem either, since adding it back into the main database changes the dynamics but if I can't solve it soon, I'll try to find a way to post a file. I'm using OS X on PowerPC. Perhaps it's different. Printer Setup is part of the OS. It exists irrespective of whether a printer driver is installed. Then printer drivers are added as needed. but a larg
  2. Here are some of the other problems I'm encountering. Again, this doesn't seem to happen when I use letter-sized paper, only small formats. If anyone can enlighten me, I'd appreciate it. I used to earn a modest living with Pagemaker + SuperBase. They had some bugs, but not ones that interfered with my ability to finish products for clients. Now I struggle constantly with scripts (scripts were easy in SuperBase), with printing, with so many aspects of Filemaker, I lose more than I earn. Okay... here are my printer settings in Page Setup for Dymo Twin on standard shipping/badge labels:
  3. All right. I used the word "rows" because I thought it would be clearer as to which direction I meant (printing down first or printing across first), but nevertheless, why does it only show four "columns" (printing down first) when I select six and there is room for six (as you can see in the picture)?
  4. I admit, I'm still a bit confused. Margins come from Printer Setup before Filemaker even looks at what printer driver you're going to use (and a different printer driver is often selected at print time), but I'll take your word for it. So, okay, if Filemaker Preview goes to the printer driver to determine the layout, then the bugs must be in Filemaker, because it doesn't matter whether I use OS X preinstalled printer drivers, third party printer drivers or updated printer drivers, the Filemaker Preview image (with incorrect layout and numbers of rows) is always the same and prints as o
  5. Hi, thanks for your responses. Unfortunately, I don't understand either of them (maybe I'm slow). 1. What would the printer driver have to do with the Filemaker Preview? Does Preview go to the driver to determine the layout? If so, I have an incorrect picture of the process in my mind. I know Filemaker queries about margins, but that's usually handled in Printer Setup and is usually generic (most people select format for "Any Printer"). Then, as far as I know, Filemaker creates a layout and then interacts with a specific printer driver at printing time. I'm pretty sure I have th
  6. In both Filemaker 9 and Filemaker Pro 10 Advanced, I frequently encounter bugs when trying to set up column printing. This is especially prevalent when printing on small formats (e.g., labels). Here are examples of the two most common problems (there are many more): As you can see, there are 5 objects on this layout. A blue box, a green box, a serial number field (left), a text field (right) and a barcode field (center). None of these objects extends off the layout. There are no invisible objects that might be responsible (I was careful to check). The column printing
  7. Mysterious indeed. Could you post a demo file showing this? That turned out to be more complicated than I expected. There are a lot of dependencies in the calculations in this script. It does many other things, including searching to see if the entry already exists, starting a new one if it doesn't, stripping leading and trailing spaces (separate calculation from the one that is be-deviling me). Everything works great and has been working for some time, except the calc that takes out the % sign but not the number. I'll try to separate it out and pare it down, but it's not trivial.
  8. It does for me too. But when I put it in a script and feed "text%20moretext" into the "Show Custom Dialog" box script step, the space is correctly substituted for the % sign but the "20" is still mysteriously there. Does that Show Custom Dialog input window do something I don't understand? Just to provide some context... the user will be copying and pasting Firstname%20Lastname from a Web browser into the database.
  9. Here's the string I passed to the calculation (via a user input box): text%20moretext Here's the calculation: Substitute ( UserInput; "\%20" ; " " ) And here's the result: text 20moretext The desired result is: text moretext. Hmmmm, I thought the % had to be escaped (with a backslash) because the calc wasn't working but I get the same result either way. I still don't understand why the "20" is still in there.
  10. This threw me for a loop. I have a simple substitute calculation. I want to exchange the HTML %20 in a text string with a space. I have escaped the "%" with a backslash and that works fine... but when I substitute "\%20" with " ", the "20" part doesn't substitute. I get the following result: ...something like abcde\%20fghi turns into abcde 20fghi. I want it to become abcde fghi. (If it matters, this is Filemaker Pro 10 Advanced.) I don't get it. It's a text string. It should treat the numbers the same as any other text shouldn't it and remove them... or am I mi
  11. I can see, in your .zip example, that the sentences and word lists DO retain the original entry order and also adjusts correctly if things are shuffled around on the left—exactly what we need. Our 'sentences' data was developed as a separate database by separate people, it's only now that we are linking them. But the portal data doesn't behave in the same way as your example when fetching from another database (rather than a table within the same database)--it changes the order dynamically as words are entered. It may take me a while to figure out why (I'm not a Filemaker expert),
  12. I'm just looking at your zipped file example. It shows a good understanding of what we want to do. I need some time to study its structure to see if we can adapt our data the same way. Will report back. Thanks.
  13. Well, I must be hallucinating, because it's not being displayed in the sort order of the underlying relationship or by order of creation. It would be great if it did. The order of creation would work fine, since once the words are entered, they rarely are changed. By the way, I moved the thread to the correct forum. Sorry, I'm still getting used to the new forum format. I'm only an occasional visitor here.
  14. Filemaker Pro 10 Advanced. We're having a problem with portal autosort I have a repeating field list on the left and a matching portal on the right that pulls corresponding data from a related table. The user types a word on the left and the related word appears in the right-hand column (the portal). So far, so good. The correct data appears. But... the portal is sorting it (I don't have any sort values set in portal preferences). This is NOT what we want. We want the portal values on the right to line up with the corresponding values on the left, exactly as th
  15. Filemaker Pro 10 Advanced. We're having a problem with portal autosort I have a repeating field list on the left and a matching portal on the right that pulls corresponding data from a related table. The user types a word on the left and the related word appears in the right-hand column (the portal). So far, so good. The correct data appears. But... the portal is sorting it (I don't have any sort values set in portal preferences). This is NOT what we want. We want the portal values on the right to line up with the corresponding values on the left, exactly as th
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.