Jump to content

Search the Community

Showing results for tags 'fms13'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Categories

  • Custom Function Library

Community Forums

  • Community Resources
    • Community Articles, Tips, & Techniques
    • FileMaker Marketplace Discussions
  • FileMaker Security Management
    • Security Concepts
    • Intellectual Property
  • FileMaker Server Administration
    • FileMaker Server 16
    • FileMaker Custom SSL Certificates
    • External Server Authentication
  • FileMaker Go & Mobile Strategies
    • FileMaker Go for iPhone & iPad
    • iBeacon Support
    • FileMaker IOS App SDK
  • FileMaker and the Internet
    • FileMaker REST API
    • FileMaker Cloud
    • FileMaker WebDirect
    • Custom Web Publishing
    • Other Internet Technologies
  • FileMaker Interface Features
    • Cards & Window Management
    • Interface Design Discussions
    • Layouts
    • Themes and Styles
    • Button, Popovers, Button Bars, SVG Icons
    • Tab and Slide Control Panels
    • Portals
    • Web Viewer
    • Conditional Formatting
    • Custom Menus
    • Value Lists
    • Tool Tips
  • FileMaker Schema & Logical Functions
    • Managing Scripts
    • Calculation Engine (Define Fields)
    • Custom Functions Discussions
    • FileMaker Query Language or FQL
    • Relationships
    • Charting
    • Remote Container Fields
    • Finding & Searching
    • Importing & Exporting
    • External Data Sources
    • Advanced & Developer Features
    • Reports, Printing & Publication
  • Brain Food
    • The Left Brain
    • Upgrading & Migration
    • Data Analysis
    • Development Standards
    • The Separation Model
    • Relational Database Theory
    • Damaged / Corrupt File Problems
    • OS Level Database Automation
    • Hardware & Networking
    • Bar Codes (Printer, Scanners, Software)
    • Accounting Solutions
  • FileMaker Discussions
    • FileMaker Pro 16
    • FileMaker Pro 15
    • Legacy FileMaker Platform Discussions
  • Productive Computing Support Forums
    • Visit Productive Computing
    • General Discussion for Productive Computing Products
    • Core CRM Solutions
    • QuickBooks and Accounting Plug-ins
    • Contact and Calendar Management Plug-ins
    • FileMaker Utility Plug-ins
  • 360 Works Official Product Support Forums
    • 360 Works General Support
    • MirrorSync by 360Works
    • 360Deploy
    • SuperContainer by 360 Works
    • ScriptMaster by 360 Works
    • FTPeek by 360 Works
    • 360Works Email Plugin
    • DocuBin by 360 Works
    • Zulu – FileMaker, iCal & Google Calendar.
  • Geist Interactive Product Support Forums
    • Visit Geist Interactive
    • Visit Modular FileMaker
    • FMPerception
    • Generator
    • fmQBO
  • FM Starting Point - By Richard Carlton Consulting
    • Visit FM Starting Point
    • FM Starting Point - General Discussions
  • FM Forums Affiliate Sponsors
    • Monkey Bread Software (MBS Plugin)
    • SyncServer Pro by LinearBlue
    • ISO FileMaker Magazine
    • Open Source Frameworks
    • FileMaker Plug-Ins
    • User Group Central - Sponsored by FMPug.com
  • FileMaker Classifieds
    • FileMaker Product & Service Announcements
    • Professional FileMaker Training
    • Services for Hire
    • Services Wanted
    • Solutions Wanted
    • Tools Of The Trade
  • The Water Cooler
    • Member Lounge
    • Wants & Wishes
  • FM Forums Operations
    • FM Forums Feedback & Site News
    • Site Instructions
  • FileMaker Platform

Blogs

  • Captain's Blog
  • FileMaker Weetbicks
  • FileMaker Security Blog
  • The FileMaker Rift
  • HOnza's Bits @ FMForums
  • SeedCode
  • CampSoftware, Hal Gumbert
  • FileMaker Hacks
  • Skeleton Key's Blog
  • Wing Forward Solutions
  • 360Works Articles and Tutorials
  • GoBillit
  • Filemaker - an amateur's view
  • Linear Blue
  • Surya Kanta Mekap's Blog
  • eXcelisys' Blog
  • Manjit Behera
  • Blue Feather's Blog
  • RCC's FileMaker News and Bits
  • Thorsen Consulting
  • DB Services Blog
  • FileMaker Magazine
  • Eye on FileMaker
  • Dev Talk
  • The Philosophy of FileMaker
  • Button Bar Icon - Text Alignment Issue
  • 1-more-blog
  • Productive Computing

Categories

  • Samples
  • Solutions
  • White Papers
  • Plug-Ins
  • FMGo

Found 331 results

  1. Per attached, our FMS13 has shown some users like {31445/0} etc - I have never seen this before - what does it mean?
  2. Front End Folders

    I want to be able to set folders on FileMaker server that will appear visually when the user goes to select a solution to view on WebDirect and Go. Is this possible? That way we can group files together and have a folder for solutions we're still testing.
  3. HI Please can someone helpme out with this. I purchased the filemaker server to host my solution so i can access it remotely. however , how many ways i tried this i can`t seem to access the file . i put in the IP address of the machine where my server is hosted but unofrtanetly it can`t seem to connect.
  4. A customer experiences problems while shutting down a database: after he closes the database using the console, some users are still able to connect. Existing users get the message asking them to close the file(s) they are working on, but some users keep on reconnecting, with success. The files show the status 'closing' in the console. Could this be a communication problem between the console and the server? Or are there other possible causes? It's regular FMPA clients (13 and 14), no WebDirect. Some (but not all) are Robot PC's, performing a timed 'watchdog' process. FMS13 on WindowsServer 2008R2. HEH
  5. It seems that filemaker pro 12 v4 client cannot connect to FM Server 14. Is there any any documentation about this or a way around making the connection possible? Article here says it's possible: http://help.filemaker.com/app/answers/detail/a_id/15003/~/filemaker-server-14-host-and-client-compatibility-chart
  6. FMS web server not enabled

    Hi, While trying to track down a reason for not having access to the Admin Console from a remote machine (can access it locally) I discovered that web server was not enabled. I can't find a way to enable it. On the status page there is no indication. I only discovered this by editing the deployment. Nor can I find a fsadmin command to start the web server. Does anyone have a clue how to proceed with starting the web server? thanks, Rick.
  7. is the client machine hardware important for performance? or is just the server? or both ? i have been having some troubles in some client machines that crash when sorting records, but i really don't know if the problem comes from the server or client please let me know thank you
  8. Our University IT is now requiring MacOS users to encrypt all storage devices. What I found on the FM board (http://help.filemaker.com/app/answers/detail/a_id/9650) is the recommendation NOT to enable Filevault due to the performance hit, but no indication of the severity of the effect. The recommendation is indistinguishable from being part of a laundry list of generic recommendations to improve performance (get a fast drive, enough RAM etc). Any experiences to help guide me here? thanks.
  9. select-able conditional value list

    I am trying to make a list that is select-able and the values are base on another field. I have tried the following but for some reason the values are all or none. If(at_client_sn=814; List(at_department; "ALBANY MEDICAL CLINIC"; "ALBANY SURGICAL ASSOC"; "ALBANY SURGICAL CENTER"; "ELM ST. PROFESSIONAL"; "EYECARE ASSOC"; "GEARY ST. CLINIC"; "INTERCOMMUNITY HEALTH"; "LEBANON COMM. HOSPITAL"; "LEBANON IMAGING DEPT."; "LEBANON SURGICAL ASSOC."; "MAIN ST. CLINIC"; "N. LINCOLN MEDICAL PLAZA"; "PHYSICIANS REF. NETWORK"; "REBOUND PHYSICAL THERAPY"; "SAMARITAN ADMITTING"; "SAMARITAN ENDOCRINOLOGY"; "SAMARITAN HEMATOLOGY"; "SAMARITAN INTERNAL"; "SAMARITAN NEURO SURGERY"; "SAMARITAN NUCLEAR MED."; "SAMARITAN OB/GYN"; "SAMARITAN OB/GYN SURGICAL"; "SAMARITAN ORTHOPEDICS"; "SAMARITAN PEDIATRICS"; "SAMARITAN PLASTIC SURGERY"; "SAMARITAN PRE-OP"; "SAMARITAN RADIOLOGY"; "SAMARITAN RHEUMATOLOGY"; "SAMARITAN SPORTS MED."; "SAMARITAN SURGICAL SPEC."; "SAMARITAN UROLOGY" ))
  10. Records disappear

    We have been having an occasional issue where records just disappear. It's been going on for almost a year now and we simply can't see what might be causing it. It is not common and seems to happen at random. Once every 2 weeks or so. Our database has 33 tables. The disappearing records all come from the same table. It is hosted on a cloud based server with 17 clients in 2 cities (same time zone) accessing it. Steps we have taken so far are: • Disabled "delete record" from the Menu Set • Implemented a dedicated "delete record" script that notifies the administrator when it is run so that the administrator can confirm with the user that the deletion was intentional. • Checked that records can not be deleted via a relationship • Tracked the timing of discovery that records have disappeared. This is difficult because it may be weeks or months before someone needs to refer to it, so doesn't really tell us when the record disappeared. When the record is deleted it appears that related records are NOT deleted. Help?
  11. I received an email from Cognito Software (MoneyWorks Accounting) last night with a warning about installing El Capitan on their server: "The El Capitan GM release made available to developers by Apple earlier this month had an extremely serious bug which would erase all data belonging to server software, including MoneyWorks Datacentre data and Filemaker Server data. We have advised Apple of the bug, and they have acknowledged but not said whether it has been fixed for the public release on 30 September." Has anyone experienced this from the FM side?
  12. Work not being saved

    We are running FMS13, opening with FM14. Few weeks ago, I could have sworn I made several changes ( and I know to save my work ). A few hours later, I noticed something I did wasn't there so I made the same change again and then a bit later, I noticed that it wasn't a slip of my memory - that nothing I had done for past several hours was in the graph or layouts although my notes about it was in the script comment (changelog)! I signed out of FM and reopened the file ( open remote ) and my work WAS there! It happened again this weekend and the only thing I noticed last night was that I could no longer right-click to select conditional formatting on labels. I signed out of FM and back in but all my weekend work was gone this time. I just closed the served file and downloaded it and when I open it, my work is there. I closed the served file and reopened it and my work is now there! I have not seen any discussions or bug reports on this behavior and I was wondering if anyone else experiences it. Client is using a Mac mini for server and I know that is not recommended but this is the first time I have ever seen this strange behavior. --- added: I had not experienced a single bit of problem during my working this weekend ... no error messages, no hangs, no blank outs ... nothing to indicate things weren't great. And I had signed out and back in several times throughout the weekend as well. In reviewing the logs ... I ask for server events. I have NONE. And there are 20 files being served with many users - it should be full.
  13. I just completed a new solution which I loaded onto our test server for further testing in a multiuser shared environment. I immediately noticed that everything was running slowly. Upon opening, a script runs that includes an import step from a SQL database using ODBC and takes about 20 seconds to complete. In single user mode on a network drive that same step takes less then a second to complete. I then noticed that all of my scripted finds take very long to complete, like 25 seconds or so. Long enough to make the solution very painful to use. In single user mode those scripted finds happen instantly. By the way, If I perform the same find manually on the server it finds the records immediately. I also have a popover button that takes like 5 seconds to open the first time. After that it opens instantly. In single user mode it opens immediately. I have many other solutions running on this server a lot larger then this one with no performance issues. I am at a loss as to why this solution runs so slowly on the server. I have recovered this file to no avail. I've also cloned the file with no records and imported the data to no avail. I also see no unusual server events in the log viewer. I am looking for ideas to solve this problem and would appreciate any help you may have. Thank you all. The solution is relatively small compared to other solutions running on this server.
  14. OK, I know I will be embarrassed by the simple answer. I'm going to upgrade from Server 13 to 14 and it says move/copy the database files located /Library/FileMaker Server That folder does not exist. I am running a mac mini specifically to run server. There is nothing else on it. In the library folder there's nothing. Where else to look?
  15. I'm having a similar problem to others but not exactly the same. While logged in to the server, I can access the Admin Console without a problem using https://localhost:16001/admin-console. However, if I try it from a remote computer using https://10.1.1.70:16000/admin-console I get various errors: Firefox: Secure Connection Failed The connection to the server was reset while the page was loading. The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.Please contact the website owners to inform them of this problem.Chrome: This webpage is not available ERR_CONNECTION_RESET The connection to 10.1.1.70 was interrupted. Check your Internet connection Check any cables and reboot any routers, modems, or other network devices you may be using. Allow Chrome to access the network in your firewall or antivirus settings. If it is already listed as a program allowed to access the network, try removing it from the list and adding it again. If you use a proxy server... Check your proxy settings or contact your network administrator to make sure the proxy server is working. If you don't believe you should be using a proxy server: Go to the Chrome menu > Settings > Show advanced settings... > Change proxy settings... > LAN Settings and deselect "Use a proxy server for your LAN". Safari: Safari can't open the page Safari can't open the page "https://10.1.1.70:16000/admin-console". The error is: "" (kcferrordomainwinsock:10054) Please choose Safari > Report Bugs to Apple, note the error number, and describe what you did befoer you saw this message. Internet Explorer: This page can’t be displayed Turn on TLS 1.0, TLS 1.1, and TLS 1.2 in Advanced settings and try connecting to https://10.1.1.70:16000 again. If this error persists, it is possible that this site uses an unsupported protocol. Please contact the site administrator. Edge: Hmm, we can't reach this page. Try this •Make sure you’ve got the right URL: https://10.1.1.70:16000 •Refresh the page •Search for what you want From doing some internet searching it seems this might be due to outdated connection protocols that are common for intranet connections but dangerous for internet connections. The latest browser updates have reportedly removed support for such connections. At first I thought maybe it was just a Windows 10 problem since I recently updated but I tried a computer that was still running Windows 7 and had the exact same problem. I saw one site that described entering an exception in the FireFox about:config file but that had no effect. Is anyone else having a problem accessing the Admin Console from another computer on your Windows network? Have you found a workaround? Note that no changes were made to our network software or hardware between the time this was working and when the problem first occurred (a couple of weeks ago). My specs: FMS 14.0.2 FMPA 14.0.2 FMP 14.0.2 Windows environment (Server 2008, Windows 10 Pro, Windows 7 Pro)
  16. I have had intermittent problems in the past sending out multiple emails (in a loop, up to 50 emails) using the Send Mail script step. Some of the emails can fail to send. I was put in touch with an IT support person in the university where I work, and he thought that the problem might be solved by sending via an SMTP server intended specifically for applications and therefore equipped to handle the high volumes and fast speeds of the multiple emails produced by a looping set of send instructions. The prefix for the SMTP server is appsmtp rather than smtp. I gave him the IP address for my version of FM Server 14, and he created the necessary firewall exception. However, if this solution is to work, the emails must go out directly from the server rather than from an email address that is hosted by the server. Even though I provide the new server address (smtp.utoronto.ca), and the correct port, my attempts to send test emails have failed. The IT person did not see correct the IP address at his end. He saw the IP address associated with my Mac. Is what I am trying to do possible? And if it is, what do I need to do to make it work? Maybe automatic emails (that happen overnight) will work but not emails initiated by a client? If it's not possible to do what I'm trying to do, please provide any insight into why emails in a loop might intermittently fail. Would it help to provide a time buffer between sends via a pause?
  17. Is it possible to port a custom certificate that I've been using in my production FMS13 system to be used for FMS14 without having to have it reissued? I'll be decommissioning the equipment that is currently running FMS13, which is a single Mac server. The new equipment will be a two machine configuration that will have the same IP and domain name addresses as previous.
  18. Hi Guys, I'm working on a database based on the Selector-Connector principle (and so far am liking it, thanks LaRetta!) but have stumbled onto something I'm not getting. I started out developing this DB on my workstation as a local DB, and this morning uploaded it to the server (a FMSv14) to test it on an iPad to see how the UI looks and feels. In my DB I have a table for all my menus I use in the UI, On each layout I show the user the name of the layout (see in red below). This is not the actual layout name, but rather the menu text in the menu. The layout name is not necessarily a text that is suited for display (ie, my menu table is called UI_Menu, but I wouldn't want my users to see UI_Menu, rather just "Menu"). I therefore use my UI_Menu table to store the name I want to display, which is the Menu_Item field. The UI_Menu table holds all the possible menu options available, which I can turn on and off (activate) at will. The UI_Stats table is basically a placeholder for things like logged in user, total logged in users, etc. It has only one record. The CurrentLayout field in the UI_Stats TO is a simple "Get ( LayoutName )" calculation. It is linked to the UI_Menu_SelectedItem::Menu_Layout for the purpose of getting the Menu_Item field of the layout I am on. This all works fine when I open the DB locally. However, when I move the DB to the server and open as a hosted DB, it stops working. The CurrentLayout field in the UI_Stats TO still has the correct value so the calc is working fine. But my relationship is broken. I get that a calculation that uses data from a related table field doesn't work and in this particular calculation this is probably the same reason. What I don't get is why it works locally and not hosted. The sclient I'm developing in is v13, but even with a v14 client it doesn't work. In my view, the local and hosted DB should behave the same. Anyone have a good way to get around this? Thanks!
  19. Hello, I have Server 13 running a number of files that are accessed by 25 client seats. All run without issues. I am now trying to access an SQL database using ODBC, and am confused by the instructions I've been reading within FM help, and FM Server help. I configured the ODBC driver I need at the server (Windows), and within the General Settings/ODBC/JDBC tab, the "Enable ODBC/JDBC" checkbox has been checked. But when I go back to FM13Adv on a client machine, and atempt to write a script with "Import Records", it asks for the ODBC driver, but there is none. The Server help indicates that if I have the ODBC driver installed on it, then there is no need to install on the client. Do I need drivers on the clients? Sorry, but I'm totally confused. I've set up ODBC from a client machine in the past and it worked, but should i really have to set up 24 other clients (Mac and Windows)?
  20. I have noticed for quite a while now (a few years) that often when I try to reopen a hosted file that FMPA will spin for 20-30 seconds and respond with "file not available on this server..." error. But upon retrying it a 2nd time, it always comes right up. Anyone else run into this? This has happened on FMS12, 13 and 14 for me. This has been across multiple servers (same client location), different machines/clients, and different files. It has been just a minor annoyance so I haven't tracked it real well: I can't attest to whether it happens every single time I open the file; or perhaps it is only after leaving the office (after properly shutting a file down), and then coming back to the office the next day; or ?? Anyone else had something similar happen? -- Justin
  21. Two X-Serves, but which is which?

    Am about to move to a two-machine deployment of FMS 13.0.10, having acquired a second X-Serve. However, although both have the same CPU, one has 12GB RAM and one 24GB. Also, the bigger one has 3x 15000rpm SAS drives, whereas the smaller one has the more usual 3x 1TB SATA drives, (RAID5 in both cases) My plan was to utilise the new smaller one as the WebDirect Server (as not all my hosted solutions use WebDirect). But am wondering if this is the best way around.
  22. I'm getting resistance from a client's IT vendor to opening ports 16000 and 16001 so that I can administer the client's server without having to remote access in using GoToMyPC. The IT vendor is concerned that FileMaker Server uses Java. I thought I remembered hearing that this was not the case beginning with 13, but I see that Java is still listed as a requirement. So my question is two-fold: Does Server 13/14 still need Java and use it as the interface into the Admin Console? If so, and the most recent version of Java is installed, is this still a security issue?
  23. Can FMS13 host FMP14 databases (created with FMP14)? I haven't been able to find a definitive answer to this. thanks, John
  24. Hi, I am going to migrate my FileMaker server from one server machine to another and I am in the process of testing the transfer. However following the test transfer I have discovered that accessing database files in the new server via WebDirect is not functioning properly. I wonder if the community can offer some advice? Normally upon entering the hyperlink (i.e. <host>/fmi/webd/), I would be presented the default WebDirect screen asking for my credentials before presenting me with the list of database files available. However when the files are hosted on the new server, I only get the default WebDirect screen but no requests for my credentials and no database files are displayed. I also tested access using the server machine's own web browser via localhost/fmi/webd/ but got the same result. On the other hand, I have tested access via FMP and FMG and they are all working fine. I'm at a lost as to where the settings went wrong or where to start with, and I would really appreciate if the community can offer some advice and suggestions. Many thanks for your time and help. The MacGuffin
  25. Hi, I just installed the custom SSL certificate as part of the update of my FMS13 to 13.0v9, and I noticed the open url script step on my FileMaker Pro client stopped working since the certificate was installed. I have since proceeded with the update and completed it successfully, but the open url issue remained. I'm at a loss as to why this is the case and would appreciate any suggestions to resolve the issue. I know the open url script stopped working after the certificate was installed but before the update was carried out because I happen to have need of using it at that point. The issue appears specific to my FMP client as the same script runs smoothly on FMG as well as on Web Direct. There is no other script steps involved: It's just open the url given in a record (it's a table of websites). Many thanks for your time and help. Cheers, The MacGuffin
×

Important Information

By using this site, you agree to our Terms of Use.