Jump to content

Search the Community

Showing results for tags 'drupal'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Community Forums

  • The New FileMaker Platform
  • Community Resources
    • Community Articles, Tips, & Techniques
    • FileMaker Marketplace Discussions
  • FileMaker Platform
    • FileMaker Interface Features
    • FileMaker Schema & Logical Functions
    • FileMaker Go for iPad and iPhone
    • FileMaker and the Internet
    • FileMaker Pro Advanced 17
    • Legacy FileMaker Platform Discussions
  • FileMaker Server Administration
    • FileMaker Server 17
    • FileMaker Server 16
    • FileMaker Cloud
    • FileMaker Custom SSL Certificates
    • oAuth and External Server Authentication
  • Brain Food
    • Security Concepts
    • The Left Brain
    • Upgrading & Migration
    • Data Analysis
    • Development Standards
    • The Separation Model
    • Relational Database Theory
    • Damaged / Corrupt File Problems
    • Bar Codes (Printer, Scanners, Software)
    • Hardware & Networking
    • OS Level Database Automation
    • Product Ideas
  • FileMaker Security Management
  • FMForums Affiliates & Sponsors
  • FileMaker Classifieds
  • FM Forums Operations
  • FileMaker Friday Night Chat's Topics

Blogs

There are no results to display.

There are no results to display.

Categories

  • White Papers
  • Infographics
  • Samples
  • Solutions
  • FMGo
  • Plug-Ins
  • Tutorials

Product Groups

  • Workplace Innovation Platform
  • Site Advertising
  • Development & Hosting

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Title


Industry


Location


Interests


Website URL


Skype


MSN


Yahoo


OS Version

Found 2 results

  1. Hi, I'm trying to install in a drupal site the connection with Filemaker. I am developing the drupal site in my machine using MAMPRO as a web server and I have my database file hosted in a shared Filemaker server. After installing in Drupal, the Filemaker modules, and the FX folder with FX.php in the libraries folder, whenever I try to use the filemaker module I get the following notice "Can not find FX.php. Please place FX.php at sites/all/libraries/fxphp/FX." I'm sure that I've installed in that location the FX folder. So I am lost. I'd appreciate any help, thks. Armando
  2. Hi everyone, I'm trying to post data to a Drupal application from FileMaker via the BaseElements plugin. I'm getting a token, setting authentication, headers, and the post variables via the BaseElements functions and I've followed examples but I'm getting the following error: {"error":"The type link relation must be specified.”} I can't find any information about what this error might be. Does anyone have any idea based on the output I've gathered below? A working cURL command that I'm basically trying to replicate that can be run from the command line is here: curl --include \ --request POST \ --user res_user:"password" \ --header 'Content-type: application/hal+json' \ --header "X-CSRF-Token: $X_CSRF_TOKEN" \ --data-binary '{"_links":{"type":{"href":"http://server.mskcc.org/rest/type/node/event"}}, "field_event_type":[{"value":"Seminar"}], "title":[{"value":”Novel Approaches to Mating Drosophila"}], "field_shared_datetime":[{"value":"2016-06-13T17:15:00"}], "body":[{"value":"Tea ?: Yes<br>Tea Time: Tea at 1:15 PM"}], "field_shared_location_text":[{"value":"ZRC Auditorium"}], "field_shared_sponsor":[{"value":"Developmental Biology"}], "field_event_hosts_text":[{"value":"Alexander Rudensky"}], "field_shared_people_text":[{"value":"Name of Speaker: Steven Reiner<br>Speaker\u0027s Credentials: M.D.<br>Speaker\u0027s Title: Professor, Department of Microbiology and Immunology<br>Speaker\u0027s Affiliation: Columbia University Medical Center<br>Institution Location: New York, NY"}], "type":[{"target_id":"event"}]}' \ http://dev.mskcc.org/entity/node?_format=hal_json I've attached the script I'm working with as an image. thanks in advance. Steven ----- BE_Curl_Trace returned: == Info: Trying 172.22.233.50... == Info: Connected to dev.mskcc.org (172.22.233.50) port 80 (#0) == Info: Server auth using Basic with user 'res_user' => Send header, 0x12c bytes (0x12c) 0000: POST /entity/node?_format=hal_json HTTP/1.1 0x2d: Host: server.mskcc.org 0x42: Authorization: Basic cmVzX2RydXBhbDpUcnU3SCZrQQ== 0x75: User-Agent: libcurl-agent-base-elements-plugin/3.2 0xa9: Accept: */* 0xb6: Content-Type: application/hal+json 0xda: X-CSRF-Token: q3LKwzWvNtlP2_X79TpJATfEnOB8HV-_lDaVCiTK8gg 0x115: Content-Length: 353 0x12a: => Send data, 0x161 bytes (0x161) 0000: " {\"_links\":{\"type\":{\"href\":\"http://dev.mskcc.org/rest/ty 0x40: pe/node/event\"}},.. \"field_event_type\":[{\"value\":\"Seminar 0x80: \"}],.. \"title\":[{\"value\":\"Sister Cells that Feast and Fas 0xc0: t --- Why Growth and Repair May Not be Fair XI\"}],.. \"field_s 0x100: hared_datetime\":[{\"value\":\"2016-06-13T17:15:00\"}],.. \"typ 0x140: e\":[{\"target_id\":\"event\"}]}" == Info: upload completely sent off: 353 out of 353 bytes <= Recv header, 0x1a bytes (0x1a) 0000: HTTP/1.1 400 Bad Request <= Recv header, 0xf bytes (0xf) 0000: Server: nginx <= Recv header, 0x24 bytes (0x24) 0000: Content-Type: application/hal+json <= Recv header, 0x1c bytes (0x1c) 0000: Transfer-Encoding: chunked <= Recv header, 0x18 bytes (0x18) 0000: Connection: keep-alive <= Recv header, 0x18 bytes (0x18) 0000: Keep-Alive: timeout=10 <= Recv header, 0x33 bytes (0x33) 0000: Cache-Control: must-revalidate, no-cache, private <= Recv header, 0x1a bytes (0x1a) 0000: X-UA-Compatible: IE=edge <= Recv header, 0x16 bytes (0x16) 0000: Content-language: en <= Recv header, 0x21 bytes (0x21) 0000: X-Content-Type-Options: nosniff <= Recv header, 0x1d bytes (0x1d) 0000: X-Frame-Options: SAMEORIGIN <= Recv header, 0x28 bytes (0x28) 0000: Expires: Sun, 19 Nov 1978 05:00:00 GMT <= Recv header, 0x25 bytes (0x25) 0000: Date: Wed, 03 Aug 2016 11:02:45 GMT <= Recv header, 0x2 bytes (0x2) 0000: <= Recv data, 0x40 bytes (0x40) 0000: 35 00x4: {"error":"The type link relation must be specified.”} <——— here's the error 0x3b: 0 0x3e: == Info: Closing connection 0 BE_Response_Headers returned: HTTP/1.1 400 Bad Request Server: nginx Content-Type: application/hal+json Transfer-Encoding: chunked Connection: keep-alive Keep-Alive: timeout=10 Cache-Control: must-revalidate, no-cache, private X-UA-Compatible: IE=edge Content-language: en X-Content-Type-Options: nosniff X-Frame-Options: SAMEORIGIN Expires: Sun, 19 Nov 1978 05:00:00 GMT Date: Wed, 03 Aug 2016 11:02:45 GMT
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.