Jump to content

Search the Community

Showing results for tags 'fmp17'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Community Forums

  • The New Claris Platform
  • Community Resources
    • Community Videos, Tips, & Techniques, Articles.
    • FileMaker Marketplace Discussions
  • FileMaker Platform
    • FileMaker Interface Features
    • FileMaker Schema & Logical Functions
    • FileMaker Go for iPad and iPhone
    • FileMaker and the Internet
    • FileMaker Pro 19
  • FileMaker Server Administration
    • FileMaker Server 19
    • FileMaker Server 19 (Linux)
    • FileMaker Cloud
    • FileMaker Custom SSL Certificates
    • oAuth and External Server Authentication
    • Zabbix Server Monitoring
    • Previous Version Server Discussions
  • JavaScript Integration
    • Java Script and the Web Viewer
    • Carafe.FM
    • Widget Studio
  • Brain Food
    • Security Concepts
    • The Left Brain
    • Upgrading & Migration
    • Data Analysis
    • Development Standards
    • The Separation Model
    • Relational Database Theory
    • Damaged / Corrupt File Problems
    • Hardware & Networking
    • Product Ideas
  • FMForums Affiliates & Sponsors
    • Productive Computing Support Forums
    • 360 Works Official Product Support Forums
    • Proof+Geist
    • FileMaker Vendors
    • FileMaker Training Resources
  • FileMaker Classifieds
    • Announcements of FileMaker Product, Services or Resources
    • Classifieds
    • Tools Of The Trade
  • FM Forums Operations
    • FM Forums Feedback & Site News
  • FileMaker Friday Night Chat's Topics

Blogs

  • Captain's Blog
  • FileMaker Weetbicks
  • FileMaker Security Blog
  • The FileMaker Rift
  • HOnza's Bits @ FMForums
  • SeedCode
  • FileMaker Hacks
  • Skeleton Key's Blog
  • Wing Forward Solutions
  • 360Works Articles and Tutorials
  • GoBillit
  • Filemaker - an amateur's view
  • Linear Blue
  • Surya Kanta Mekap's Blog
  • eXcelisys' Blog
  • Manjit Behera
  • Blue Feather's Blog
  • RCC's FileMaker News and Bits
  • Thorsen Consulting
  • DB Services Blog
  • FileMaker Magazine
  • Eye on FileMaker
  • Dev Talk
  • The Philosophy of FileMaker
  • 1-more-blog
  • Productive Computing
  • Geist Interactive
  • Soliant Consulting

Categories

  • White Papers
  • Infographics
  • Samples
  • Add-ons
  • FMGo
  • Solutions
  • Tutorials
  • Plug-Ins

Product Groups

  • Workplace Innovation Platform
  • Site Advertising
  • Development
  • FileMaker Hosting

Calendars

  • FileMaker Events
  • Community Calendar

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Title


Industry


Location


Interests


Website URL


Skype


MSN


Yahoo


OS Version

  1. A google search reveals that FMP not recognizing modifier keys is at least a decade old problem. It's hard to resist making some kind of a comment but I will resist. At any rate, it seems that restarting the computer, at least on a Mac, resolves the problem, (until it pops up again). My question is this: Is it understood what is it in the restarting process that corrects the problem, and if it is, is it something that can be imitated with some kind of script, command, etc? Thanks
  2. Hi everyone, I'm trying to get attaching files go mails generated using FM17 to work. The idea is to attach a variable file to a mail-message generated for a specific record. The filename for the attachment is specific to the record and I've got a field that generates that filename (fileNamejpg01). I'm using the send mail option in a script (which is working) and the option to attach a file by giving a file path. That file path looks like this: file:../../../Desktop/werkmap/Beeldmateriaal/instagram/$fileNamejpg01 The variable part is "$fileNamejpg01" and I'm sure I'm doing something really dumb ... but don't find anything that solves the problem (or that I at least understand). Hope someone can help! Thanks, Peter
  3. I have in my small store, a sales system running on a POS with an extra display, for the customer to see what is being added to the invoice. How do I make the filemaker present on this small monitor the summary of what is being sold? how can I maker filemaker to display on the second monitor only the invoice.
  4. Hello, I've come upon a strange phenomenon, and wonder what could have gone wrong: In layout mode, I select gray solid coloring for a couple of fields and their labels, but in Browse mode (both list and table views), the colors fail to show in some instances. Only in form view, everything is displayed as expected. Neither restarting FM nor the PC (win10) helped. I assume that the solution is simple, but somehow I can't come up with it, therefore: Many thanks in advance for helpful comments!
  5. I'd like to be able to export a text file that would contain several fields from a single record, with each field on a separate line. Here's an example: John Q Public 111 West First Street New York, NY 10001 How might I do that? I know how to export csv or Excel files, but they don't satisfy my need.
  6. To try to explain the setup as succinctly as possible: Database is running on a FM17 Server (on a Windows virtual(?) machine... Our IT department handles that part). The FM database does a number of imports every morning from our primary (4D) database, using an ODBC driver, but I have not found a way to have those imports run successfully from the server, so I have them running on an instance on a secondary user account on my desktop computer. The scripts are triggered by adding a record to a table, which is checked every five minutes using an OnTimer script. I run a separate instance of FM17 on my user account so that I can use the database even if there is an import running. This solution has been working (fairly) well for a number of years, but last week, my desktop computer was updated to Mojave (10.14.6), and since that upgrade, it seems that the imports on the secondary account will only run while that user account is active. 1) Is anyone else doing anything similar, where they have an instance of FM running on a separate user account? 2) If so, have you had any trouble with Mojave, or have suggestions on what may be going on? 3) Any suggestions on how to fix this? My initial thought is to just open the database using FMP on the Server system and try having the imports run from there, but am concerned that might also have problems. Any suggestions would be greatly appreciated.
  7. I have a field called Price. I need to create another field called calculated price that will add a percentage depending on the value of the original Price field. Example: If the Price is $100.00 or more Subtract 10% from the price If the price is $10.00 or less Subtract .25% If the Price is between $10 and $50.00 Subtract .5% If the Price is between $50 and %100.00 Subtract .75% and so on and so on... So if I have a record with a Price of $1.00 the calculation will fill in the Calculated Price field with $.75
  8. Hi, I am using the Base Elements plugin Execute SQL command to select SQL on a table in another FileMaker file. For a file with many fields and quite a lot data in some fields, this times as about 1 minute just for SQL SELECT command for 1,000 rows. I haven't used MBS (monkeybread software) plugin yet, but I wonder if anyone knows if it is significantly faster? I.e. BE_FileMakerSQL vs. MBS(FM.SQL.Execute..) - is one significantly faster? Here's the code to select 1,000 rows for reference, $timer_seconds comes as about 60 seconds here. If I export same table internally in FileMaker using the menu export to Excel, it takes 29 minutes for all 41,000 rows, so timing seems similar for the Base Elements SQL. (NB there is some flag going on here in the FileMaker database so internal export gets 41,000 rows but script SQL SELECT COUNT(*) gets 200,000 rows for same table, but I don't think that is relevant to my question). Set Variable [$time1; Value: Get(CurrentTimeUTCMilliseconds)] Set Variable [$part_ca; Value: BE_FileMakerSQL ( "SELECT * FROM Contact_ACTIVITY OFFSET 100000 ROWS FETCH FIRST 1000 ROWS ONLY" ; "&≠≠&" ; "EOR≠≠EOR" ; "DataContacts11" )] Set Variable [$timer_seconds; Value: (Get(CurrentTimeUTCMilliseconds) - $time1) / 1000] MBS command I think would be something like: MBS( "FM.SQL.Execute"; "DataContacts11"; "SELECT * FROM Contact_ACTIVITY OFFSET 100000 ROWS FETCH FIRST 1000 ROWS ONLY" ; ...delimiters here I'm assuming.. ) We only have base FileMaker here on machine I am using, which can run the Base Elements plugin, but to run MBS plugin, needs FileMaker Pro Advanced to install it I think, am getting several databases in roughly same FM format where script workspace disabled, hence need to use SQL select run from script in my own external FileMaker file. Might consider getting FMP Pro Advanced if MBS is faster. Tx any suggestions!
  9. I have a layout calculation that looks like: Round(If($$NoGPABump = 1;Classes::GPANoBump; Classes::GPABumped);2) In most instances, this rounds the appropriate value to 2 decimals and displays those two digits. But on occasion, it displays only one decimal as in this one: . Instead I want to see 4.20. If I round to, say, 4 decimals, it works properly: . Rounding to 3 digits gives 4.199. How do I get the trailing zero to show up? This seems to be consistent for all data that rounds to a last digit of zero. Is this a bug? Is there a workaround? Thanks,
  10. I have a layout with a number of button bars, all with the same style. Each button is set to have an inner shadow and a white fill on Hover. For any of the buttons that call a popover, after the popover is closed, the hover shadow no longer works, but the fill still changes to white. I've tried adding a refresh object script trigger when closing the popover, but that doesn't work. Some of the buttons are currently placeholders, which just call a script that exits itself so I can test the hover state. Those work fine.
  11. Is this at all possible? I want to have two buttons that will each do the following. Have one button to ‘Strike Thru’ text that is highlighted before. Means not all the text in the field will be changed. And one button to change the text colour to Red, again highlighted before. Means not all the text in the field will be changed. Any tips how to do this? Please bare in mind I am a FMP beginner. Thanks.
  12. For about 12 years, we've had a FileMaker database import external data from a .mdb (Access) database that has data that is downloaded from some equipment. The process has survived several computer upgrades (Windows XP and Windows 7) and FileMaker version upgrades (created in 7 and currently running in 16). It broke when we moved into the Windows 10 environment. The script is set up to retrieve the data from the .mdb file and it says it can't access the file. So when I dive into the script and try to specify the ODBC connection it now asks for a username and password. We've never had a user name or password tied to either the .mdb file, the ODBC connection, or the FileMaker file. But no matter what we try, we can't get past this step. Is this a bug? What am I missing here? Thanks in advance.
  13. Say I have a 2 page letter pdf in a container. I want to make a 1 page pdf that is 11X17 of this PDF. Do I need a plugin to do this? If so what? Or can I achieve this natively in FM?
  14. Hello, good afternoon! I'm from the Philippines and I really need help here regarding how to send SMS using Semaphore. Semaphore is an alternative for Twilio. I use Semaphore since this is a SMS Gateway for Philippines and it's every cheap as well. Here's is my script using Insert from URL: "httppost://api.semaphore.co/api/v4/messages?apikey={{KEY_REDACTED}}" & "&number"=SendMessage::mobileno & "&message"=SendMessage::textmessage When I try to click the "Send" button that I created, it always give me an error (see the image below). Hope someone can help me. Thanks!
  15. Dear All, I am trying to put a conditional formatting validation which turns Red when the value is entered wrong. Basically all my tries have failed so I would like your help here. The criteria of entering a value is xxxx-xxxx-xxxx-xxxx 1111-2222-3333-4444 1. Length of value is = 19 OR this should be a 16 digit number, in groups of 4 separated with dashes 2. Non-Digits characters are not valid. Please could you help me with this and I will really appreciate. Many thanks Regards Lutfi
  16. I am using Filemaker Pro 17. I have created a container field with 'interactive content (PDF, MP3, etc.)' checked in the Data tab in the Inspector. PDF's won't upload. I've uninstalled and reinstalled Adobe Reader DC. I've tried other PDF files and they just won't load. What am I doing wrong? (I've done is successfully in the past with Filemaker 15 with the exact same PDF files). I'm using a MacBook Pro with MacOS Mojave Version 10.14.2 (18C54).
  17. I have filemaker server on virtual server, I have a script that exports emails and or names i cannot get the file to be saved to the local desktop it tries to save to server with an error when i do manually it works fine so i am doing something wrong... Thanks in advance
  18. I have been using FM17Adv for some time. I am on a MacPro 12-core tower and I had been running macOS Sierra. All the internal scripts I had in one database worked perfectly. I recently updated to High Sierra and now I am getting script errors I don't understand. And this is from the same exact file I used previously. I have one script where I want it to open a folder in Dropbox so I can access files there. But I am getting this error: Can’t make "Dropbox" into type integer. Then I get a -1700 error dialog immediately after that. Can anyone explain how I can fix this. I have not been able to find anything online. The script is a native AppleScript, and I suspect that has something to do with this. Here is the script: tell application "Finder" activate open folder " Pieces 2011" of folder "Teaching Material" of folder "Dropbox" of " ThomaStudios 4TB" select Finder window 1 set position of Finder window 1 to {2877, 167} end tell Thanks. J D Thomas ThomaStudios
  19. Hi Guys, There are any logic or resource that i can use to make like a "text to columns". Make text from field one flow to another fields but only with in the middle of coma regarding your sequence, like a excel? Full text with Comas Text1 Separated Text2 Separated Text3 Separated How,Are,You? How Are You? Could please help me, i need a lot of this resource.
  20. I don't really know what I'm missing here. I have two windows next to each other. I want to activate a Script Trigger on Record Load (I have tried On Layout Enter as well) , and it does that fine as long as I'm only having one window open. But not when I'm switching between the windows. Ie, I want the script to run when I enter the Window. Isn't this supposed to work?
  21. Excel and Filemaker calculates the difference between two dates differently. I always thought that when you subtract two date from one another, the result was the number of full days between the dates. For example: Calculate the difference between 1/15/19 – 1/9/19. There are 5 full days between these dates (10th, 11th, 12th, 13th, and 14th). However, FM and Excel calculations do not result in 5, and they don’t even agree with each other! In Excel, Difference = 7 In FM, Difference = 6 It seems that when you subtract two dates in Excel the result includes the starting and ending dates and therefore it is not the number full days between the dates. In FM the result seems to include either the starting or ending date (not both), and therefore it also is not the number of full days between the dates. What gives?
  22. Hi everybody, looks like I do have a sort of rookie problem here. I created a subsummary report which is sorted by a break field and all works fine. All is fine in layout and preview mode. Just in browse mode I seem to have a problem. There is a large grey empty area just underneath of the subsummary part showing. Anyone with an idea what it is I messed up here? I already googled but just found 1 similar report from 2010. Sort of optically annoying. Any help is highly appreciated.
  23. Hi everyone I am working with filemaker on and off for the last recent years but, no doubts about it, I am still a rookie. lately I have created a db similar to a booking engine for shore excursions for river cruise ships. Lots of modules, layouts, scripts etc. As I really have to work with my limited knowledge, it took a long time and is not really constructed in a way any pro would do it with a lot of workarounds and probably sort of unorthodox. However, it works just fine for me and I am sort of proud, to have gotten to the point where I am. However, I am afraid, that I corrupted the whole thing somehow. No I am trying to integrate a sort of an accounting layout consisting out of a summary or subsummary report. The report contains fields from 4 related tables. and a summary field. The db has some 5 different tables and around 35 different active layouts. First problem is that my subsummary part, which I created with the New Layout/Report assistant, does not show up at all in browse mode. I have tried to base the layout on all 4 tables, but it seems not to be working. The second problem is that the summary field is not working and producing some random weired numbers instead of the summary of the field it is assigned to. On the attached pics I have placed the summary field into the bottom in order to demonstrate the results. In every ordinary case it is located in the subsummary part. I have played around here a lot. deleted it, created a new field, created a new layout etc, etc, but it just won't calculate the value of the field it is assinged to. Anyone any idea, of what am I doing wrong here? Tnx for any help in advance.
  24. Hi Guys, There is any script who request user and password of user after click in a button. I have a check box in my solution with get username for log register and validation, i want to request user and pass to allow user enter this option. Thanks for all.
  25. This is a problem I frequently have. I can't custom format a date in the Inspector. I can't make a selection because the drop down menu becomes a long vertical blue stripe and selections are not available. I wonder if this is a FMP problem or a Windows 10 problem. Does any one else have the same problem?
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.