Jump to content

Search the Community

Showing results for tags 'psos'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Community Forums

  • The New FileMaker Platform
  • Community Resources
    • Community Articles, Tips, & Techniques
    • FileMaker Marketplace Discussions
  • FileMaker Platform
    • FileMaker Interface Features
    • FileMaker Schema & Logical Functions
    • FileMaker Go for iPad and iPhone
    • FileMaker and the Internet
    • FileMaker Pro Advanced 18
    • FileMaker Pro Advanced 17
    • Legacy FileMaker Platform Discussions
  • FileMaker Server Administration
    • FileMaker Server 18
    • Zabbix Server Monitoring
    • FileMaker Server 17
    • FileMaker Cloud
    • FileMaker Custom SSL Certificates
    • oAuth and External Server Authentication
  • Brain Food
    • Security Concepts
    • The Left Brain
    • Upgrading & Migration
    • Data Analysis
    • Development Standards
    • The Separation Model
    • Relational Database Theory
    • Damaged / Corrupt File Problems
    • Bar Codes (Printer, Scanners, Software)
    • Hardware & Networking
    • OS Level Database Automation
    • Product Ideas
  • JavaScript Integration
  • FMForums Affiliates & Sponsors
  • FileMaker Classifieds
  • FM Forums Operations
  • FileMaker Friday Night Chat's Topics

Blogs

There are no results to display.

There are no results to display.

Categories

  • White Papers
  • Infographics
  • Samples
  • Solutions
  • FMGo
  • Plug-Ins
  • Tutorials

Product Groups

  • Workplace Innovation Platform
  • Site Advertising
  • Development & Hosting

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Title


Industry


Location


Interests


Website URL


Skype


MSN


Yahoo


OS Version

Found 14 results

  1. When running PSoS, I thought the attachments would be stored in the temporary folder and removed when the PSoS-session is over. I find that each attachment creates a folder like "UID@email.com" in the Documents folder, and it stays there after the session. I tried to make the script remove it, but ran into some problems. Any suggestions?
  2. To begin, I have about 100,000 records (and growing) in a "Parent" table. Each Parent will have at least one "Child" (usually about 2 or 3, but can be 5 or 6). Each Child has a "Quantity" calculation field {sum( in - out)} which is related to the "Transactions" table.  I'm trying to filter a table (in list view) of the "Product" aka. parent to show only products that have any "Inventory" items aka. child that have quantity > 0.  I'm able to generate the results, my problem is the speed at which it calculates  For instance, "Prod A" might have three children: A_1, with qty 1 A_2, with qty 0 A_3, with qty 0  "Prod B": B_1, with qty 0 B_2, with qty 0  "Prod C": C_1, with qty 0 C_2, with qty 0 C_3, with qty 5 C_4, with qty 7  Therefore, I created a calculation field called "invQty"in the Product table as such: sum (inv::quantity). I have a button on my product layout attached to a script that looks for a value > 0 in the invQty field.  The result of the above example will display "Prod A" and "Prod C" only, which is great but it takes about 45 seconds. (Script is performed on client, file is hosted on FMS)  Would this be a time to use executeSQL, if so, how would the calculation be written (I have yet to use this function) from what i've read it isn't much faster? Otherwise, is there a faster way to do this? You guys always come up with some clever stuff, hope you can help me.  Additional thoughts: I've been working with PSoS lately, and it's been amazing, but not sure if this can work here to get a found set to display on client. I've also been looking into the "MasterDetail" setup by Todd Geist. Pretty awesome stuff, just not sure if it's the right solution for me yet.  Thanks in advance to everyone.. I also attached an image of the relationship for this example. I put a lot of information for this simple task, just wanted to be clear as possible.   Â
  3. I have a fairly decent size FMdb; everything seems to be working as I want it, as far as calculating and presenting the information I want. However, it's really slow on generating Summary Reports when I'm connected to it on a WAN, or on a FMGo. The reports has a lot of calculation fields; Some values are ExcuteSQL for some Dynamic value changes, and some are TO related calculations. I wanted to try the Perform Script on Server, but I can not wrap my head on how to get started. The reports I'm running, is basically doing a Find and Sort. I don't understand how the Get(Result)?? to get the found and sorted information to the Layout I want to display. Any help/resource would be great. Thanks.
  4. Hi, I get error 800 in the "Export Records" script step when executing it as PSOS. The file path is set in a variable ($path) as a calculation: Get(TemporaryPath)& "tmp.fmp12" This script works well when executing it to save the file to the local temporary folder (OS X El Capitan), but returns an error when executing it as PSOS (Windows Server). I believe it can be a permissions issue, but I thought the temporary path was accesible from FM Server "by default". Anyway, any insights are appreciated, thanks!
  5. I have a system being hosted using FMS14. I also have a duplicate database hosted for testing/exporting using FMS15. PSOS is much slower in my hands with FMS15. Both servers are physical boxes, with similar (maybe identical) specs (Cores, RAM HD Space, HD Space available) I also have a Server Side script that creates a found set, exports data to excel and emails it to a user. (This is based on https://www.skeletonkey.com/restoring-filemaker-clients-found-set-within-server-side-script/). The exports have a couple of related fields, but no unstirred calculations. Using FMS14 this has been working just fine. Using FMS15 it has been significantly slower. As a test, I exported 13,000 records from both FMS14 and FMS15. Using FMS14, it takes about 10 Seconds to recreate the found set, then 70 Seconds to create the export. Using FMS15, it takes about 20 Seconds to recreate the (same) found set, then 175 Seconds to export the data. In another series of tests, this time exporting 30,000 records (more realistic in my scenario) I found; Using FMS14, it takes about 25 Seconds to recreate the found set, then 168 Seconds to create the export. (2.5x longer to find/2x longer to export 3x records) Using FMS15, it takes about 90 Seconds to recreate the (same) found set, then 825 Seconds to export the data. 9x longer to find/11x longer to export 3x records) In the last series of tests, this time exporting 50,000 records I found; Using FMS14, it takes about 59 Seconds to recreate the found set, then 262 Seconds to create the export. (6x longer to find/4x longer to export 5x records) Using FMS15, it takes about 160 Seconds to recreate the (same) found set, then 1700 Seconds to export the data.(16x to find/24x to export 5x records) Any ideas? Anyone see similar results with PSOS on FMS15? Again, the machines are identical, the databases are identical and the scripts are identical. the only difference is FMS14 vs. FMS15. I am also letting another user pull data using ODBC. That has also gotten extremely slow using FMS15, but that is a discussion for another thread. I am not using WebD on this server. In general the FMS15 database performs find using FMP Clients. But the FMS15 functions are not very impressive. I am petrified to move my production database to FMS15, and even considering moving the test server back to FMS14. Help! TIA Jerry
  6. Hi, I have a problem with server side import of records. I have a simple script which just does an import of a textile (with tab delimiters): Set Variable [$FileList; Value: "filewin://server/folder/1795739.txt"] Go to Layout ["files" (files)] Import Records [No dialog; "$FileList"; Add; UTF-8] When I run it client side, everything is fine. When I run it server side with Perform Script on Server I'm getting an error: The previous script step, "Perform Script on Server", could not be completed because of an error.... If I run Get ( LastError), I get error code 100 (File is missing) I have tried many different file locations for the textile. Network path, Local path (on the FM server) and Relative path (from where the database is placed on FM server). I have tried placing the file in the FM server Databases and Documents folder AND the User Documents folder: filewin://server/folder/1795739.txt filewin:/C:/Users/ARAXI/Documents/1795739.txt filewin:/C:/Program Files/FileMaker/FileMaker Server/Data/Documents/1795739.txt filewin:/C:/Program Files/FileMaker/FileMaker Server/Data/Databases/1795739.txt file:1795739.txt Every time I get error 100. What am I doing wrong?? FileMaker server is v14 on Windows Server 2008 and the client is running on Windows 7.
  7. LS, My plan is to let the FMS handle more duties, without overloading the server. For instance 25 PSOS are allowed, so I would like to get the count of those sessions. How do I do that ? I would like to think there would be a simple way to know how many sessions are running and which script they are running. Or shouldn't I be doing this at all ? Regards.
  8. Dear FileMaker Pros, Perform Script on Server (PSoS) Doesn't Run I run FMP 13 (on Windows.) I import records to my Hosting FM Server from my Client. Running the script steps from the Client works well, but its a time consuming task of more than 4 hours, the records are big, almost one million. To save time, I switched the script to Perform Script on Server, (wait for completion, unchecked.) The script does not perform Import records, as it did without PSoS. My script steps on the hosting Server Db: ScriptName:"Import A" > Go to Layout ["Part_A"] > Go to Field [Select/perform; Stock_A::Field_A] > Go to Record /Request/Page[First] > Import Records [No dialog;"Receive_Gen"Add;Windows ANSI] My Perform Script on Server on Client: > Go to Layout ["Part_A"] >Perform script on Server ["Import_A"] > Go to Record/Request/Page [Last] Note: Unchecked - wait for completion Would appreciate your comments. Thanks in advance Lawrence
  9. I had a request to print PDFs from an iPad. In the past I created a bot that based on Sic Fried Rice's (if I'm not mistaken) technique would print a label on a label printer by triggering a script from the iPad. I would like to be able print without setting up a Bot, PHP or using a plugin. I got close but for some reason I'm stuck on the last bit and I'm sure other developers have done this before. So the process I came up with so far is: 1, I found a lightweight utility called SumatraPDF which I copied to the Doc folder on the Windows FM 14 server 2. I populated a global field with the batch file string to print the document (e.g. "C:\Program Files\FileMaker\FileMaker Server\Data\Documents\sumatrapdf" "C:\Program Files\FileMaker\FileMaker Server\Data\Documents\1.pdf" -print-to-default) 3. I created a print script for the iPad that runs a PSOS script that exports the global field to the documents folder and opens it So when running the script from the iPad I can see it creates the correct batch file on the server and I can click on it manually to run - it works Problem is it doesn't print when run from the iPad. Maybe 'open automatically' isn't supported on PSOS? I'm open to other ideas.... Dan Update: seems that it is unrelated to printing - the batch file just doesn't get run.
  10. Hi Guys, I am having trouble with Find Operation getting slower and slower each day. There are some design consideration as per some articles i have read recently which i will be doing as well. I inherited this solution from another developer, Find is based on some Calculation fields which are based further on some other calculation fields (both calculation fields have 'Do not store results' option checked) I know its not the best of designs, i wanted to ask for any possible improvement to Find process as its getting clumsy now. I have indexed relevant fields though, data in the table isn't huge, around 2000 records with 50 fields but Find is based on unstored calculation fields mainly. Can PSOS be used in Find Operation? Is there any other thing i must do at the beginning. Thanks much,
  11. I have a Windows Server 2012 R2 Standard (64bit, 48gb ram) running FileMaker Server 13.0.9.905 and we have a problem where PSOS 'clients' are not getting disconnected after the script runs. They eventually fill up the activity 'client' window and over a few days the server eventually stopped accepting new connections since we hit the 'maximum simultaneous script sessions' limit. I have been watching this over a few months and the problem seems to go away after a reboot ... it seems to work fine for a few days disconnecting the session after the script runs, but then we go back to the same issue where it seems to never disconnect their session. we have a handful of psos scripts that have the same result when the problem happens, it doesn't disconnect any of them. What's odd is that the users quit at night, so they are no longer connected and we have a 4 hour disconnect idle client setting ... and these ghost clients still are connected. and they stay connected until i forcefully "disconnect" them (in the activity screen) or reboot the server. the scripts that are running normally take about 5-10 seconds to complete normally ... they are a basic script that finds records and creates new records based on the found set. I don't see any odd records appearing in the database (like an infinite loop occurring), and if an infinite loop was occurring I assume this wouldn't be a random situation but would always consistently not work. Also in the log i see no reference to the session after the first minute of the script running even though it is still listed in the activity ... which implies to me that the session is not doing anything. these scripts have the "exit script" step at various junctures, as an example ... if none found ... exit script, so the script rarely finishes without a true exit. scratching my head on this one and wondering if anyone else has seen similar issues
  12. Weird issue here. Running FMS 13.0v5 and FTPeek 1.66 enterprise on OS X 10.10. I am working on a script A calling FTPeek upload to FTP. Script B calls script A as part of an overall process. When i call script B from script A with usual Perform Script, everything works fine. However when i call it with Perform Script on Server (PSoS) - which is supposed to be supported by enterprise license - the script basically hangs. Then the FMS Admin-Console Activity/Clients shows a client connection as "FileMaker Script" which will basically won't leave the queue - even if I send a disconnect message. Only way to solve the issue is restart the entire host...! When running in debug mode from FMP, the moment script B calls script a with PSoS, FMP just freezes and I need to force quit it. I understand that 1.66 brought support for PSoS but that only applies to enterprise license which is what i have as my order confirmation message tells me so... Any idea anyone ? Logs attached. Thanks 360Plugins_ServerScripting64.log
  13. Hi, i am trying to implement Tim Dietrich "EasySync" utility to enable users to work on the system while in areas with poor connection and then sync when back to the office. I know that there is a part of this forum where people discuss only the "EasySync" but i think that my issue is somehow more related to the client - server connection and Psos than to Tims scripts as such. The scripts are using and seam dependent on PSOS feature. First time i installed the demo files and configured the features as per given tutorial it worked fine and processed whatever it was supposed to process. After a few successful intentions the script suddenly stoped working giving an endless loop on any Perform on server instance of the script. I was disabling one by one "Perform on server..." script and testing in Script Debugger and it always stops on the next script that is supposed to perform on the server which pretty much tells me that this particular feature stoped working for some reason (Psos). Why is this happening? - Is it possible that PSOS feature gets blocked by the server after some time (the server is AWS Wndows 2012 server) or for some reason. - Could it be just my computer (I am using a Mac for this and i also fullishly upgraded to Yosemite which brought me a lot of issues, maybe this one also has something to do with Yosemite)
  14. Most of my medium to heavy scripts are now performed on server. To give the users some feedback while they wait, I wanted a method that was simple and subtle. In this example I ; added a popover button with '+' icon set the feedback message in the popover title bar formatted, sized and positioned the popover added a OnObjectEnter script tigger to the popover in the script I add a PSoS step with Wait for completion set to 'On' last step of script is Close Popover
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.