Jump to content

Search the Community

Showing results for tags 'upload'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Community Forums

  • The New FileMaker Platform
  • Community Resources
    • Community Articles, Tips, & Techniques
    • FileMaker Marketplace Discussions
  • FileMaker Platform
    • FileMaker Interface Features
    • FileMaker Schema & Logical Functions
    • FileMaker Go for iPad and iPhone
    • FileMaker and the Internet
    • FileMaker Pro Advanced 18
    • FileMaker Pro Advanced 17
    • Legacy FileMaker Platform Discussions
  • FileMaker Server Administration
    • FileMaker Server 18
    • Zabbix Server Monitoring
    • FileMaker Server 17
    • FileMaker Cloud
    • FileMaker Custom SSL Certificates
    • oAuth and External Server Authentication
  • Brain Food
    • Security Concepts
    • The Left Brain
    • Upgrading & Migration
    • Data Analysis
    • Development Standards
    • The Separation Model
    • Relational Database Theory
    • Damaged / Corrupt File Problems
    • Bar Codes (Printer, Scanners, Software)
    • Hardware & Networking
    • OS Level Database Automation
    • Product Ideas
  • JavaScript Integration
  • FMForums Affiliates & Sponsors
  • FileMaker Classifieds
  • FM Forums Operations
  • FileMaker Friday Night Chat's Topics

Blogs

There are no results to display.

There are no results to display.

Categories

  • White Papers
  • Infographics
  • Samples
  • Solutions
  • FMGo
  • Plug-Ins
  • Tutorials

Product Groups

  • Workplace Innovation Platform
  • Site Advertising
  • Development & Hosting

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Title


Industry


Location


Interests


Website URL


Skype


MSN


Yahoo


OS Version

Found 7 results

  1. I'm trying to upload a new solution to FMS. When I attempted to connect using the saved credentials, it threw the error "Invalid name/password. Please try again." Unfortunately, the login pane was grayed out, so I could not make any changes. So, I went into Keychain Access and deleted the credentials. Now, there are no saved credentials, but I am still unable to access the login pane. I see my server in Local Hosts, the IP address is correct, and I can access the Admin Console. But I can't log in to upload. I have managed to lock myself out of my own server. How embarrassing is that? FMS 16 FMPA 16 MacOS Sierra
  2. There's some FTP code posted but here's a basic SFTP version. Feel free to correct me or add to it and post. Some elements actually might not be needed or could be better written. I'm not a programmer per se so be nice..... /********************************************************************************************************** * SFTP Upload * parameters are * sftp_hostname, sftp_username, sftp_password, sftp_port (should be 22 I believe) * remote_directorypath, local_directorypath, local_filename * * JSch is licensed under BSD style license. * http://www.jcraft.com/jsch * http://www.jcraft.com/jsch/examples/ * http://epaul.github.com/jsch-documentation/javadoc/ * * Jar file: http://sourceforge.net/projects/jsch/files/jsch.jar/0.1.44/jsch-0.1.44.jar/download * * Disclaimer: This code is provided as is without any guarantees,warranties or representations * User is responsible to verify all legalities * Finally - This is just a base. Feel free to add to it and post..... **********************************************************************************************/ import com.jcraft.jsch.*; import java.io.*; JSch jsch = new JSch(); Session session = null; String result_text = ""; // Use External Function SMGetVariable( variableName ) to return to FM try { session = jsch.getSession(sftp_username, sftp_hostname, Integer.parseInt(sftp_port)); session.setConfig("StrictHostKeyChecking", "no"); session.setPassword(sftp_password); session.connect(); Channel channel = session.openChannel("sftp"); channel.connect(); channelSftp = (ChannelSftp)channel; channelSftp.cd(remote_directorypath); // check for file on local drive if (new File(local_directorypath + local_filename).exists()) { File f = new File(local_directorypath + local_filename); channelSftp.put(new FileInputStream(f), f.getName()); // check for file after upload using jsch's ... Display info about path cmd Thread.sleep(2000); if(!channelSftp.stat(remote_directorypath + "/" + local_filename)){ result_text = result_text + "Upload Failed"; // returns to FM } else { result_text = result_text + "Upload Completed"; // returns to FM } } else { result_text = result_text + "File not found on local drive. Verify path and file name"; // returns to FM } } catch (JSchException e) { result_text = result_text + e.printStackTrace(); // returns error to FM } catch (SftpException e) { result_text = result_text + e.printStackTrace(); // returns error to FM }
  3. OK - we now have a working CloudMail solution that sends any number of emails with attachments (as URL links). I have two minor issues with it: 1/ Any images that we use on the HTML email (which are uploaded as attachment files, but not specific to each 'campaign') if we use as HREF links, don't work. If I check the message source the URL is there but it is prefixed and suffixed with a pile of coding which messes up the link. e.g. <a href=3D=E2=80=9Dhttp://momentumski.com/=E2=80=9D>. Any ideas what the E2=80=9D is all about? 2/ The attachment link, which is automatically uploaded prior to send the email opens in web browser. I would like to force this to download which I can do by changing the PDF file metadata to Content-Disposition:attachment on the AWS S3 file storage. I know that it is possible to assign this during the upload to the AWS server, but I don't know if the 360works CloudMail plug-in can manage it. Any ideas? Many thanks - almost there .... Anatole Beams
  4. I would like to use a scripted upload. I store the base url in a global field (ui::SCBaseURL), and can use this in a webviewer to upload and view files via supercontainer as expected. The calculation is: ui::SCBaseURL & "/Completions/SO/" & Substitute( order::id; "/" ; "-" ) &"/scan" and this works as expected. I then change the webviewer to this: ui::SCBaseURL & "/Completions/SO/" & Substitute( order::id; "/" ; "-" ) &"/scan?style=noupload " so that I don't get the upload button. Great. All works as advertised. I then attach a button to the layout with a script which effectively start with the following variable assignment and test: Set Variable [$result; Value:SCSetBaseUrl( ui::SCBaseURL )] if [ $result - "ERROR"] ... I get permanent errors at this point and SCLastError gives me a "java.lang.NullPointerException" error. I'm using v2.832 of the companion plugin, and 2.82 of the SuperContainer server (since I can't restart the server at present). Is it just down to the server version mismatch, or am I missing something else? Any suggestions welcomed.
  5. I am evaluating File Maker Pro 14 and Server 14. After uploading a database to Sever 14, when the FM tries to open the version on the server I get this error: The file "DBTrackingODBC.fmp12" could not be opened. (Extended privilege diabled) The first database I tried worked, but this one it not. The only real differences are that I added an Admin password to this one and the tables are ODBC (to an Azure SQL server database if that matters.) If I try to open the database via WebDirect on the browser, it asks me to login. But it will not accept my database's admin password. So I tried the server admin password and my ODBC database password to no avail. I have anonymous access enabled in this database so if I click cancel, my database comes up but all of the fields say <Data Source Missing> How do I get access to the database from FM? and what password am I supposed to be using in WebDirect? I am on Windows 10 and the server is running locally. Thanks, Brad
  6. I have a developer subscription. My FMS17 works fine on OSX 10.12.6. I installed FMS17 on a Win7 (VMware) virtual machine (developer should allow up to 3 FMS) and FMS seems to work fine: I login, see the demo file, etc. The problem is that when I try to upload a DB from FMPA, both from OSX or from the VM Win7, I see the FMS but the login pane is greyed out. I reinstalled FMS to no avail. Is there a problem with Win7? Something else? Thanks Trevix
  7. Anyone out there know if such a thing should exist either as an AppleScript or a shell command? thanks - Anatole
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.