Jump to content
James Gill

SuperContainers Log directory cannot be written

Recommended Posts

I am running a fresh installation of 360Works SuperContainers v2.93 but when I start the SuperContainerServer standalone, I get an error message that says "Problem starting/stopping: Check Folder permissions as Log File cannot be written"

I've checked the 360Works website and can't find any articles describing this exact issue, however I do see an article that shows the default directory of the Log files that SuperContainers uses and noticed that the OS (WIndows Server 2012 R2) does not have the directory required...(C:\Documents and Settings\SuperContainer\SuperContainer.log) but if I try to manually create the Folder it tells me it already exists.  This issue persists regardless of where I try and run the application from.

Any suggestions?

Edited by James Gill

Share this post


Link to post
Share on other sites

James-
With Windows 2012, SuperContainer Standalone is actually going to write to C:\Users\SuperContainer\. The Documents and Settings folder is just a symlink to C:\Users. What user are you trying to run SuperContainer as? And can you check the permissions on C:\Users\SuperContainer and make sure it is writable to that user? Thanks!

Share this post


Link to post
Share on other sites

Hi Ben,

I'm trying to install and use SuperContainers as myself.  I should be a directory admin, which grants me local admin access to the server.  Obviously this is not going to be the final deployment, but for testing purposes I've had it working in the past without issues.  On that note, what does 360Works recommend as far as running SuperContainers as a standalone server and running the SuperContainers.jar as a service?  Is it doable?  Or do I need to keep the user that is running the standalone jar logged in?

From what you wrote it appears as if you want me to create a folder within the 'C:/Users/' directory called 'Supercontainers'?

Edited by James Gill

Share this post


Link to post
Share on other sites

After you've run the SuperContainer jar file, is there not a folder already created at 'C:\Users\SuperContainer'? You can also change the location SuperContainer uses to store files/logs from within the jar file in the Options menu.

If you'd like to run SuperContainer as a service, the best option is probably to use the installer on the same machine as FilemakerServer, or do a manual install that will then use Tomcat as the service on a machine without FMS. To run the standalone jar, the user would need to be logged in.

Share this post


Link to post
Share on other sites

Ben,

There is no 'SuperContainer' folder in the Users folder, and manually creating it does not resolve the issue.  Changing the store directory of the files/logs in the jar file also does not resolve the issue.

Share this post


Link to post
Share on other sites

Hi stanmcman,

The standalone server will attempt to write logs into the same directory as where you have it pointed for the "Files" directory. Click the Options button on the user interface and see what path is in the box for Files directory. Next, make sure that directory has read/write permissions. To check permissions, I will typically allow read/write permissions for everyone on that directory (and if necessary, their parent directories) and then start the standalone jar and see if that clears the issue. If it does, the permissions is definitely the cause and you can adjust them accordingly. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×

Important Information

By using this site, you agree to our Terms of Use.