Jump to content
dysong3

Webdirect stopped working

Recommended Posts

Hello,

I have a FMS 15.03 running on Sierra.  I recently upgraded the OS from 10.12 to 10.12.2.  As soon as I did this Webdirect stopped functioning.  The webdirect URL gives a "404 not found" error message.  I have tried downgrading  the system from Time Machine backups to 10.12.1 but to no avail.  I have checked all the troubleshooting items that can be found here.  There is nothing I can find that would impede webdirect's functionality.  Would anyone have any idea what might be amiss?  Or any ideas for getting Webdirect back up and running?

Edited by dysong3

Share this post


Link to post
Share on other sites

Can you get to the web server, not any FMS part of it, just the name or IP address of the web server?

What does the FMS admin console report?  What does the FMS event log report after an FMS restart?

Share this post


Link to post
Share on other sites

At a minimum I would try to run the deployment wizard again. After that, you can try to reinstall FM Server. What usually works is a "clean install" of FM Server. That means back up all settings and files, stop the server, uninstall it, delete the directory from Library and reinstall it all from scratch.

I have especially found this if you have the Server.app installed, as it turns on its own web server, regardless if you have it on or not. If you do have that installed, make sure you turn off web services before reinstalling FMS.

Share this post


Link to post
Share on other sites

Hmm.  My problem keeps reappearing.  When I try to edit deployment the web server fails with the following error message:

Quote

Test web server (http://127.0.0.1:80/fmi-test/test.xml): Error code = 404

Any ideas what may be provoking this?

Share this post


Link to post
Share on other sites

As per Mike: do you have the OSX Server app installed?

If not, anything else running on port 80?

Share this post


Link to post
Share on other sites

No I don't have OSX Server running.

Here is what is using port 80

Quote

COMMAND    PID     USER   FD   TYPE             DEVICE SIZE/OFF NODE NAME

java       315 fmserver  153u  IPv6 0xba1c9772f2d76b33      0t0  TCP localhost:56255->localhost:http (CLOSE_WAIT)

java       315 fmserver  183u  IPv6 0xba1c9772f2d390b3      0t0  TCP localhost:56237->localhost:http (CLOSE_WAIT)

Safari     910 serveur1   29u  IPv4 0xba1c9772f2d3365b      0t0  TCP 10.0.1.14:56746->dia.tizoo.com:http (ESTABLISHED)

Safari     910 serveur1   47u  IPv4 0xba1c9772e8d2aa3b      0t0  TCP 10.0.1.14:56621->a95-101-72-136.deploy.akamaitechnologies.com:http (ESTABLISHED)

Safari     910 serveur1   49u  IPv4 0xba1c9772f2d7bd63      0t0  TCP 10.0.1.14:56622->a95-101-72-114.deploy.akamaitechnologies.com:http (ESTABLISHED)

com.apple 1087 serveur1    5u  IPv4 0xba1c9772ea399a3b      0t0  TCP 10.0.1.14:56637->ec2-184-72-235-40.compute-1.amazonaws.com:http (ESTABLISHED)

com.apple 1087 serveur1    9u  IPv4 0xba1c9772e8d2865b      0t0  TCP 10.0.1.14:56638->ec2-184-72-235-40.compute-1.amazonaws.com:http (ESTABLISHED)

com.apple 1087 serveur1   12u  IPv4 0xba1c9772ec4b484b      0t0  TCP 10.0.1.14:56642->bud02s23-in-f14.1e100.net:http (ESTABLISHED)

com.apple 1087 serveur1   16u  IPv4 0xba1c9772ec4b365b      0t0  TCP 10.0.1.14:56645->bud02s23-in-f14.1e100.net:http (ESTABLISHED)

com.apple 2517 serveur1   11u  IPv4 0xba1c9772ea39646b      0t0  TCP 10.0.1.14:56659->212.222.52.198:http (SYN_SENT)

com.apple 2517 serveur1   16u  IPv4 0xba1c9772ec7fda3b      0t0  TCP 10.0.1.14:56749->server3.ahja.ch:http (ESTABLISHED)

All this appears to me, (but what do I know) associated with FMS.

Share this post


Link to post
Share on other sites

Just reporting that redoing the upgrade to OS 10.2.2 and the doing a "dirty" FMS install (i.e. not clean) seems to have resolved the issue.

Edited by Lee Smith
typo OS should be 10 not 12

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×

Important Information

By using this site, you agree to our Terms of Use.