Jump to content
dysong3

some scripts make FM15 crash, but not FM 14, 13 or 12

Recommended Posts

I have a number of scripts that have worked perfectly for years in previous versions of FileMaker, however in FMP 15 they causse FM to crash.  They only way I have found to avoid the crash is to use the debugger and to use the "step into" button.  That of course is a very cumbersome workaround. You can see one of the culprits below.  Anyone have any ideas what's wrong here?

 

 

Untitled 2.jpeg

Edited by dysong3

Share this post


Link to post
Share on other sites

On what step does it crash, and what does the crash log say?

As an aside: you should avoid copy and paste.  As step # set a variable to the content of the field.  And in step 4 set the field to the content of the variable.

Share this post


Link to post
Share on other sites

Sorry for being a dummy, but how do you access the FM crash log?  I've just googled it and found nothing.

Of course you're right about copy and paste.  It just goes to show how old some of these scripts are, they were made before variables were part of FM and I've never got around to correcting them.  That is not the reason for the crashing as I've just corrected it and it still happens.

Edited by dysong3

Share this post


Link to post
Share on other sites

Have you tried using the Error Capture in your script?

It sounds like your file may have developed corruption. 

Have you tried opening it in the previous version of FileMaker? Does it still crash?

Do you have a backup copy of the file? If so, does it have the same problem?

 

Share this post


Link to post
Share on other sites

Hmm Error capture doesn't seem to offer any help.  The scripts still work perfectly well in previous versions of FM.  I have backups and the oldest backup I could find, more than a year old, behaves in the same manner.  The same scripts make FM15 crash.

Share this post


Link to post
Share on other sites

When an app on Mac crashes you have the option to view or save the crash log.  Sometimes there are good clues in there.  Don't paste it here because it is long, paste it into a text editor and attach it here.

Share this post


Link to post
Share on other sites

Do you have any onTimers on the any open windows?

Is there a web viewer on any of the layouts involved?

Share this post


Link to post
Share on other sites

Remove the web viewer from the layout and see if it still crashes.

Share this post


Link to post
Share on other sites

Well the web viewer appears to be the culprit.  But that doesn't resolve my problem as I would like the script to work and keep the web viewer.  Any ideas on how to do that

Share this post


Link to post
Share on other sites

We would need to know a lot more detail about the process / workflow that you have going...

Share this post


Link to post
Share on other sites

Hello,

Your Os seems to be Sierra and Java 1.6 ?

It seems also that you don't have engouh free memory. Maybe the cute / paste is using to much memory in the clipboard.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×

Important Information

By using this site, you agree to our Terms of Use.