Jump to content
jorfasan

Filemaker Server 16 and Windows 10

Recommended Posts

The FM specifications state that (On Windows platform), the Windows 10 OS is nos apparently supported.

Any experiences about installing FMServer 15 or 16 under Windows 10?

Thanks in advance,

 

Jorge

Share this post


Link to post
Share on other sites

not supported, so why would you want to?

You'll find plenty of posts of people who have tried with 15, some were able to make it work, some didn't.

Share this post


Link to post
Share on other sites

Consumer-grade Windows OS is lacking many of the optimizations that a true server has. Along with vast differences in prioritizing of services and processes, it is truly a different kind of beast.

As Wim said, you may get it to work. You may get it to partially work. It may put your data at risk. Or it may fail completely. At that point, you have no support options with FMI. They won't help you until you get it onto a supported OS.

Some important things to keep in mind should you continue down that route.

Share this post


Link to post
Share on other sites

Well it is the classic strange issue that comes to me.

A company set up a server in a NUC5i5RYH with Win10 and said it was good enough for FMServer 15… and it was not supported.

I can see the tech reasons in favor of the server-grade Windows OS

I will try a search in order to see if the difficulties are beatable. 

Thanks, folks !!

Share this post


Link to post
Share on other sites

How many users?

Share this post


Link to post
Share on other sites

4 users 

 

The 4 machines are: (3 windows and 1 mac.

Next year perhaps the 5th license to be used with FMGo. Not important.

Share this post


Link to post
Share on other sites

In my last job we developed for a customer that ran their FMS on a Win7 system. They had constant issues and rebooted the box nearly daily. We kept telling them to move it to a proper server OS. They haven't as yet.

You can always buy a Mac mini and run it on that for those few users. Here in Australia they sell for $800 and it's supported by FileMaker. Just make sure you don't skimp on backups as the mini only has a single drive.

Share this post


Link to post
Share on other sites

Well, it can work.

But you may run into issues like your Windows PC goes to sleep or restarts to install updates.

For Server you can configure more to keep it running all the time. Depends all on the compromises you like to make.

Share this post


Link to post
Share on other sites

As always helpful and concise messages.

I will search in the forum to give the instalation process a try. 

Thanks to all.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Who Viewed the Topic

    1 member has viewed this topic:
    Quito 
  • Similar Content

    • By Olypatchmaster
      Our network person and I have done a bunch of troubleshooting and came up with this summary and a few questions.
      Ever since we installed FileMaker 16 in our two-machine setup, Zulu has been failing. In the Zulu error log from C:\Program Files\360Works\Applications\logs:
      Oct 2, 2017 8:44:59 AM PDT com.prosc.mirror.config.server.FileMakerServerInfo getHostAddressForProperties
      INFO: Will use 127.0.0.1:16020 for direct WPE address.
      Oct 2, 2017 8:45:05 AM PDT com.prosc.fmpjdbc.FmXmlRequest doRequest
      INFO: Starting request: http://127.0.0.1:16020/fmi/xml/FMPXMLRESULT.xml?-db=DatabaseName&-lay=ProscNoSuchTable&-view
      Oct 2, 2017 8:45:05 AM PDT com.prosc.fmpjdbc.FmXmlRequest setProductVersion
      WARNING: Null product version; assuming 12
      Oct 2, 2017 8:45:05 AM PDT com.prosc.fmpjdbc.FileMakerException <init>
      INFO: com.prosc.fmpjdbc.FileMakerException: Error 959: XML Web Publishing is not enabled - Run the FileMaker Server deployment assistant and make sure that the XML web publishing checkbox is selected () username: domain\user / requestUrl:http://127.0.0.1:16020/fmi/xml/FMPXMLRESULT.xml?-db=DatabaseName&-lay=ProscNoSuchTable&-view

       I verified that the URL does indeed return an error code of 959. Playing around with it, I found that if you use the DNS name of the machine instead of the localhost IP:port (https://wpe.domain.edu/fmi/xml/FMPXMLRESULT.xml?-db=DatabaseName&-lay=ProscNoSuchTable&-view), the request returns an error 105 (expected response) instead. 
       
      I poked around on the internet trying to find out more about this, and discovered the -dbnames command; again, it works fine on the main https port (https://wpe.domain.edu/fmi/xml/FMPXMLRESULT.xml?-dbnames), but returns a 959 on the Custom Web Publishing port of 16020 (http://127.0.0.1:16020/fmi/xml/FMPXMLRESULT.xml?-dbnames). So it’s like XML is enabled on port 443, but not for the Custom Web Publishing port 16020. How is that possible?
       
      For reasons we don’t fully understand and haven’t figure out how to correct, both the FileMaker Master and the Worker machines ended up with the Web Publishing Engine. So I tried the port 16020 request on the Master server, and it works! Which is great, except we want it to work on the Worker machine, not the Database server which ended up with a WPE.
       
      Some questions:
      1)      We know XML is enabled on the main (port 443) site, what do we need to do to make work on the localhost:16020 site?
      a. I hope this involves moving the ‘Web Server’ listed in the Admin Console to the Worker machine, but if not any info on what might be going on there would be great.
      2)      If we can’t get the Worker machine to realize XML is enabled on port 16020, can we change the FM config so Zulu doesn’t use port 16020 ‘for direct WPE address.’?
      3)      If we can’t do that, are there any issues with installing it on the Master, other than the obvious issue that we don’t want the WPE on that machine?
      Thanks for any insight anyone might have.
    • By typewriter
      Where can I find information on Filemaker Server 16 caching and (re)calculation? I have this problem: a customer that I took over upgraded to Server 16. Workstations are still on 15. Now, a soritng... status dialog appears very often, something that didn't happen with the previous version (which was 15, I believe).
      I know there are changes made to the way FMS determines what to recalculate and when, but I can't find a document or webpage with a good explanation. I'd like to get a clue about where to look for the source of the problem. Anyone with a reference or hint where to look?
      Some data: server is a MacMini corei5, running 10.11.6, 12 GByte RAM, with a normal HDD (no SSD yet). Server cache is set at 4Gbyte. Database is not particularly big, but has a lot of filtered portals (where you'd have many related records that are filtered on the client). This may be a cause, but then: why now and not in a previous version of FMS? 
    • By gczychi
      Hi,
      I want to access a data base «Import.fmp12» hosted on FMS 16 with the new Rest API but cannot get it to work.
      Testing with «ARC Plugin for Chrome» (great tool, btw) and Postman.
      In ARC, I get the error 802 – Unable to open file; in Postman, I won't even get that far:  «Could not get any response»
       

      This is what I did so far:
       – The file is accessible fine with any FileMaker client using FileMaker username and password (triple checked spelling, etc.)
       – Can connect fine to WebDirect with any browser and http
       – Cannot connect using Rest API and http, so went for https
       – Got an authentication error with https, so
       – Installed a self-signed certificate both on the server Mac and on local Mac for my myowndomain.com
      Getting mixed results:
       – Firefox: myowndomain.com certificate: Error code: SEC_ERROR_UNKNOWN_ISSUER  (to be expected)
       – Safari: FMI Default Certificate: Certificate not valid (host name mismatch). For whatever reason, Safari doesn't use my certificate.
       – Chrome: strikethrough https but shows the WebDirect server
       – ARC Plugin: Using https://myowndomain.com/fmi/rest/api/auth/Import Can get now through to the server (no SSL-Auth problems anymore), but the result is: {"errorMessage": "Unable to open file","errorCode": "802"}
       – Postman: Using https://myowndomain.com/fmi/rest/api/auth/Import «Could not get any response» and an error message: «{"errorMessage":"Method Not Allowed"}»
       
      Any ideas?
      Thanks  for any help.
       
      Gary
       
×

Important Information

By using this site, you agree to our Terms of Use.