Jump to content
Keawe

supercontainer windows server webdirect won't show

Recommended Posts

Posted (edited)

Hello,

I installed supercontainer on my Windows server at aws Amazon. I also installed the companion plug-in. It shows up on Filemaker Pro no problem. But it doesn't show on webdirect. Any idea?

Here is my configuration:
- FMS 15, Windows 2016 server. 
- SuperContainer 2.94, build 9234.
- I have the companion plugin put inside "..\FileMaker Server\Web Publishing\publishing-engine\cwpc\Plugins".
- The plug-in I use is "SuperContainer_Companion_Plugin.fmx64".

Thanks.

P.S.: I will send an email to 360works. But just want to post it here so we can all share the solution. Thanks.

Edited by Keawe

Share this post


Link to post
Share on other sites
11 hours ago, Keawe said:


- FMS 15, Windows 2016 server. 

Not supported!  Only FMS16 runs on 2016 Server and I'm pretty sure there are valid (IIS) reasons why it is not supported.

Share this post


Link to post
Share on other sites

Solved it!! I didn't set my x-frame properly to allow webdirect to show the supercontainer in iframe.

If you run into the same problem, please go to your IIS config and set the iframe to ALLOW-FROM http://yourfilemakerserverhostIP/

It is secure since you are only allowing iframing from yourself.

That will do it. Hope you find this solution useful and don't have to pull your hair out like I did. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Who Viewed the Topic

    1 member has viewed this topic:
    Lee Smith 
  • Similar Content

    • By Jim Gill
      I just moved my solution from Server 15 to 16.03 and everything went smoothly except on small issue.  
      My solution has a WebDirect file that users login from the web.  The URL on my site is supposed to take the directly to the login screen but since the upgrade drops them directry on the WebDirect Home Screen.  Am I missing something?  Did something change in Server 16?  This worked flawlessly in 15
      Here is the link:
      https://fcserver.fernwoodcove.com/fmi/webd#FC_Databases
      Thank you in advance!
      Jim
    • By Milerfake
      IMPORTANT - I am currently installing Filemaker Server 16 on a desktop PC running Windows 7 Pro. I know that it is not ideal, but I havent been given clearance on using the Windows 12 server computer..
       
      After the files have been installed for Filemaker 16 Server,
      I am given a 1920 Error from Windows stating that I might not have the correct privileges to start the services.
      This cause the installer to cancel and rollback.
      I have updated bonjour, updated Java to the latest version, I have made sure that all the windows updates have been installed. I disables the DEP and I start using the setup.exe file found in the file folder of the Filemaker Setup folder.
      If anyone has encounter this issue before and knows or has any suggestions on what course of actions to try next, I will be very appreciative on thier help.
      I will also append to this if i find the solution.
       
      Currently in the process of uninstalling bonjour, java and the C++ files, restarting the PC and reinstalling the server files again.
      kind regards
    • By Agentshevy
      Hello everyone..
      Guess I have been away for a while. Not fully back though because I am not really engaged with computer tech stuff at the moment. However, I really stumbled across a problem earlier today while going through my email logs. I observed that a server script I had set up has not been attaching the Pdf file report as supposed to. It only delivers the message while leaving out the file attachment. I did test the script when I added it but what I did not test was the result when run by the server.
       
      Allow user Abort [Off]
      Commit Records/Requests [No dialog]
      Set Variable [$FileName;Value:"Summary"&".pdf"]
      Set Variable [$PDFPath;Value:Get(TemporaryPath) &".pdf"]
      Go to Layout ["Summary_Layout]
      Perform Script ["Print_Page_Setup"]
      Save Records as PDF [Restore;No dialog;"$PDFPath";Current record]
      Send Mail [Send via SMTP Server;No dialog]
       
      As at the time of my writing the script, I was not observant about server-side scripts. I did go back just recently to observe that the "Save Records as PDF" script step is not server compatible.
      Please, is there any work around on this? Much help is appreciated.
    • By Grundly
      Hello folks
      I am experiencing a peculiar behaviour, which is creating a user case problem, in a solution that is utilizing the Data Separation Model and WebDirect. I need to know if this behavior is normal, a bug, or if my implementation is incorrect.
      I've got an interface file and a data file. Each file has two Privilege Sets defined (in addition to [Full Access]); call them Floor and Manager. Floor has very restricted access, and Manager has more liberal access (but no where near Full Access).
      Scenario 1) I've made a script in the interface file which performs a re-login. A user logs in as Floor privileges via WEBDIRECT. User then performs the script and enters credentials for Manager. The interface file successfully performs the re-login and gains the privileges associated with Manager. However, the data file does NOT change, it does not re-login, and it still exhibits the behaviour of the Floor privileges. I know this is an incorrect implementation. Which brings me to:
      Scenario 2) I've made a script in the interface file which collects the account name and password from the user (show custom dialogue), stores them in temporary global fields and as local variables, clears the temporary global fields (keeps the variables), then performs the re-login using those variables (which works). The interface file gains the new privileges as expected. Then, that same interface script calls a re-login script in the data file, passes those login credentials to it, and then performs a re-login there in the data file as well. This works perfectly in FileMaker Pro Advanced, but it does not work in WebDirect. WebDirect still exhibits the same behaviors as described in Scenario 1: interface file does gain the new privileges, but the data file remains unchanged, retaining the original login's privilege set. 
      Thus, how can I make WebDirect act like FileMaker Pro in regards to getting both parts of data separation model to perform a re-login? 
      Thank you
       
    • By mbarrett65
      I have a report in web direct that shows a list of records. An issue I'm having is when the report includes enough records that the page scrolls, when I change the value of a field, and then click to another record, the page refreshes and leaves me at a different place in the list of records. Not very good from a user perspective. Is there anything I can do to prevent the page from refreshing or does that just happen when the browser sends the changed record info back to the server?
×

Important Information

By using this site, you agree to our Terms of Use.