Jump to content

Recommended Posts

I have a FileMaker server 13.v10 database solution that changed somehow during development and now does not display several WebDirect objects properly.

For starters, the text shows up as white on a white background, which it did not do before.  We have been and are using the Cool Grey theme.

Other problems with display:

1.  3 value lists will not display:  One a regular list from a set of values, another list from a related layout, and a third a filtered list from another layout.  Another value list works normally

2.  A picture in a container field (locally stored, not external yet) does not show.

3.  A filtered, sorted portal does not show the records, nor are they accessible in the portal. The filtering and sorting are straightforward.

We have tried several things to correct the issue:

1.  Made a new layout, grouped everything together and paste it on the new layout.

2.  Made a new layout and made the fields and portal from scratch.

3.  Simplified and changed the relationships to the portal

4.  Substituted simplified relationships for the value lists (just for testing.

5.  Tried the db on FM Server 16 and made most of the changes above, nothing was different.

6.  Used Dropdowns, Popups, and radio buttons, no change in behavior

7.  We had FMDiff examine the db for corruption, but they found no problems, so file corruption is not an issue.  We also compacted the db in order to reindex all indexed fields, but that did not help.


Everything works fine using FM client.  Only WebDirect has problems.



A photo showing the problems on WebDirect is attached, as is a photo showing the fields properly displayed in FileMaker Client.  Please forgive the look and feel; the photos show the layout as we made changes and are troubleshooting.

Has anyone seen this before?  Do you have any ideas how to fix it?


Thanks for your help.

View from WebDirect.png

View from FileMaker Client.png

Share this post

Link to post
Share on other sites

My guess is that the missing data is from a related file, and the file is not authenticating correctly.

Share this post

Link to post
Share on other sites

Thanks for your feedback.

It's a single file solution, so no related file and now authentication needed.  Also, it works fine in Client, just not in WebDirect.



Share this post

Link to post
Share on other sites

Something in the startup script? E.g., are you looking at a found set of none?

Share this post

Link to post
Share on other sites

Thanks for your feedback.

It's a single file solution, so no related file and now authentication needed.  Also, it works fine in Client, just not in WebDirect.



Solved!  It seems we did not try enough alternate themes to the Cool Gray theme.  The Vibrant theme fixed all the major problems, but still has some minor issues, such as Italic text on WD not present in FileMaker, and the need for a black background with white text for one of the portals.  Other than that, functionality is 100%!

Share this post

Link to post
Share on other sites

Well that's good, but hmmmm. A theme was the first thing I thought of, but it doesn't seem possible that a theme would cause a value list to display <no values defined>. 

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Who Viewed the Topic

  • Similar Content

    • By Jonathan Ackerman
      I am developing an app where users may login with Android or IOS via Webdirect.
      On IOS (safari) via Webdirect-- everything is fine.
      With Android(chrome)-- anytime the script refreshes the screen or switches panels-- all uncommitted data is lost.
      any ideas or workarounds?-- 
      my script checks validation and i really need to refresh to trigger conditional formatting
      also hoping to have a multi-panel entry so the user does not have to scroll to the bottom (layout has about 100 fields)
    • By xochi
      Suppose you have a WebDirect database that has both a [Guest] account and regular user accounts.  Is there any way with a special URL or JavaScript to do an automatic [Guest] login that bypasses the filemaker web direct login screen?
      Basically, I want to have a Public area of the site which never asks for authentication, and a members-only are which does, but I don't want to confuse the Public by making them click the [Guest] button ever.
    • By Morenomdz
      Hello there, I've set few text boxes per layout that work as "tutorials", with one button called "help" that changes one global field [tutorial] from Yes to No (and vice versa), commits the record.
      When the global field "tutorial" is set to yes, all the "text boxes" should hide, when it is set to no they should apear. It works perfectly in the fm client but when I got to the web even if I change the field to Yes or No in the client and save the record, the web still shows all the text boxes.
      It looks like the the "hide when" is simple not working. Using 
      table::tutorial = "yes"
      Did a test having the a tex field for the tutorial showing on the layout, it looks like the webdirect is not seeing the field content at all. It shows as empty on web and Yes or No on the client.
    • By jorfasan
      We have a development that if accessed by regular Filemaker Pro the button (via Open URL) that links to a document (word file) it does open the application (MS word) resulting a very satisfactory behaviour for users.
      But the same stuff when running with WebDirect the Chrome gets an 
      "not capable of opening the window; please deactivate the popup window blocker and try again". Well needless to say that that blocker is not active (under preferencies) and the IS manager of the net also verifies it is not blocked at her level. 
      Also firefox, same machine, is not able to open the application; in this case with no alarm / action at all. 
      Any clues??
      - Windows 7 professional, SP1 
      - Chrome: Versión 41.0.2272.118 m
      - Firefox:  36.0.4
      - FM Server:
    • By paul.s
      So, We have a unix admin working on our Mac OSX server. I specifically instructed them not to break our Filemaker 13 Apache install. Well it looks like they worked on the machine but broke one thing.
      Does anyeone know where I should look to fix this?
      What works:
      Webserver servers files fine from the Filemaker HTTP Folders.
      Filemaker WebDirect works fine.
      PHP is working.
      PHP is indicated as ON in FMSA Admin.
      Admin pages at http://localhost:16001/admin-consolework fine.
      Admin screen shows green on Webserver. Indicates PHP is enabled.
      This is the only thing that is not working:
      Previous PHP pages which has successfull connection to databases no longer connect to the database.
      I assume that a reference to filemaker somehow got removed from one of the php config files, but I don't know where.
      Can anyone give me an idea where to look?

Important Information

By using this site, you agree to our Terms of Use.