Jump to content

Recommended Posts

Posted (edited)

So I created a solution in Filemaker Pro and its appearance looks great.... until I open it in WebDirect on a web browser. Fields are cut off at the bottom, styles like Condense condense wrong, and rectangle boxes don't show at their full size. Also, the padding spacing on radio buttons is completely ignored.

I've tried three different browsers: Safari, Firefox, and Google Chrome, and all show the exact same results. The only way I am even remotely able to change the appearance for the WebDirect browser page is by scrubbing out all the style changes (mostly Condense) and that still only changes about 20% of the inconsistencies.

Thank you for any help.

 

Edited by Ponderosa

Share this post


Link to post
Share on other sites

Hi Ponderosa

The experience you are having is typical of WebDirect renderings of FileMaker Pro layouts. Not everything behaves as you would expect. When you are designing a layout that you expect will be used in WebDirect, then the advise is test, test and test again as you develop your solution, and use multiple browsers on multiple platforms to test with.

FileMaker explain some of the limitations of WebDirect at https://fmhelp.filemaker.com/docs/16/en/fmwd/index.html#capabilities , however some of the issues you mention are not listed there.

Part of the issue is that fonts behave differently in web browsers that they do in FileMaker Pro. You cannot guarantee that fonts will render at the same size exactly, or even that fields will be exactly the same size with the same positioning and size. Keep your WebDirect layouts simple, make sure you use themes (rather than styling individual layout items 'locally'). It is often advisable to have different layouts for WebDirect than the layouts intended for use in FileMaker Pro. It is a shame it has to be that way.

You show as using FileMaker 15 in your profile, improvements were made in FileMaker 16 Server for WebDirect, and you may find that some of the problems go away if you upgrade.

I hope this helps and you now know that you are not alone!

Share this post


Link to post
Share on other sites

Is it possible that part of the problem is that I'm working from 15 Pro, but "broadcasting" from WebDirect 16?

Share this post


Link to post
Share on other sites

rwoods, I forgot to say thanks for the help, and as an update to this post I organized my styles better and tested, tested, tested as you'd say, on the one layout needed for WebDirect. I'm fairly satisfied in the results, thought the layout looks REALLY weird in Filemaker, LOL.

Part of the end-result was directing the person to that layout ONLY if they're using a web browser by the "Get ( ArchitectureMode ) " function and getting the solution to go there if it said "Web Publishing Engine" and the version number.

(Middle section is included if needed for anyone else who gets stumped by my conundrum)

Oh, and I upgraded my Pro version to 16 yesterday afternoon, and there doesn't appear to be any change (oh, well), positive or negative.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×

Important Information

By using this site, you agree to our Terms of Use.