Jump to content
Sign in to follow this  
animation_master

Weird IsEmpty() Bug

Recommended Posts

I’ve just run into a bizarre problem. The result of a Boolean calculation in Data Viewer is different from the result of the same calculation in my Layout.

Here is the calculation:

IsEmpty (Address::Street)

I place the calculation in Data Viewer and in a Field on my Layout.

IN DATA VIEWER, this calculation evaluates “True” when the field contains no data, and it evaluates “False” when the field contains data.

IN THE LAYOUT, this calculation always evaluates “True”, whether or not there is data in the field!

I get the same results when I use IsValid().

Is there something obvious I’m missing here?

Share this post


Link to post
Share on other sites
Genx    1

Is your calculation field unstored?

Share this post


Link to post
Share on other sites

Yes, indeed, it's unstored, but... your question prompted me to click on the "Do not store results" checkbox. (I don't know, just to be sure.) When I did that I got the message, "This calculation cannot be stored, because..." That led me to look at the "Evaluate this calculation from the context of..." That's where the problem lay. Wrong context. Thanks for the brain jumpstart!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.