Jump to content
Sign in to follow this  
GeoSteven

Firewall setting - Web Browser will not display web viewer content

Recommended Posts

GeoSteven    0

We have FMSA 11 on (server name FM01) which is serving our "VM" app via IWP. We have SC installed as a stand alone on a different server (SC01) which has been modifed to place documents on a 3rd server (FS01). We will not be using the SC plugin so we've designed a portal with a web viewer next to it to show the document related to the record chosen.

Everything works as expected using an FM11 client or IWP… as long as we are within the firewall (on the LAN). If I try to access the docs (via IWP) from any point outside our office the browser brings back all of the related record information then after a few minutes the web viewer displays (… cannot display this web page…). I initially suspected this was a firewall issue so I added an entry to forward any reqs to port 8020 on our domain to port 8020 on the server which has SC running on it. This has not fixed the problem. If I enter http://outdomain:8020/SuperContainer/ into a browser outside the LAN it display a SC page and gives the option to upload docs (which I need to prevent if I can) which tells me the firewall is allowing the traffic. But still the application will not display the doc.

I've checked this from 3 different PC's using 3 different ISP's. I've also verified that the latest Java updates are installed.

What am I missing here?

Share this post


Link to post
Share on other sites
Smef    14

Steven,

I think you and I have been emailing about this issue, correct? I just want to make sure that this is the same person.

Share this post


Link to post
Share on other sites
GeoSteven    0

just to follow up on this - 360 works educated me on this. I was using the interal IP address (ex 192.168.111.111) in the web viewer URL instead of the external one (ex www.mydomain.com/subaddress). Naturally this failed because any user outside our LAN would be directed to their own local IP address.

A real 'duh' moment for me.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.