Jump to content
Sign in to follow this  

Strange Convert Behavior

Recommended Posts

Hi - 


I have a single file runtime solution, and working on an upgrade that requires conversion from pre-FMP12 format.  I'm using the Convert File script step.  I've run into something very strange.  My solution uses it's own file extension  .fhc.


So I've set up the Convert step with no dialog and with a specified source file - namely 'fhcm.fhc.  The first several times I tried this, the output file was named fhcm.fmp12 - as expected -- and the original file was left unchanged, since I specified no dialog.  (It does not get changed to a fp7 file extension.  


Somewhere along the way, the Convert File step started naming the output file FHCM #, where # is a digit, starting with 0 and incrementing if I do this multiple times.  It also changes the lowercase to upper case.


So instead of naming the converted file fhcm.fmp12 (which it had done at first), I now end up with a converted file named FHCM 0.fhc or FHCM 1.fhc, etc.


I can't for the life of me figure out what changed nor can I find any documentation of when or why it would do this.


Any thoughts?




Share this post

Link to post
Share on other sites

I think I've figured this out, and it appears to be a genuine bug - or else I missed the documentation.  It seems that runtime behaves differently when using the Convert File script step.  Documentation says converted file will get fmp12 extension, but when I run from runtime, with dialog turned off, it adds a space and digit to the filename but does NOT change extension.  Seem to be very consistent.  

Would be great if anyone else can test this.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • By halaeliya

      We are in the process of updating our FileMakerGo on the iPads from 13 to 16 but we are running into an issue with the sync. We are currently running MirrorSync 2.3 but will eventually upgrade to 3. Meanwhile, we need to get FMGO 15 or 16 work with our current MirrorSync.
      The sync error doens't always show, sometimes it syncs and sometimes it doesn't.
      Any ideas? 

    • By totoleheros
      I am struggling : I have a script using 360Works_ScriptMaster.fmplugin functions. It used to run smoothly with FMP12 and 13. I had to update FMP and now the 360Works_ScriptMaster.fmplugin would not load. I have tried with both FMP14 and FMP15. The 360Works_ScriptMaster.fmplugin is not listed in the pref pane of FMP14/15, while — on the same machine (and the same java 8.121 version) — it is loaded. I have tried to have the file in these directories: /Application/ FMP FileMaker Pro 14 Advanced/Extensions or the ~/Library/Application Support/Filemaker/Filemaker Pro Advanced/14.0 (or 15.0)/Extensions.
      No success. Could someone have a clue about my problem? Many many thanks in advance.
    • By bioplasma
      This is one of the hardest thing I been trying to acomplish, I want to transform the contacts module into a Donors module for our blood bank.
      I have transform most of the fields already to match the donor information we will need. However I want each donor to show in a portal all the units or (products) associated to that donor.
      Example: 1 Donor can donate blood every 56 days 1 unit (which has a serial number associated to it) 
      I want each donor to show all the products or units associated to him.
      Im sure this might be something really simple to some of you so any help will me much appreciated
      Thank you in advance for all the help  
    • By AntoineD
      I try to put in a container an audio file with the text pronounced by FM from a text field.
      As I didn't see how to do it from FM, I tried to build my first Perform AppleScript [] using the terminal command "Say"
      On the terminal : (say "hello") works fine.
      and (say "hello" -o filename.aiff) => creates a file with the sound "hello".
      From filemaker, Perform AppleScript ["say \"hello\”"] : make the Mac pronounce correctly.
      But I can't run :  Perform AppleScript ["say \"hello\” -o filename.aiff"]
      I have a error message "Identificator can't be after identificator".
      I couldn't find anyway out.
      Does any of you have an idea ? 
    • By bioplasma
      Recently i change my office PC to a Mac Laptop since is much more accessible for me. After getting Filemaker 12 for it, I try running the copy I have of FM starting point and this what happens.
      I will appreciated any help I can get to resolve this 
      Thank you


Important Information

By using this site, you agree to our Terms of Use.