Jump to content
Sign in to follow this  
SkiinIan

Select ODBC Data Source shows no entries

Recommended Posts

Trying to connect to an ODBC external data source in Filemaker Pro 16 Advanced

We have a windows 10 desktop with user DSN's and System DSN's specified, 

image.png.ed4dc7e4d8dc7bbd59aafafbe3872c62.pngimage.png.873c7d53fa1441313be64f88705c2795.png

However the Select ODBC Data Source shows no entries?

image.png.63d281948fcc68fff1f4358896ecf5f6.png

I have seen older posts saying that a System DSN has to be specified, but we did this and still nothing showing, is this a bug or am I missing a step.

 

Share this post


Link to post
Share on other sites

Just wondering, did you verify that the odbc drivers were installed and System DSN configured on the master machine (FM 16 Server)?

Share this post


Link to post
Share on other sites

Just wondering why you ask "  System DSN configured on the master machine (FM 16 Server)?" Because there is no server involved here just FM16 Pro advanced with a locally stored file trying to connect to an ODBC SQL database 

 

Share this post


Link to post
Share on other sites

Sorry, I misunderstood. I asked because I’ve made the mistake of installing drivers on a client machine instead of the server.

Are you using the right SQL version SQL 2012, or 2016?

Share this post


Link to post
Share on other sites

The server I am trying to talk to is a Windows server (not sure of the exact OS) and we can successfully connect using the ODBC drivers (ie in the ODBC settings we test connection and it completes with success. We can also connect using another application, Lotus Approach, using those same ODBC drivers. Someone else told me to try the 64 bit drivers so I will try that later today.

 

Share this post


Link to post
Share on other sites

Yes, that’s probably correct! In Windows, if you’re using the 32-bit version of FileMaker Pro 16, you must use a 32-bit ODBC client driver; if you’re using the 64-bit version of FileMaker Pro 16, you must use a 64-bit ODBC client driver. In macOS, you must use a 64-bit ODBCclient driver.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By jim.weeda
      For about 12 years, we've had a FileMaker database import external data from a .mdb  (Access) database that has data that is downloaded from some equipment.  The process has survived several computer upgrades (Windows XP and Windows 7) and FileMaker version upgrades (created in 7 and currently running in 16).  It broke when we moved into the Windows 10 environment.  The script is set up to retrieve the data from the .mdb file and it says it can't access the file.  So when I dive into the script and try to specify the ODBC connection it now asks for a username and password.  We've never had a user name or password tied to either the .mdb file, the ODBC connection, or the FileMaker file.  But no matter what we try, we can't get past this step.  Is this a bug?  What am I missing here?
       
      Thanks in advance.
    • By Scott Pon
      Using MS Access 2010. Filemaker 13 Pro, Filemaker 13 Server.
      I have a MS Access database that that I programmed to do a lot of calculations and creates data. Now I want that data saved in a Filemaker database.  I was able to create ODBC connection to the Filemaker database.  I am able to view the Filemaker tables/data in MS Access.  
      At 8AM daily I want the Access database to do the calculations, and then insert the data to Filemaker . However every time I try this, the Filemaker Login Screen comes up.  And I would have to manually enter the username and password.
      Is there any way to bypass the log on screen?
      Thanks in advance.
    • By trevix
      On windows 7 (VMware on OSX), using FMP17 and Microsoft Access 2016
      Trying to do a ODBC import and selecting the datasource, I get asked for Username and password, even if the Access DB is not password protected.
      The data sources are correct (tested from Livecode) and should be working without user name and password.
      On the properties of the ODBC pane setup the path seems correct (not pointing to 32): %windir%\SysWOW64\odbcad32.exe
      What am I missing?
    • By jchallenw
      Does anyone have experience and/or success using a 4D database as an external datasource through ODBC. I can add the system DSN and add it to FMP. Once I attempt to view the tables in the 4D database, I receive an error that the "ODBC connection is not compatible". Does anyone have a work around or suggestions? Thanks!
    • By Christopher Gauntt
      Hello all,
      I installed FileMaker Pro ODBC drivers, and was able to access the data with queries from Microsoft Excel.
      However, when I tried to access the same data with the same driver using Microsoft Visual Studio 2015, it could see the table occurrences, but it couldn't find any of the data columns.  It came back with the following error:
      " Error at Data Flow Task [ODBC Source [1]]: There was an error while trying to get schema information. Table has no columns."
      I got the same error, no matter which table occurrence I selected.
      Has anyone else run into this and solved it?
      I have been google searching without much luck.  Although I found one post of someone who claimed they were able to do it with Microsoft Visual Studio 2017, so maybe an upgrade is in order?
      Thanks in advance,
      Chris
       
       
       
  • Who Viewed the Topic

    6 members have viewed this topic:
    rivet  lucyblade  Draken Blue  jee  Kolbeinn Reginsson  Hproth 
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.