Jump to content
Sign in to follow this  

Unable to view pdf documents in container fields using Filemaker Pro (OSx Only)

Recommended Posts

I have encountered this situation in two separate instances.


     1) In the last company i worked for. I updated them to Filemaker Server 16

     2) With a current client of mine which i set them up on Filemaker Server 17


My dilema is the following:


I designed two completely different databases, one in each scenario and both have had the same issue. As i am designing the database (locally), i am able to upload pdf files and view/interact with them perfectly. However, as soon as i upload it to the server, i loose the ability to view/interact with pdfs anytime i connect via Filemaker Pro from a mac computer. The rest of the database works perfectly fine, scripts, layouts, fields etc. It works perfectly fine if i connect via Webdirect, Filemaker Go and Filemaker Pro (Windows Only); In any of the previous scenarios i am able to view/interact with pdf content. The only connection that gives me issues is via Filemaker Pro from a mac.


In my last company i pitched the idea of building a national expense management database and upgrading to the latest FM version (16 at the time). I was successful in building and implementing this system, however this pdf issue persisted and i exhausted all methods of testing (known to me), i even worked with a Filemaker Engineer (because we had support) for about 3 months and he could not replicate the issue and eventually i just gave up thinking that it was most likely a local problem. But now that i am working as a consultant, i am seeing the exact same issue with my current client and its completely unacceptable!


Honestly after working on this issue for so long, the only thing i can think that might have something to do with it is the SSL certificate/Secure connection back to the server. I know that since Filemaker 15 and up, port 443 has been used to insert data into container fields. There is a mismatch in the SSL certificate for some reason (still troubleshooting), but if that was really the case, then wouldnt there be an issue with Go, webdirect and not to mention FM Pro in windows as well? I am very sorry if i wrote too much, this is my first ever post in a filemaker forum. Please help me because this has been truly inconvenient and a major hindrance to any type of system i build. Images are attached (test database, which only has 1 container field to isolate issue).


Please let me know if there is anything else you might need to know to clarify things more.


Thank You.

(PROBLEM) Filemaker Pro Mac.png

Filemaker Pro Windows.png

Filemaker Webdirect.png

Filemaker Go iphone.jpg

SSL Connection PRO.png

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.