Jump to content

How do you turn off Font Smoothing?


NAL
 Share

This topic is 6451 days old. Please don't post here. Open a new topic instead.

Recommended Posts

  • Newbies

Have just installed FM Pro 7, only to find that the record font display is blurred and hard to read, whereas FM6 is nice and sharp. I have tried the three different font smoothing settings in Preferences, none of which improve the situation. Enlarging the window display is not an option. Does anyone know how to disable font smoothing?

Thanks for any suggestions!

Version: v7.x

Platform: Windows XP

Link to comment
Share on other sites

On Mac OS X, you can turn off font smoothing for fonts under a certain size (you specify) in the System Preferences > General settings.

Link to comment
Share on other sites

you post says your platform is Windows XP, if so, where are the three settings for font smoothing?

In 2000 "Smooth edges of screen fonts" is in the Display Control Panel in the Effects tab.

FYI, or more than you wanted to know:

Windows does font smoothing using a non-standard TrueType font record named gasp which determines what size to smooth. If the font is missing the gasp record, Windows uses a default font size to do smoothing. In Windows 2000, the default is 16pt. This causes some fonts to appear very jagged at normal screen sizes (the opposite of what you are seeing in FM7...).

There is a program named TTFGASP that runs under the Win32 console that inserts the gasp record with a low point size to smooth at.

Note that if "Smooth edges of screen fonts" is turned off, no font will smooth, regardless of the gasp record.

Link to comment
Share on other sites

  • Newbies

Thanks, everyone!

Think I need to clarify: Font Smoothing in XP is set to "Standard". FM6 displays fine with this setting; FM7 does not, and does not even with font smoothing in XP turned off.

Therefore it appears that FM7 is doing its own font smoothing, perhaps on top of what XP is doing. So a method is needed withing FM7 to turn off its font smoothing, and as yet I have not been able to find one.

Bad call, FM7, ditto on the Relationships interface, which used to be nice and clear and not even require thought. I have been using FM Pro because it DOESN'T act like Access; please don't take any cues from Microsoft and try and think for your users!

Unless FM7 comes out with an update, my guess is the only possible way to turn off font smoothing at present would be a registry fix, if there is one.

For CyborgSam: I think the default color setting is low, which may be why your colors don't look right. Check Edit, Preferences, Layout tab, and see what your color settings are.

Thanks all!

Link to comment
Share on other sites

  • Newbies

New and still getting used to the forum layout; note above for CyborgSam was meant for belgiumbruno.

For CyborgSam: the three font smoothing options I mentioned are in FM7 under Preferences, not in XP. The setting I used in XP is Display Properties, Appearance, Effects, etc. In that location, the only two choices are Standard, and ClearType. Not sure if there's another choice/location in XP.

Thanks!

Link to comment
Share on other sites

  • 1 month later...
  • Newbies

Hi all... I have been using Filemaker for many many years, and I just wanted to say that I too hate this new "feature" in FM7, the font smoothing. On all TFT screens we use in our office, FM7 looks awful, no matter what setting I select. Why isn't there a "Turn off font smoothing"?

I'm on the FM7 trial now, but I don't think we'll order the full version if this "enhancement" can't be turned off...

Link to comment
Share on other sites

  • 2 weeks later...

I went to the "FileMaker 7 Tour" in New York. The laptops they were using to show off FileMaker 7 were pcs and the image projected on the screen was amazing. So I asked why his screen was so clear. After the meeting I pressed the FileMaker Corperate guy that was there for a release date and he wouldn't budge. It is fixed because they would admit that the presenter had the new rev. on his computer.

And the waiting goes on......

Link to comment
Share on other sites

This topic is 6451 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.