Jump to content

Importing Japanese data?


markmanley
 Share

This topic is 6460 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I'm creating a new database and need to import some mixed (english and Japanese) data from a .txt file. Some fields (name, address, company) can contain both roman and japanese character sets.

How do I prepare the field in the database to receive the data? I tried the usual setup, but I get gibberish in the fields. NOTE - in the Import Field Mapping dialog box, I can see the Japanese characters, but upon hittinng "import" the data is corrupted.

Thanks in advance!

FileMaker Version: 7

Platform: Mac OS X Panther

Link to comment
Share on other sites

  • 2 weeks later...
  • Newbies

Did you chose a Japanese font for the field? It is usually Osaka.

I live and work in Japan, make bilingual databases on FM, and use it on OS X, OS 9 and Win 2000. Have just got my new version so will try it and see.

FM5 had some display issues, so I used FM5J, but FM6 seems to handle it OK, though I have only upgraded previous DBs, not created a new one.

On holiday for a few days, so be patient.

Link to comment
Share on other sites

Thanks for your help. I did use Osaka, but the data still shows as corrupt. The imported file itself is saved in SJIS format, and is a standard text file. I open it with TextEditor and it looks great. I'm excited to understand how this works, as i'm tying it in to Oracle databases, to pull real-time queries, which I'm managing over the web, for our Japanese office.

Thanks in advance!

Link to comment
Share on other sites

  • 2 weeks later...

Mark,

As an experiment, try creating a new field to accept the text, but before you leave "Define Database...", choose "Options...", go to the "Storage" panel, and change your default indexing language for the field to Japanese.

I'm not sure what it does, but the field is setup with different fonts, etc. If you can get that to work, then it is just some setting on your original field that isn't Japanese friendly.

PS: Update your profile - click on the link given to the left of your post to tell everyone what OS and version you use. This lessens the chance of receiving help that makes no sense to you. wink.gif

Link to comment
Share on other sites

This topic is 6460 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.