Jump to content

Open URl script not working

This topic is 7137 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Hi guys,

Having seen a recent post about using the Open URL function, I thought it would be cool to use this facility in my database to look up the destinations of our deliveries via www.multimap.com.

I have used the following syntax but it doesn't work and I get the equivelant of a 404 error on MultiMap's website. Can anyone see what I am doing wrong?



Link to comment
Share on other sites

I had no replies to this posting but have now solved the problem for those of you that are interested.

I created a calculation field combining the following URL and the postcode/zip field:

"http://www.multimap.com/p/browse.cgi?pc=" & Substitute ( postcode ; " " ; "" )

The Substitute will take out any spaces in the postcode (but in the US you of course have numbers with no spaces so not a problem for you guys). I then specified an OpenURL script with the GoTo address as the calculation field and Voila!

This little baby will now, upon clicking a button, go to www.MultiMap.com and show me exactly where my client, supplier, delivery address is, how fantastic!!!

Link to comment
Share on other sites

Question - just out of interest, I am seeing if i can work out how to call up Australia. I worked out to replace pc with au, but i can't get it to go directly to a postcode.

e.g an example of what "should" be our string for a postcode of 4000 is

<a href="http://www.multimap.com/p/browse.cgi?au=4000" target="_blank">http://www.multimap.com/p/browse.cgi?au=4000</a>

I can only get a map of australia. Any ideas?

Is 4000 a valid post code? It didn't return anything. However, I typed 400 (random as I have never been to Australia) in and it returned the address of Mulgrave Street, Brisbane. But this was when I entered the post code from their website, not when I sent the URl from FMP7.

Initially I couldn't get it to work either, took me a while to figure the UK coding. I would initially think you need to change the TLD to www.multimap.com.au and not .com.

Doesn't quite work yet but something like: "http://www.multimap.com.au/p/browse.cgi?pc=" & [Post/zip code field]

Link to comment
Share on other sites

This topic is 7137 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.