Jump to content
Sign in to follow this  
jeffer

web database errors (FMSA7.0v2)

Recommended Posts

Hi everybody! This is quite a long story, so please bare with me...

I am trying to publish a database to a website on my intranet (lan). So I installed filemaker server 7 and updated it with filemaker server advanced for the web possibilities. I've updated the whole thing to 7.0v2 since I like updating. So far so good! I've created a simple database with two fields and loaded it with some records and populated the fields. Next thing was to put the database in the filemaker server so that it would share the database on my network. When I open filemaker I can open the database and edit the fields and so on. I'm still going strong cool.gif

Next I started the filemaker site assistant and connected to my filemaker server. I selected the database file and created some xls files and saved them into the desired folder (root/library/filemaker server 7/web publishing/xslt-template-files/test/home.xsl). Note that I can't select any layout at all whitin the options for creating those files.After doing that, I pointed my browser to the address of the server (http://10.0.1.30/fmi/xsl/test/home.xsl). And this is where the problem starts.

The browser (safari, firefox, netscape) shows a screen with some options like 'show all records', 'add record' and 'find record. Unfortunatly it gives the following errors:

Find records: The prefix "sa" for element "sa:uses-valuelists" is not bound.

Share this post


Link to post
Share on other sites

Is the fmxml Extended Privilege activated in the Privilege Set attached to the account that opens the file?

Share this post


Link to post
Share on other sites

Hi and thnx for the answer!

I've set to extended privileges fmxml and fmxslt for all the user accounts. I think I need to register the web engine to the filemaker server, I just don't know how to do that:( And since I configured the web publishing engine, I can't connect to the web xsl files anymore and the site assistant can't connect to the server anymore...filemaker...what's going on there mad.gif

greetz,

Jeffrey

Share this post


Link to post
Share on other sites

To register the WPE to FMS, first in the client services tab of Admin Tool--the SAT tool not the Site Assistant--create a pass code and a pass phrase.

Then via the Web Console, enter that same pass code and pass phrase. That allows the FMS to know that the WPE calling it is legal.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.