Jump to content
Sign in to follow this  
seanhite

FileMakers prebuilt Work Requests Application

Recommended Posts

I purchased FileMakers prebuilt FM Work Requests Application on Filemakers Presales statements (and FM website info) that the FM Work Requests Application could be served via IWP via FM 7 Server Advanced.

The FM Work Requests Application Users Guide says the app can be served via FMNet and/or IWP via FM 7 Server Advanced.

Yet much to my surprise, the FM Work Requests Application can NOT be served via FM 7 Server Advanced via either FMNet and/or IWP. The app shows "missing field" and the Icons/buttons do not display correctly.

I contacted FM Tech Support and they indeed verify that the FM Work Requests Application can NOT "out of the box" be served via FM 7 Server Advanced. FM Tech Support says this is because some scripts in the FM Work Requests Application haven't been "optimized for FM 7 Server Advanced" (though the FM Work Requests Application works correctly out of the box when being shared via FM 7 Client via both FMNet and IWP). FM Tech Support could not tell me what script(s) would need to be "optimized" in order to get the FM Work Requests Application to work correctly via FM 7 Server Advanced.

Does anyone out there have experience with the FM Work Requests Application? How about experience with FM Work Requests Application running via IWP and/or FMNet via FM 7 Server Advanced?

IF yes, have you come up with a "work around" to get the FM Work Requests Application to work correctly via FM 7 Server Advanced? Do you know which script(s) need to be modified? What modifications need to be made?

Any ideas, hints, suggestions, vodoo, greatly appreciated.

Sean Hite

Share this post


Link to post
Share on other sites

If you turn on "Show compatible script steps" in the ScriptMaker, it will show you (by greying) the steps that are not compatible. It's just a matter of going through script by script.

Share this post


Link to post
Share on other sites

hayesk,

Are you speaking in "general" FM 7 terms, OR have you specifically looked at the FM Work Requests Application?

----------------------

The FM Work Requests Application has a "secondary" related file (fmw_Language.fp7) that is NOT accessible. FM did a very good job of locking down this secondary file. I believe this file is the "key" to the issue, but I am NOT able to get into it.

Thanks.

Sean Hite

Share this post


Link to post
Share on other sites

Regarding how to access and modify the "fmw_language.fp7" file in the FileMaker Work Requests app - this had me stumped for a bit, then i found the answer on page 69 of the user's guide.

This is all you have to do - first open the "FileMaker Work Requests.fp7" file, then from the FileMaker windows menu, select Show Window then select fmw_Language. The window opens, and whenever that window is on top, you can manage the database and everything else in the file.

Hope that helps someone in the future, might save a couple hours of dev time that I wasted LOL.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By Tony Morosco
      I'm a botanist, and the tables I am working with are for tracking botanical garden collections. The data represents plants in the garden, and the plants are tagged and show up in the database.  The tables I am working with were created in FMP 7, and I'd like to open them up in FMP 11 (or later.)  The system hasn't been used in years, but still has valuable information.
      One of the tables is giving me problems using the FMP convert and recover commands.
      These tables are all inter-related.  The main table is the Accessions table, which contains records for all of one kind of plant, from the same source, received on the same date.  It is basically a museum standard.
      The other tables are related to each other through this one main table.  The Species table is related to the locations table through the Accessions table. 
      (i.e.  table A relates to table C through the table B, the intermediary)  
      From the Locations table, we can't see the the species information unless the accessions table is present.
      When issuing the open command on the main table to convert the database to FMP 11, I get the message:
      "Accessions.fmp7" is damaged and cannot be opened.  Use the Recover command to recover this file. When using the Recover command from v. 11, I get another message:
      WARNING: problems were detected while recovering the database.  Please review the Recover.log file to see where problems were found and their severity.  The recovered file should NOT be used going forward; copy only the most recent work from it into a backup copy of the original file. Recovery results:   File blocks: scanned and rebuilt 563 blocks, dropped 214 invalid data blocks.   Schema: scanned fields and tables, 1 items modified   Structure: scanned; 1 items modified   Field indexes: rebuilt  
      Opening the recovered database, there are only three records present.  There should be hundreds.  So obviously I am looking on how to wrangle this database open.
      I've attached the log file here, as well as the database structure map.  
      The other files have converted just fine.  But since the main table won't open, we are kind of stuck.
      I can share the files with you through Dropbox or whatever, if needed.
      Please let me know any thoughts you have, either basic or advanced.  And ask for any clarifications or additional questions.   :-)  
      Thanks!
      -Tony
      Recover.log

    • By Tumma K
      Hello, All!

      I am an aspiring developer for Filemaker. The company I work with is stuck in the past working off of Filemaker Pro 4.1

      I was given the task of bringing us up to Filemaker Pro/Server 13. So far my conversion prototypes are successful but we recently had a layout issue that can only be fixed in versions 3-6 (as the file is an .fp3) I work off of a macbook while our network is all Windows 7. In order for me to repair the layouts without tampering our active database, I decided the best option is to repair a copy of our solutions off the network. Unfortunately, when I go to download the trial version of Filemaker Pro 6 off of the respected website, the file is corrupt! I've tried multiple times, with different extraction apps and in different directories.

      My question is;

      Does anyone know a place where I could obtain version 6 (or better yet, 4.0) for an OSX computer? I've looked everywhere!
       
      Thank you for your time,
      Tumma K.
    • By MrEddByrnes
      I'm hoping my question can have a happy ending. In the mid-90's, I purchased Filemaker 3. When Filemaker 5.5 Pro was released, I bought the update CD, which requires the user to either have FM 3 installed or to have the installation CD for FM 3. I've used it all these years, most recently with Windows XP Pro, and it has worked just fine. The databases I began with were long ago converted to FM Pro 5.5 databases.
       
      I'm still using FM Pro 5.5 on a laptop with WinXP Pro, but in 2013, I purchased a PC with Windows 8. I haven't been able to install FM 3 on it, therefore can't install FM Pro 5.5. I am retired and rarely use Filemaker, but I have a few Filemaker databases I'd like to add to my Win 8 machine. I don't feel it's worth upgrading FM for the sake of using a couple of databases.
       
      Has anyone else run into this situation and/or have a (possible) solution? Is there perhaps any other software that can read FM 5.5 databases? Thanks in advance for your help.
       
    • By bmill
      I am using a custom filemaker solution for medical office billing written with fp5 running on a mac with snow leopard. In addition, I have a patient management db (which I wrote) that is linked through pt. ID number to the billing program allowing transfer of some demographic information (name, DOB, etc).
       
      Other than being limited by hardware restrictions, the billing program serves our needs for now and upgrading to fp12 will take some time (and money).  In the meantime, I am upgrading my pt. management program to fp13 and would like to move new patient demographic information from the billing program ( fp5 running on snow leopard through Parallels) and the new pt management program ( fp13 running on OS X 10.9) on the same mac.   
       
      Ideally, demographic information would be entered once into fp5 and then a scipt would make the data available for fp13.
       
      Any ideas on how to make this work?
    • By randyinla
      Hi, can anyone tell me why my on-line database might have stopped allowing me to delete records?  All of my access privileges and passwords are correct.
       
      thanks!
  • Who Viewed the Topic

    6 members have viewed this topic:
    beckham  Karsten Wolf  Punith baskar  soundsessential  ggt667  Joost Miltenburg 
×

Important Information

By using this site, you agree to our Terms of Use.