Jump to content
Sign in to follow this  
jeffer

got it working...?

Recommended Posts

...then you will get a medal of honor from me!

Installation of the server and the web publishing engine is piece of cake. But configuring the whole thing is a new thing for filemaker developers. Some of us just don't have the knowledge for configuring web services on a server. The manuals are quite fine, but basicly it all boils down to references to other manuals that refer you 'again' to another manual. confused.gif

I'm trying to get one test database available to the web trough the filemaker server advanced solution, but it just doesn't work. Sometimes the server hosts the xsl files, and another moment you can't connect to the web publishing server at all, even not with the site assistant. I just don't know what I'm doing wrong and as you can make up, it irritates me.

So, if someone here got it working...maybe some kind of guide is welcome stuff around the community?

greetz,

Jeffrey

Share this post


Link to post
Share on other sites

Here is what I have got working so far.

In FileMaker server admin, go to the configure tab. Choose to add a FileMaker Web publishing Engine. For the Identifier and Passcode, enter anything you want. For this example, lets user 'hair' and 'bear'

If you are using OSX, make sure web sharing is on and running.

Next go to the following URL in your web browser:

http://localhost/fmi/config

First thing you will be asked to do is enter a console username and password. Make these up. These will be your admin information for anytime you want to use the web console.

Next thing you will want to do is set up the address, web publishing identifier, and web publishing passcode. For the address, use localhost (assuming advanced is running on the same machine as server). For Identifier and Passcode, enter the same ones you entered in FileMaker server admin. In this case it is 'hair' and 'bear'

Hit the 'Commit' button at the bottom of the page. You may also have to hit the 'Restart Publishing Engine' button at the bottom of the page.

Go to publishing engine tab, enable the settings you want running.

Go back to the FileMaker Server tab, then choose the link for published databases. If you have set up your databases correctly in the admin tool, you will see them in the list here.

This is basically the steps I took to get it all running.

One thing that I have found to be tricky, and that is setting up the priv. in the actual FM database files correctly. Do this carefully using FMPro. make sure permissions are turned on correctly for either instant web publishing or XML publishing.

As far as getting the XML to work, I cant completely attest to that. I am working on using Lasso to access FMSA and serve up the data. I am finding LDML is close enough to using CDML that I dont have to completely start over if I had to use XML. So far I am getting Lasso to serve up my test FMSA pages. And since Lasso uses FMSA's XML to communicate with the database, that means the FMSA XML is working.

Larry

Share this post


Link to post
Share on other sites

"In FileMaker server admin, go to the configure tab. Choose to add a FileMaker Web publishing Engine. For the Identifier and Passcode, enter anything you want. For this example, lets user 'hair' and 'bear'"

I don't have a configure tab?? (Yes I have adv server...)

Share this post


Link to post
Share on other sites

Potz you need to look for something call Client something.

It's with JDBC / ODBC where u can add web publishing engine.

Right click -> on the server admin (server) and choose properties.

Windows...

Share this post


Link to post
Share on other sites

Hit the 'Commit' button at the bottom of the page. You may also have to hit the 'Restart Publishing Engine' button at the bottom of the page.

Hitting that button gets me an unexpected error. So I restarted the service manually.

Go to publishing engine tab, enable the settings you want running.

Go back to the FileMaker Server tab, then choose the link for published databases. If you have set up your databases correctly in the admin tool, you will see them in the list here.

Yeah... can't get this far as it always kicks back sayign my user name or password is invalid, even when it exists in the server admin, and I even created a local administrators accoutn for good measure.

Share this post


Link to post
Share on other sites

Bloody problem happened to me during my first try.

1) Reinstall the IIS

2) Reinstall the Filemaker Advance (uninstall first)

3) Make sure that all the server is serving is only FMAdvance

4) Filemaker Server must be same server

5) Filemaker Server must have add client (webpublishing)

6) Filemaker Advance must point to localhost (127.0.0.1)

7) Try remember your identifier name and password (call it same as your machine name including password just in case

Share this post


Link to post
Share on other sites

How to go crazy in 5 easy steps!

I am having the same issue on win2ksv4.

I understand setting the identifier and Passcode in the 'enable client services' dialog box. that is not the issue.

after I do a clean install

Share this post


Link to post
Share on other sites
Guest

Try using a passcode with no special characters on the FM server on the client id

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.