Jump to content

Import =Total records skipped due to errors


This topic is 6606 days old. Please don't post here. Open a new topic instead.

Recommended Posts

For the past 3 months I've been creating/building a fairly complex solution, importing and creating single records as I go along using FP7 DEV. I'm suddenly no longer able to import with this particular solution. I have not had need to import for over a month, so I do not know when this function ceased.

All other solutions I have continue to import flawlessly. Someone suggested I upgrade to v3 and I did so right away. After upgrading I still can create one new record at a time but just like before, every attempt I make to import any set of records with this ONE solution results in the following window:(the record number changes depending on the number of records in the file I attempt to import)

Total records added / updated: 2063

Total records skipped due to errors: 2063

Total fields skipped due to errors: 0

So my situation is that this ONE solution I created will no longer import. It goes thru the motions of import only. All other solutions will import records with no problem.

No data type whatsoever can presently be imported into this particular solution. I've tried 7 different files, varying in record size. I've tried as little as 10 records to import. Regardless of what type or size of file I attempt to import, the "next" serial number available increases by exactly the number of records in the file I'm attempting to import.

"Total records skipped due to errors" - in my situation this line must refer to something in this solution only and not to the Filemaker program itself as other solutions I have will import the exact same file.

I am presently attempting to save a clone of this solution so that I will not have to recreate everything but the clone file will not import either and neither will recent back ups of the solution. (I back up daily saving an exact copy in a different directory) I found a back up from over a month ago that will import fine but so many changes and additions have been made since then.

Thank you for taking time to read all this. ANY suggestions, any thoughts as to how to correct this or how to save the solution having it able to import would be beyond helpful.

Link to comment
Share on other sites

I edited my original post to include more detailed specifics. I have the latest upgrade now but my original database was created with DEV 7.0v1 (the one with import bugs) and I have used at least 7 different types of files for import ranging in size from 10 records to 10,000 records. They all import into other solutions flawlessly but not this one. I've attempted all versions of DEV 7.0 but none allow this database to import.

Link to comment
Share on other sites


FileMaker 7 imports records, followed by the display of the Import Records Summary dialog. This dialog will show if any records were skipped during the import process. If records were skipped, check the validation options selected for each field to determine if any constraints were violated. A common cause of skipped records includes having FileMaker 7 fields configured with the "Not Empty" attribute. If a particular field is empty in the Access database and its validation attribute is set to "Not Empty", then the entire record will be skipped when it is imported into FileMaker 7.

I found the above little tid-bit of information here:


Such WAS the case in my database.....I removed the "Not Empty" attribute and Voila'....import was done flawlessly.

Link to comment
Share on other sites

This topic is 6606 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.