Jump to content

Importing date goes wrong


Toni
 Share

This topic is 5701 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Hi every one.

This is the first time I'm having troubles with importing data into a filemaker database.

I'have configured a script for importing from a tab-separated text file in filemaker 4.1. In this file there are two date fields. When I changed into FM6 the import goes wrong. The dates are in european format dd/mm/yyyy. When they are imported they go in american format mm/dd/yyyy. Of course I have imposted FM to work with system dates which are dd/mm/yyyy. Now this is causing some trouble since one of this dates indicates me the deadline.

Example:

text file --------------field in FM

10/02/2006--------------02/10/2006

In other cases of importing it would import it correctly but strangely will not do the sort correctly.

Example:

filed sorted in FM ascending

20/02/2006

20/01/2006

Any help on this please?

Thank you Toni

Edited by Guest
Link to comment
Share on other sites

Ok, I looked deeper today what the trouble could be.

I do have records in the database with the correct import (suppose imports done before changing into FM6) and some others which have the wrong date imported. I selected two of them and then exported into txt file. After that I imported into Excel the data in the .txt file. And what do I see!

The record with correct data had it in the MM/dd/yyyy format and the incorrect one had it in dd/MM/yy format. Very strange. I have the feeling sth. wrong with the settings of FM, but can't get which one.

Has it anything to do with the "character set" option during import? You know, the drop-down menu with Ansi, Lotus etc. option?

Looking forward to an answer, Toni

Link to comment
Share on other sites

Finally, I did found the problem.

I was importing the data into a share database. I open this as remote from my PC. Today i copied the database into my PC and did a test. It went fine. Hmm, I know i do configure all the regional settings into the network the same way, so it going wrong? I checked the regional settings of the master PC (where the database resides). This PC has Windows XP Service Pack 2 installed. The configuration of regional settings was ok, the date was configured as

dd/mm/yy

But there was sth. which I noticed. There is a drop-down menu from where you can select a country to match your your criteria of regional settings, or you can customize these settings. That's what I have always done, customize them. In this drop-down menu it was selectd "English UK". Well i changed it, I choose Italy. Restarted FileMaker, and there it is. The date is now correct. Hua! But I have always thought that the customize settings will override those in the drop-down menu. In this case they didn't. So i think this is a problem related to FM not to Windows, because in other applications things go ok.

What do you think? Thanks Toni

Link to comment
Share on other sites

This topic is 5701 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.