Jump to content

GTRR inconsistent behaviour


mav
 Share

This topic is 5713 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Here's the set up . . .

Our database has multiple 'buttons' with various scripts attached to each, and there is only one script step in each - which is GTRR Showing only related records matching current record only. The related record and button is being displayed in a portal.

Here's the fault . . .

Click on the button and the user is taken to the first layout, and to the most recent record on the layout they had visited. No error given to the user about not being able to 'reach' the layout due to permissions - I have seen this one before.

Unfortunately, this is not a repeatable fault . . .

This can happen to any one of five users just once in a month, or even twice in a row for the same button, and then not for months - it has not happened to me personally, although I'm using FM Advanced 8.0v2 and I'm not navigating as much as the users are. All other users are Mac OS X 10.3.9 FM 8.0v2 networked from a Mac OS X 10.3.9 FMS 8.0v2.

The script step shows the correct layout, not as mentioned my others on these forums.

Any thoughts ?

Link to comment
Share on other sites

Søren means that the field on one side of the realtionship is not the same typ as on the other -- usually one is text and the other is number.

The only other time I have seen similar weirdness happen is in FMP 6 when the relationship has a sort order defined, and the sort order includes a field that has been deleted.

If the file was used with FMP 8.0v1 or FMS 8.0v1 I'd also suggest indexes may be corrupted. This is reasy to fix -- turn off indexing, then turn it back on again.

Link to comment
Share on other sites

Thanks for point out what Soren means regarding the keys. All of my primary and forgeign keys are text.

As for the index being corrupt, the file did begin as a FMP 8.0v1 file. Are you suggesting turning indexes off and then on again for every key field ?

Do I need to do a search within each key field after turning the index back on to rebuild the index ?

Link to comment
Share on other sites

This topic is 5713 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • By Tumma K
      Hello, All!

      I am an aspiring developer for Filemaker. The company I work with is stuck in the past working off of Filemaker Pro 4.1

      I was given the task of bringing us up to Filemaker Pro/Server 13. So far my conversion prototypes are successful but we recently had a layout issue that can only be fixed in versions 3-6 (as the file is an .fp3) I work off of a macbook while our network is all Windows 7. In order for me to repair the layouts without tampering our active database, I decided the best option is to repair a copy of our solutions off the network. Unfortunately, when I go to download the trial version of Filemaker Pro 6 off of the respected website, the file is corrupt! I've tried multiple times, with different extraction apps and in different directories.

      My question is;

      Does anyone know a place where I could obtain version 6 (or better yet, 4.0) for an OSX computer? I've looked everywhere!
       
      Thank you for your time,
      Tumma K.
    • By MrEddByrnes
      I'm hoping my question can have a happy ending. In the mid-90's, I purchased Filemaker 3. When Filemaker 5.5 Pro was released, I bought the update CD, which requires the user to either have FM 3 installed or to have the installation CD for FM 3. I've used it all these years, most recently with Windows XP Pro, and it has worked just fine. The databases I began with were long ago converted to FM Pro 5.5 databases.
       
      I'm still using FM Pro 5.5 on a laptop with WinXP Pro, but in 2013, I purchased a PC with Windows 8. I haven't been able to install FM 3 on it, therefore can't install FM Pro 5.5. I am retired and rarely use Filemaker, but I have a few Filemaker databases I'd like to add to my Win 8 machine. I don't feel it's worth upgrading FM for the sake of using a couple of databases.
       
      Has anyone else run into this situation and/or have a (possible) solution? Is there perhaps any other software that can read FM 5.5 databases? Thanks in advance for your help.
       
    • By bmill
      I am using a custom filemaker solution for medical office billing written with fp5 running on a mac with snow leopard. In addition, I have a patient management db (which I wrote) that is linked through pt. ID number to the billing program allowing transfer of some demographic information (name, DOB, etc).
       
      Other than being limited by hardware restrictions, the billing program serves our needs for now and upgrading to fp12 will take some time (and money).  In the meantime, I am upgrading my pt. management program to fp13 and would like to move new patient demographic information from the billing program ( fp5 running on snow leopard through Parallels) and the new pt management program ( fp13 running on OS X 10.9) on the same mac.   
       
      Ideally, demographic information would be entered once into fp5 and then a scipt would make the data available for fp13.
       
      Any ideas on how to make this work?
    • By randyinla
      Hi, can anyone tell me why my on-line database might have stopped allowing me to delete records?  All of my access privileges and passwords are correct.
       
      thanks!
    • By randyinla
      Hi, I still use filemaker 5.5 and am very happy with it and don't want to upgrade.  Does anyone still host filemaker 5.5?  Thanks!
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.